FORUMS
Remove All Ads from XDA

[GUIDE] Dualboot Custom ROMs on L5 and L7

840 posts
Thanks Meter: 809
 
By Caio99BR, Senior Member on 22nd December 2015, 02:44 AM
Thread Closed Email Thread


Informations

Hey guys, today i will show DualBootPatcher one of the best apps for multi ROMs (i think this is the unique app for this :P).
I have managed to support L3II, L5, L7 and L7II (Officially)
I am not the creator, just the supporter
XDA NEWS!!!

Disclaimer

Your warranty is now void.
I am not responsible for bricked devices, dead SD cards, thermonuclear war, or you getting fired because the alarm app failed. Please do some research if you have any concerns about features included in this ROM before flashing it! YOU are choosing to make these modifications, and if you point the finger at me for messing up your device, I will laugh at you. Hard. A lot.


Requirements

1. A Custom Recovery (TWRP or PhilZ Touch or the old CWM :P)
2. A KitKat ROM (Real KitKat ROM, not build.prop edited, a fake KK ROM)
3. The Dualboot Patcher - http://goo.gl/0bcbbN (Download the APK in Downloads Section)(For L3II, L5, L7 and L7II)
4. A KitKat ROM (To install :P)


Installation

1. Make a nandroid backup in case anything fails. (optional if you like playing with fire)
2. Install the DualbootPatcher
3. In the Patcher, go to the ROMs section, and a popup will ask you to set the kernel. Do it.
4. After this you need to go in menu (the tree dots) of Primary ROM and search for Update Ramdisk. Press it.
5. In the patcher, go to the Patch ZIP file section, open your ROM zip file
6. After this select in what partition you want to install:
Primary ROM Upgrade - To update ROM without affect the Secundary ROM (and others) when you have one installed.
Secundary - To install in /system.
MultiROM (1-3) - To install in /cache, you have 3 slots in this.
Data Slot - To install in /data (ID is IDentification of ROM)
Extsd slot - To install in your sdcard
7. You not need to change the Device
8. Do the same for GAPPS (optional)
9. Press in confirmation button and wait.

You have two options here:
9. Go to ROMs section and press in button of a device with arrow inside, select the patched zip files (ROM and GAPPS), and by last press in confirmation button, just wait..
10. After finish, close the app (see Know Issues), open and go again to ROMs section and you will see the default ROM to boot (the last installed). Reboot your phone.
11. It will now boot onto your ROM installed, once you've completed your first boot setup, install the DualBootPatcher.
or
9. Restart in recovery, flash the patched zip files (ROM and GAPPS). Restart your phone.
10. It will now boot onto your ROM installed, once you've completed your first boot setup, install the DualBootPatcher.

You are now able to select which rom to boot from the ROMs section. Once you've selected which rom is the default, restart your phone. Voilà!


Know Issues

- The ROMs section sometimes bug and get a infinite refresh, close the app and open app again.
- Never use this in JellyBean 4.1 or "You are gonna have a bad time"
- Contact me


Special Thanks

@chenxiaolong for the awesome DualBootPatcher.
@virulentt for him original thread for tutorial (and encouragement)
@Jonas Cardoso for testing in L5
@WinterR for testing in L7
@ECr34T1v3 for testing in L3II


ScreeShots



The Following 5 Users Say Thank You to Caio99BR For This Useful Post: [ View ] Gift Caio99BR Ad-Free
 
 
22nd December 2015, 03:06 AM |#2  
virulentt's Avatar
Senior Member
Flag Montreal
Thanks Meter: 434
 
More
Thanks for the mention
23rd December 2015, 09:38 PM |#3  
Caio99BR's Avatar
OP Senior Member
Flag São Paulo
Thanks Meter: 809
 
More
@WinterR test the unofficial snapshot, please :P
26th December 2015, 01:12 PM |#4  
What about different kernel and not the one from rom's zip? Better to add them to zip before patch or can be installed later by patching kernel's zip?

Or there can be only one kernel for all roms?

Sent using XT1562 - stock 5.1.1
28th December 2015, 12:57 AM |#5  
Caio99BR's Avatar
OP Senior Member
Flag São Paulo
Thanks Meter: 809
 
More
Quote:
Originally Posted by ch3mn3y

What about different kernel and not the one from rom's zip? Better to add them to zip before patch or can be installed later by patching kernel's zip?

Or there can be only one kernel for all roms?

Sent using XT1562 - stock 5.1.1

For kernels you need to flash two times, first flash with patched zip (in app) and second flash you need to set the ROM and flash again (via recovery).

The first will update modules (/system) and second is to update the boot.img

Note: Ever you change kernel you need to go to app and set the kernel to save you new boot.img
7th January 2016, 01:23 AM |#6  
Caio99BR's Avatar
OP Senior Member
Flag São Paulo
Thanks Meter: 809
 
More
Now DualBootPatcher supports the L7 and L7II!!!
The Following User Says Thank You to Caio99BR For This Useful Post: [ View ] Gift Caio99BR Ad-Free
22nd January 2016, 07:06 PM |#7  
I got some time and would like to check it out.
I can only use 4.4.4 roms (on L7 there are no newer ones)?
How it works with sdext? Is it used as both /system and /data? Or just /system? But than where is nonprimary rom /data located?

PS. What file systems are supported by app? Or maybe it depends on kernel?
22nd January 2016, 07:28 PM |#8  
Caio99BR's Avatar
OP Senior Member
Flag São Paulo
Thanks Meter: 809
 
More
@ch3mn3y you can use all ROMs up to 4.2, because SELinux and other core things like storage/emulated/0.
The SdExt only store system.img, and only system (for now, the patch is under progress all time).
You have option to put 1 in /system (dual), 3 in /cache (multi-slot), and unlimited in /data and /sdext (External Card).
Support F2FS and Ext4, auto-detect, just need support in your ROM and all will works (not tested because no F2FS support for mine device :P)
The Following User Says Thank You to Caio99BR For This Useful Post: [ View ] Gift Caio99BR Ad-Free
22nd January 2016, 10:14 PM |#10  
So I tried to mod cyanhacker 2.0 to work from extsd, but app FC's at 1.4%. Tried last 8.0.0. Anyone know which one works with our device or this rom (don't know which one cause FC)?
22nd January 2016, 11:34 PM |#11  
Caio99BR's Avatar
OP Senior Member
Flag São Paulo
Thanks Meter: 809
 
More
Quote:
Originally Posted by ch3mn3y

So I tried to mod cyanhacker 2.0 to work from extsd, but app FC's at 1.4%. Tried last 8.0.0. Anyone know which one works with our device or this rom (don't know which one cause FC)?

The rom is stored in any partition in a folder called "multiboot", try other rom or old app versions.

Enviado de meu E435 (L3 II Dual) usando Tapatalk
The Following User Says Thank You to Caio99BR For This Useful Post: [ View ] Gift Caio99BR Ad-Free
Thread Closed Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes