Remove All Ads from XDA

[ROM][4.4.4] LineageOS 11.0 for LG Optimus One [OS2SD][18/03/06]

236 posts
Thanks Meter: 1,664
By HardLight, Senior Member on 26th July 2014, 09:10 AM
Post Reply Email Thread
28th June 2017, 12:47 AM |#441  
ibub's Avatar
Senior Member
Flag Louisville,Ky
Thanks Meter: 1,517
Originally Posted by bikeride34

This does, however, reflect the order that I created the partitions in GParted. I started with a 7 GB partition at the beginning, next a 7 GB partition at the end, and finally the two in the middle. I didn't think that would have an effect on things. Plus, doesn't it vary from system to system whether a partition is shown as /dev/sda1 or /dev/sda2? I was expecting that phone would put the first partition on the disk as /dev/mmcblk0p1, the second as /dev/mmcblk0p2, etc... Why would it not do that?

Rebooted the phone, apps I downloaded are still on there. Data is persistent, on the second partition of the sdcard. Maybe the partition scheme the installer expects has changed from OP? /system on the first partition, /data on the second, swap on the third and /sdcard at the end?

Also, to confirm, is the sdcard partition supposed to be FAT32 or VFAT?

Yeah, It looks as if the partitions were numbered in the order that they were created. My fat partition is listed in twrp as vfat.

Sent from my LGL15G using Tapatalk
5th July 2017, 10:08 AM |#442  
HardLight's Avatar
OP Senior Member
Thanks Meter: 1,664
Arrow LineageOS 11.0
20170704 build uploaded!


- Android Security Patch Level: May 1, 2017
- LineageOS boot animation

Android File Host | XDA
The Following 10 Users Say Thank You to HardLight For This Useful Post: [ View ] Gift HardLight Ad-Free
18th July 2017, 10:20 PM |#443  
HardLight's Avatar
OP Senior Member
Thanks Meter: 1,664
Arrow LineageOS 11.0
20170718 build uploaded!


- Android Security Patch Level: July 1, 2017

Android File Host | XDA
The Following 10 Users Say Thank You to HardLight For This Useful Post: [ View ] Gift HardLight Ad-Free
26th July 2017, 11:59 AM |#444  
Junior Member
Thanks Meter: 2
6th October 2017, 08:58 PM |#445  
Junior Member
Thanks Meter: 0
open gapps problem
Guys i cant flash with , any idea , 1 am on 1 GB sdcard (lol) .
_____ _____ ___ ____
/ _ \ | __ \ / _ \ | _ \
| / \ || |__) | |_| || | \ \
| | | || ___/| __/ | | | |
| \ / || | \ |__ | | | |
\_/ \_/ |_| \___| |_| |_|
___ _ ___ ___ ___
/ __| /_\ | _ \ _ \/ __|
| (_ |/ _ \| _/ _/\__ \
\___/_/ \_\_| |_| |___/

Open GApps pico 4.4 - 20171006

- Mounting /data /system

- Gathering device & ROM information

awk: /system/etc/permissions/ No such file or directory
awk: /system/etc/permissions/ No such file or directory
* Incompatible GApps Currently Installed *

This Open GApps package can ONLY be installed
on top of an existing installation of Open GApps
or a clean AOSP/CyanogenMod ROM installation,
or a Stock ROM that conforms to Nexus standards.
You must wipe (format) your system partition
and flash your ROM BEFORE installing Open GApps.

******* GApps Installation failed *******

- Copying Log to /sdcard

- NO changes were made to your device

Installer will now exit...

Error Code: 40
cp: can't stat '': No such file or directory
cp: can't stat '/system/default.prop': No such file or directory
cp: can't stat '/data/local.prop': No such file or directory
cp: can't stat '/build.prop': No such file or directory
- Unmounting /data /system

Updater process ended with ERROR: 40
I:Legacy property environment disabled.
Error installing zip file '/sdcard/'
Updating partition details...
9th November 2017, 07:06 PM |#446  
niral.naik's Avatar
Flag Bharuch
Thanks Meter: 10
Wanna sell LG p500 call me +91-9429992192
10th November 2017, 07:20 PM |#447  
HardLight's Avatar
OP Senior Member
Thanks Meter: 1,664
Arrow LineageOS 11.0
20171108 build uploaded!


- Android Security Patch Level: October 1, 2017

Patched 'KRACK' (Key Reinstallation Attacks) WPA/WPA2 vulnerability
Patched 'Cloak and Dagger' accessibility service vulnerability
Patched Dnsmasq vulnerability (CVE-2017-14496)
Other security and stability fixes

TWRP 3.1.1


What's new in 3.1.1-0:

  • Backups will now include adopted storage keys (Dees_Troy)
  • Fixed an adb restore issue (bigbiff)
  • Fixed rebooting when no OS is present (Dees_Troy)
  • Fixed line wrapping in the GUI terminal (_that)
  • Updated TWRP source code to AOSP 7.1.2 (Dees_Troy)Updated TWRP source code to AOSP 7.1.2

What's new in 3.1.0-0:
  • vold decrypt on a few select HTC devices, TWRP will now attempt to use the system partition's vold and vdc binaries and libraries to decrypt the data partition (nkk71 and CaptainThrowback)
  • adb backup to stream a backup directly to or from your PC, see documentation here (bigbiff)
  • tweak MTP startup routines (mdmower)
  • support new Android 7.x xattrs for backup and restore to fix loss of data after a restore (Dees_Troy)
  • support POSIX file capabilities backup and restore to fix VoLTE on HTC devices and possibly other issues (Dees_Troy)
  • better indicate to users that internal storage is not backed up (Dees_Troy)
  • improve automatic determination of TW_THEME (mdmower)
  • minimal getcap and setcap support (_that)
  • try mounting both ext4 and f2fs during decrypt (jcadduono and Dees_Troy)
  • shut off backlight with power key (mdmower)
  • timeout during FDE decrypt (Dees_Troy and nkk71)
  • support for FBE decrypt and backing up and restoring FBE policies (Dees_Troy)
  • boot slot support (Dees_Troy)
  • TWRP app install prompt during reboot (Dees_Troy)
  • support for AB OTA zips (Dees_Troy)
  • support new Android 7.x log command (Dees_Troy)
  • update recovery sources to AOSP 7.1 (Dees_Troy)
  • numerous bugfixes and improvements by too many people to mention

Android File Host | XDA
The Following 9 Users Say Thank You to HardLight For This Useful Post: [ View ] Gift HardLight Ad-Free
15th November 2017, 04:15 AM |#448  
Junior Member
Thanks Meter: 2
Originally Posted by HardLight

20171108 build uploaded!

This is really brilliant.

My new phone went for a saltwater swim so I fired up my old LGP500 and decided to install CM, found this thread with LineageOS still being updated, installed the MULTI TWRP and flashed this ROM.

I'm not 100% certain that I partitioned the SD correctly because it complained about /data while installing, but GParted showed all the correct partitions in the correct order, and it booted fine. In Settings->Storage I don't see any management options for SD-EXT, but it all seems to be running fine so far.

Next step: getting GAPPS / microG and some useful apps installed.

Could you update the first post with latest GAPPs link and maybe some words of wisdom/experience with the switch to microG? My previous phone was still in support so the Play Store worked just fine.

A different CM11 ROM I flashed came with GAPPs and I was able to log in, get my contacts, but everything in the Play Store complained about compatibility. So any ideas re: alternate appstore or comments about microG plus sideloading would be great... I realise you don't get many new users any more but you never know maybe others will migrate here from other CM11 ROMs and seeing that they can get access to some working apps would probably encourage them.
15th November 2017, 06:04 AM |#449  
Junior Member
Thanks Meter: 2
Going from locked Froyo LG P500 to LineageOS 11.0
Here's my experiences in a nutshell moving from LG P500 with Froyo (old baseband) to Hardlight's LineageOS 11.0:

I made progress in three leaps. The first leap was getting rooted and getting Recovery installed.

1) Install Rom Manager from Google Play.
2) Use adb to sideload One-Click-Root, or copy it to the SD card and used a file manager to install it.
3) Run one-click-root and get Superuser

Now the benefit of experience. While you're here, open a shell from Superuser and copy the following files from /system/lib to /sdcard:,, and These files will come in handy later if you want your mobile calling/data/sms features to work.

4) Run Rom Manager and install ClockworkMod Recovery. Ignore everything it says about TWRP.
5) Select Boot to Recovery. Congrats you are in ClockworkMod

The second leap was trying several ROMs and finding out what's good and bad about them.

I tried several ROMs. I tried a gingerbread one first and found that like with Froyo I couldn't use Google Play, but I could sideload some gingerbread apps.

Next I tried CM10 and CM11. Various ROMs that had youtube demos, all looking a lot smoother than they were in reality, probably because the developers pegged the CPUs at a high overclock for the purposes of the demo, and didn't demo any real apps... just navigation and settings. The reality (broken Play Store, glitches in Status, terrible slowdowns) was very disappointing and I returned to Froyo for 2 months, with an occasional attempt at a different ROM that promised to provide a better experience.

I had seen LineageOS early on and I didn't want to give it a try because it seemed like a LOT of work to set it up, and running off the SD card seemed like a pretty bad idea from a stability point of view, not to mention that using the phone in USB-Storage mode was a favourite feature and that was obviously going to be impossible with the OS on the SD card. But over time I saw that all the ROMs were basically unusable without moving huge amounts of the software onto the SD card, so I wasn't going to be using USB-Storage mode regardless. So eventually I took the plunge, earlier today.

LineageOS 11.0 built by Hardlight seems to have solved almost every issue I had with the other ROMs. The wakelock is still there but the rate it burns the battery down at isn't quite so terrible. The phone doesn't double as a hand-warmer. Standby uses maybe a bit over 1% per hour, (vs 1% every 6 hours on Froyo with wifi active and gmail syncing) The camera is improved but slower, and I can run some apps I couldn't run on Gingerbread. But more importantly, it's been completely stable.

The third leap then, was installing Lineage. It's not as hard as it sounds.

First, you need TWRP. You can flash that from ClockWorkMod. Just download the 2.7.1 MULTI that Hardlight provided and put it on the SD card then fire up CWM and flash it. Job's done. The installation instructions say you need a version from 2016 or better, but the 2.7.1 worked fine.

Second, and before you flash LineageOS, back up your phone using TWRP, and then copy that backup off the SD card onto your computer. That way you can roll back to exactly how it is now if for some reason you're not happy. You'll be happy, trust me, but you'll be even happier having that security blanket.

Third, format the SD card and create the 4 partitions. I used a 32G Kingston UHS1 card that I got for $20. I made a 12G first FAT partition, then a 12G EXT4 partition, then a 500M SWAP partition, and lastly I gave the remainder (6.7G I think) to the F2FS Data partition.

After that I copied the latest LineageOS ROM onto the SD Card, along with the 3 libs, then flashed that and rebooted.

Wow it was seriously 10-20x faster to install than many of the other ROMs, and it booted in a tiny fraction of the time as well. It booted almost as fast as stock.

After setup I went straight to Settings->About Phone->Build Number, tapped 7 times to enable the Developer Menu, then I opened that and enabled Developer Mode and USB Debugging.

Then I went to the Terminal Emulator, 'su -' and copied the 3 libs from /storage/sdcard0 to /system/lib, and my mobile carrier came online.

The next part of my journey is still ahead: installing gapps, microG, and seeing what apps are available, stable, and have usable performance on this dear old indestructible plastic brick.

P.S. I figured out how to install the latest TWRP from the downloads link
Download both the latest, and Flash the .zip one and reboot to recovery, then click [install] and [image] to install the newest one. This was really confusing. Official TWRP zips lack the image file, and the latest here lacks the zip wrapper, lol... I'm sure there's instructions somewhere but they evaded my keen googling skills.
The Following User Says Thank You to linuxgeex For This Useful Post: [ View ] Gift linuxgeex Ad-Free
15th November 2017, 09:42 AM |#450  
Junior Member
Thanks Meter: 2
Going from locked Froyo LG P500 to LineageOS 11.0 - Part II
Okay, so I downloaded
o "unfortunately, the process has stopped" - while running setup.
o back button a few times, cancel google account setup steps, developer mode, performance, swap on, try again fingers crossed.
o "There was a problem communicating with Google servers. Try again later."
o Reboot, fingers crossed again.
o "Unfortunately Google Play Services has stopped" - before I can even get to the account settings. [ok] and proceed with account setup anyhow.
o "There was a problem communicating with Google servers. Try again later."
o Open browser, google search "lol cats" comes up fine.

Wipe all partitions, re-flash, try
o regular crashes after setup but at least it syncs my contacts.
o setup->apps->downloaded->uninstall updates, then disable both
o now phone is stable, but no play store.
o backed up, I'll try adding microG tomorrow.
15th November 2017, 10:33 AM |#451  
Senior Member
Thanks Meter: 65
Guys go directly for microG. Hardlight customed this rom hardly enough to get OS2SD, deodexed and patched with signature spoofing to get it ready for microG. Beyond that, he is always updating the rom with last android security patches. Do no hesitate. Check this thread completely, there are links to Marvin' s microG thread or simply google it here on XDA and follow strictly the instructions.
You'll need to clean flash everything. Get a good 16GB class 10 microSD.
For apps to get working you'll have to use a try/fail process one by one. Look for older versions and try until you get the one is working. Remember playstore apps developers are focused just on high end phones. Old phones have old processors and compatibility is not always checked.
That al said, Enjoy your tiny P500 old monster bring back to a real new life!

Enviado desde mi Galaxy Tab 2 mediante Tapatalk
The Following User Says Thank You to josehbermudez For This Useful Post: [ View ] Gift josehbermudez Ad-Free
Post Reply Subscribe to Thread

4.4.4, cm 11, optimus one, os2sd, p500

Guest Quick Reply (no urls or BBcode)
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes