FORUMS
Remove All Ads from XDA

[ROM][8.1] LineageOS 15.1 for P8 Lite

2,151 posts
Thanks Meter: 2,175
 
Post Reply Email Thread
Hi,



LineageOS 15.1 for Huawei P8 Lite (ALE-L21/23/02) & (CHM-U01/U03)

*** Beta Version ***

About
Code:
LineageOS is a free, community built, aftermarket firmware distribution of Android 8.1 (Oreo), which is designed to increase performance and reliability over stock Android for your device. LineageOS is based on the Android Open Source Project with extra contributions from many people within the Android community. It can be used without any need to have any Google application installed. Linked below is a package that has come from another Android project that restore the Google parts. Lineage OS does still include various hardware-specific code, which is also slowly being open-sourced anyway.
Working
Code:
* Touchscreen * Adb / Mtp * Audio * Boot * Internal/External storage * Wifi * NFC * Camera
Not Working
Code:
* RIL * Bluetooth * Sensors
Installation
Code:
* you must also have this recovery version installed : TWRP * go to TWRP and do a full wipe (system, data, cache, dalvik/art cache/cust) ! * install LineageOS ROM * boot the rom * reboot in TWRP and flash gapps and root (optional) * reboot system * Enjoy !!!
Update
Code:
* copy the new update of LineageOS to Internal/External Storage * reboot device to : TWRP * wipe cache & dalvik cache * install the new update of LineageOS * reboot to System * reboot system * Enjoy !!!
Download
Credits
@surdu_petru
@meticulus

Kernel Source: android_kernel_huawei_hi6210sft

Please support my work, it's very important! Thanks
DONATIONS

Regards !
Attached Thumbnails
Click image for larger version

Name:	photo_2019-05-09_16-51-36.jpg
Views:	864
Size:	72.2 KB
ID:	4756074   Click image for larger version

Name:	photo_2019-05-09_16-51-31.jpg
Views:	864
Size:	48.3 KB
ID:	4756075   Click image for larger version

Name:	photo_2019-05-09_16-51-34.jpg
Views:	860
Size:	46.1 KB
ID:	4756076  
The Following 24 Users Say Thank You to DarkJoker360 For This Useful Post: [ View ] Gift DarkJoker360 Ad-Free
 
 
9th May 2019, 03:50 PM |#2  
DarkJoker360's Avatar
OP Recognized Contributor
Flag Aradeo
Thanks Meter: 2,175
 
Donate to Me
More
Reserved

Some news about oreo: well as I can see it s pretty hard to have oreo stable as nougat but I won't give up on this, for now here is a test version. I hope to fix something more soon.

Off-charge is working!
The Following 15 Users Say Thank You to DarkJoker360 For This Useful Post: [ View ] Gift DarkJoker360 Ad-Free
10th May 2019, 08:06 AM |#3  
Junior Member
Thanks Meter: 0
 
More
thank's for your job😀

hi am I in Los 14.1 do I still have to wipe or can I just upgrade to 15?

what does sensors mean?

the magisk connection does not work
11th May 2019, 12:19 AM |#4  
_MartyMan_'s Avatar
Senior Member
Flag Budapest
Thanks Meter: 388
 
More
Thank you very much!
11th May 2019, 08:45 AM |#5  
Member
Thanks Meter: 11
 
More
Dayum, bro. You're amazing. Thanks for all your efforts keeping this device alive!

Sent from my Mi Max 2 using XDA Labs

---------- Post added at 08:45 AM ---------- Previous post was at 08:42 AM ----------

Quote:
Originally Posted by Canna77

thank's for your job😀

hi am I in Los 14.1 do I still have to wipe or can I just upgrade to 15?

what does sensors mean?

the magisk connection does not work

Well, it means that the gyroscope, proximity and the others are not going to work correctly or even not work at all.

Sent from my Mi Max 2 using XDA Labs
11th May 2019, 04:47 PM |#6  
Member
Thanks Meter: 16
 
More
dude I beleve in you, you can do it!

---------- Post added at 04:47 PM ---------- Previous post was at 03:59 PM ----------

also while trying to install it, error 7 and apperantly my device name is " ", basicly nothing, I know how to fix that but why does that happen?
11th May 2019, 05:00 PM |#7  
DarkJoker360's Avatar
OP Recognized Contributor
Flag Aradeo
Thanks Meter: 2,175
 
Donate to Me
More
Quote:
Originally Posted by ender1324

dude I beleve in you, you can do it!

---------- Post added at 04:47 PM ---------- Previous post was at 03:59 PM ----------

also while trying to install it, error 7 and apperantly my device name is " ", basicly nothing, I know how to fix that but why does that happen?

Remove ota assert
The Following User Says Thank You to DarkJoker360 For This Useful Post: [ View ] Gift DarkJoker360 Ad-Free
11th May 2019, 05:09 PM |#8  
Member
Thanks Meter: 16
 
More
Quote:
Originally Posted by DarkJoker360

Remove ota assert

yeah I did that, I am saying just in case its something wrong
edit: ok any idea with what to compress this, if I compress it with mi explorer I just get invalid zip format
12th May 2019, 09:06 AM |#9  
Member
Thanks Meter: 16
 
More
ok apperantly I have vendor image mismatch, i need huaweiale-l21 and I have it anyways who cares, RIL IS WORKING, I AM NOT JOKING, basicly it thinks my device is dualsim and my both sim cards are the same (cuz I am singlesim), I got in call, the voice was very high pitched and the other guy couldnt hear me, but when he called me everything was perfect, I can use my mobile data and I swear of god I am single sim (ale-l21), dude you did it! also I did a mustake with compresing my bad (the upper post I fixed it)
moreee edittt: when I restarted even when I called he hears me and I hear him, basicly RIL is working fine on single sim for me, I have no idea why but it also fixed my battery, yeah um ril is working on oreo.... dude thank you sooooo much
UPDATE: well that didnt last long, after a factory reset and gapps the rom saw that I use singlesim and ril stopped working, thats stupid....
UPTADE2: WTH after few restarts the phone started thinking I use dualsim again and it ril started working again, then the phone turns off without reason and starts offline charging, this rom is hell of a mess, also after every restart there was different senario, 1 - no sim in the phone, thinks its single sim, 2 - there is a sim in the phone but no singnal, thinks its single sim, 3 - there are 2 sims in the phone and both are same, thinks it dualsim, this rom is a mess, also it doesnt let me boot in the rom without getting me into offine charging (when its plugged in), the vendor image warning is still there is still there
The Following 2 Users Say Thank You to ender1324 For This Useful Post: [ View ] Gift ender1324 Ad-Free
12th May 2019, 09:47 AM |#10  
DarkJoker360's Avatar
OP Recognized Contributor
Flag Aradeo
Thanks Meter: 2,175
 
Donate to Me
More
Quote:
Originally Posted by ender1324

ok apperantly I have vendor image mismatch, i need huaweiale-l21 and I have it anyways who cares, RIL IS WORKING, I AM NOT JOKING, basicly it thinks my device is dualsim and my both sim cards are the same (cuz I am singlesim), I got in call, the voice was very high pitched and the other guy couldnt hear me, but when he called me everything was perfect, I can use my mobile data and I swear of god I am single sim (ale-l21), dude you did it! also I did a mustake with compresing my bad (the upper post I fixed it)
moreee edittt: when I restarted even when I called he hears me and I hear him, basicly RIL is working fine on single sim for me, I have no idea why but it also fixed my battery, yeah um ril is working on oreo.... dude thank you sooooo much
UPDATE: well that didnt last long, after a factory reset and gapps the rom saw that I use singlesim and ril stopped working, thats stupid....

This is a good news man !

Unfortunatly I wasn' t ever able to test ril here as my NVMO sim card isn' t recognized even on N.

Gonna investigate more ! Thanks so much
The Following User Says Thank You to DarkJoker360 For This Useful Post: [ View ] Gift DarkJoker360 Ad-Free
12th May 2019, 10:36 AM |#11  
Member
Thanks Meter: 16
 
More
Quote:
Originally Posted by DarkJoker360

This is a good news man !

Unfortunatly I wasn' t ever able to test ril here as my NVMO sim card isn' t recognized even on N.

Gonna investigate more ! Thanks so much

yeah it is actually, but it still loops from the senarios (sim/nosignal, nosim/nosignal, 2sim/signal), also I cant really say offline charging is good because when I get in it i need to reboot like 5 times to boot into system without the phone turning off, anyways seems good for now, I am going back to my lineage 14.1 for now, maybe after a update I will test again also any idea why is this vendor warn, also overheating is gone (on rros oreo there was a lot of overheating)
The Following User Says Thank You to ender1324 For This Useful Post: [ View ] Gift ender1324 Ad-Free
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Message:
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes