FORUMS
Remove All Ads from XDA

[ROM][Lineage 16.0 Unofficial][Pixel 2 XL/Taimen][06-09-19]

291 posts
Thanks Meter: 862
 
By calsurferpunk, Senior Member on 10th December 2018, 06:37 AM
Post Reply Email Thread
Hi all. Since I haven't gotten any word as to when there will be official support, I wanted to go ahead and share a build of Lineage OS 16.0 for our Pixel 2 XL/Taimen. It's a completely stock build. If it's working for enough people, then I'll continue to provide builds until/unless we get official support. If you find an error, please try to post logs via logcat to aid in fixing it (better yet to submit it to the Lineage OS team directly as well).

Lineage OS 16.0

Steps for First Install:
  1. Flash latest google image
  2. Boot using the latest version of TWRP: https://dl.twrp.me/taimen/twrp-3.2.3-1-taimen.img.html
  3. Wipe cache and data
  4. Flash latest ROM .zip file
  5. Flash the TWRP installer: https://dl.twrp.me/taimen/twrp-pixel...2.3-1.zip.html
  6. Reboot to recovery
  7. Flash OpenGapps (Android 9.0, ARM 64, probably nano): https://opengapps.org/ or MindTheGapps: https://androidfilehost.com/?fid=3700668719832237178
  8. If desired, flash a custom kernel
  9. If desired, flash Magisk
  10. Reboot and hopefully enjoy

Steps for Updates:
Follow steps 4- 10 above. You can skip steps 1 - 3 (latest Google image, booting with TWRP .img, wiping) and optionally 7 (flashing Gapps).

Latest ROM, 06-09-19:
Download

Old Releases:
Old Download

I usually like to provide updates every ~2 weeks or month to keep up with security updates and/or anything else important. Thanks for trying and God bless .

Special thanks to @draymond1987, @RaymanFX, and all the other developers for their continued hard work.

View changelog up to build date

/.repo/local_manifests/roomservice.xml is attached
Attached Files
File Type: xml roomservice.xml - [Click for QR Code] (1.1 KB, 190 views)
The Following 26 Users Say Thank You to calsurferpunk For This Useful Post: [ View ] Gift calsurferpunk Ad-Free
 
 
10th December 2018, 02:25 PM |#2  
calsurferpunk's Avatar
OP Senior Member
Thanks Meter: 862
 
Donate to Me
More
A quick note: If you seem to get stuck on the Gapps setup wizard, you can touch each corner of the screen, going clockwise, starting in the top left corner, to skip it. I've seen the data transfer tool have issues lately. You can uninstall it and continue afterwards.
The Following 4 Users Say Thank You to calsurferpunk For This Useful Post: [ View ] Gift calsurferpunk Ad-Free
10th December 2018, 03:32 PM |#3  
Member
Thanks Meter: 19
 
More
Any known bugs?
10th December 2018, 03:42 PM |#4  
calsurferpunk's Avatar
OP Senior Member
Thanks Meter: 862
 
Donate to Me
More
Quote:
Originally Posted by pimpdaddy00

Any known bugs?

I had an issue at some point where it would shut off when unplugged, but I don't know if it was just something about how my phone is setup. The other thing I encountered was the setup wizard getting stuck before (but fixed after removing the data transfer tool manually later). I'm hoping to see someone else have it working as I know at some point I was able to boot without issue, other than Magisk possibly not working without flashing another custom kernel. Getting any feedback from logs would helpfully tell me what changed and possibly where to fix it at that point.
The Following 2 Users Say Thank You to calsurferpunk For This Useful Post: [ View ] Gift calsurferpunk Ad-Free
11th December 2018, 04:49 PM |#5  
Senior Member
Thanks Meter: 89
 
More
I checked the channelog and noticed a few minor changes that seemed nice. Overall, I just hope Active Edge gets working in future ROMs lol. Though I know it's difficult. Good job on this!
The Following User Says Thank You to Darriousx For This Useful Post: [ View ] Gift Darriousx Ad-Free
16th December 2018, 05:09 AM |#6  
Senior Member
Thanks Meter: 500
 
More
Can't even get this to boot.
The Following User Says Thank You to LLStarks For This Useful Post: [ View ] Gift LLStarks Ad-Free
16th December 2018, 05:22 AM |#7  
calsurferpunk's Avatar
OP Senior Member
Thanks Meter: 862
 
Donate to Me
More
Quote:
Originally Posted by LLStarks

Can't even get this to boot.

Do you see the lineage OS logo and then blank screen or very shortly after? I've been facing an issue where it looks like com.qualcomm.qti.telephonyservice stops due to not loading a reference properly if I'm not charging. Thanks for letting me know you've had issues.
16th December 2018, 04:15 PM |#8  
Senior Member
Thanks Meter: 500
 
More
I could never get past the Lineage logo. Initial boots are usually long, but it would just crap out and reboot to whatever recovery I put in.
The Following User Says Thank You to LLStarks For This Useful Post: [ View ] Gift LLStarks Ad-Free
19th December 2018, 01:57 AM |#9  
calsurferpunk's Avatar
OP Senior Member
Thanks Meter: 862
 
Donate to Me
More
Quote:
Originally Posted by LLStarks

I could never get past the Lineage logo. Initial boots are usually long, but it would just crap out and reboot to whatever recovery I put in.

Good news all! It looks like the boot issue and modem service failure is fixed. I installed it on my phone and it seems to be stable. Sorry for any/all frustration with the previous build. Hopefully all who have been waiting can use it now:

https://androidfilehost.com/?fid=11410963190603877722
The Following 8 Users Say Thank You to calsurferpunk For This Useful Post: [ View ] Gift calsurferpunk Ad-Free
19th December 2018, 09:27 PM |#10  
Member
Thanks Meter: 22
 
More
Quote:
Originally Posted by calsurferpunk

Good news all! It looks like the boot issue and modem service failure is fixed. I installed it on my phone and it seems to be stable. Sorry for any/all frustration with the previous build. Hopefully all who have been waiting can use it now:

https://androidfilehost.com/?fid=11410963190603877722

Thanks a bunch! Flashing now!
The Following User Says Thank You to Not So Pro For This Useful Post: [ View ] Gift Not So Pro Ad-Free
22nd December 2018, 01:04 AM |#11  
tranna's Avatar
Junior Member
Thanks Meter: 0
 
More
Currently using a Pixel 2 XL, can't seem to complete the Android Setup. The app keeps crashing after I connect to WiFi and click continue, does anyone have some advice?
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Message:
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes