FORUMS
Remove All Ads from XDA

WiFi calling on unlocked p2XL on vzw

614 posts
Thanks Meter: 56
 
By Schroeder09, Senior Member on 14th October 2019, 04:24 AM
Post Reply Email Thread
I have been trying to figure this out since I got this phone in late 2017. How do I get the wifi calling to work on vzw with my unlocked 2xl? Reading on the internet seems to indicate that there is some software missing for this feature to work with vzw. This 2xl may have wifi calling on T-Mobile for example, but not vzw because it isn't "carrier branded" for vzw. I'm assuming that's some piece of software.

Does anyone know what this is and is it a shareable file that someone could provide and explain where I need to put it in my phone via solid explorer to get the wifi calling working on this phone? I was so excited for that feature when I upgraded from my s4, and have never had it yet. It's one downfall for the unlocked phone.
14th October 2019, 10:16 PM |#2  
OP Senior Member
Thanks Meter: 56
 
More
Anyone? Do I just need to flash a Verizon radio image or something like that?
15th October 2019, 09:24 PM |#3  
Senior Member
Thanks Meter: 152
 
More
I have also been trying to do this as well, in that menu, it is not provisioned, does that mean my carrier needs to do something?

Mod Edit: removed portions of quote no longer needed
The Following 2 Users Say Thank You to d33dvb For This Useful Post: [ View ] Gift d33dvb Ad-Free
15th October 2019, 10:06 PM |#4  
jlokos's Avatar
Senior Member
Flag Willamette Valley
Thanks Meter: 645
 
More
Quote:
Originally Posted by d33dvb

I have also been trying to do this as well, in that menu, it is not provisioned, does that mean my carrier needs to do something?

Mod Edit: removed portions of quote no longer needed

After setting up android 10, I went to settings>Network & internet > Mobile Network > Advanced, and tapped wifi calling, turned the toggle on and a screen popped up "activate wifi calling;" it required me to enter the emergency location information address.. I pressed save, and wifi calling was activated.
The Following User Says Thank You to jlokos For This Useful Post: [ View ] Gift jlokos Ad-Free
16th October 2019, 10:36 PM |#5  
OP Senior Member
Thanks Meter: 56
 
More
Are you on Verizon with an unlocked pixel 2XL I take it? Were you too unable to get Wi-Fi calling working on Verizon before the Android 10 update?
25th October 2019, 04:21 AM |#6  
OP Senior Member
Thanks Meter: 56
 
More
Is there anyone out there that has information on this? How is vzw locking out bring your own devices from their WiFi calling and several other services? What identifier on the phone are they using and how can it be tricked with root? Are there any Xposed modules that could make this work?
27th October 2019, 09:33 PM |#7  
bigmatt503's Avatar
Senior Member
Portland
Thanks Meter: 46
 
Donate to Me
More
Quote:
Originally Posted by Schroeder09

Is there anyone out there that has information on this? How is vzw locking out bring your own devices from their WiFi calling and several other services? What identifier on the phone are they using and how can it be tricked with root? Are there any Xposed modules that could make this work?

I have my pixel 2xl from google and it's working without issue.
Go to settings, network and internet tap on mobile network and scroll down to advanced and it's at the bottom (above apn settings). That's all I had to do. Nothing special even though I'm rooted it still had nothing to do with root.
Let me know if this helped

Bigmatt503

---------- Post added at 08:33 PM ---------- Previous post was at 08:32 PM ----------

Quote:
Originally Posted by Schroeder09

Are you on Verizon with an unlocked pixel 2XL I take it? Were you too unable to get Wi-Fi calling working on Verizon before the Android 10 update?

Yes, see my post down below
29th October 2019, 12:57 PM |#8  
OP Senior Member
Thanks Meter: 56
 
More
I have been reading and reading and reading on this. I can't find a way to make these carrier services work. What can I do? Here is what I see when I dial *#*#4636#*#* in my dialer.

The options are turned out turned on but greyed out for Wi-Fi calling, video calling, and UT interface. It tells me my IMS registered and voice over LTE is available. Do I need to change any settings in this section of my phone app? Do I have to change my preferred network type to something other than LTE / CDMA automatic, or change my radio band? What about the SIP server?
Attached Thumbnails
Click image for larger version

Name:	Screenshot_20191029-063739.png
Views:	70
Size:	213.2 KB
ID:	4859601   Click image for larger version

Name:	Screenshot_20191029-063703.jpg
Views:	70
Size:	258.9 KB
ID:	4859603  
12th November 2019, 03:56 AM |#9  
OP Senior Member
Thanks Meter: 56
 
More
No one knows of a work around?
12th November 2019, 08:24 AM |#10  
wolfu11's Avatar
Senior Member
Flag Minneapolis
Thanks Meter: 404
 
Donate to Me
More
Quote:
Originally Posted by Schroeder09

I have been reading and reading and reading on this. I can't find a way to make these carrier services work. What can I do? Here is what I see when I dial *#*#4636#*#* in my dialer.

The options are turned out turned on but greyed out for Wi-Fi calling, video calling, and UT interface. It tells me my IMS registered and voice over LTE is available. Do I need to change any settings in this section of my phone app? Do I have to change my preferred network type to something other than LTE / CDMA automatic, or change my radio band? What about the SIP server?

This has happen to me a couple times when I was using an essential phone and tried to get WiFi calling to work on it. Once I went back to my unlocked pixel 2xl I had to call the help line and get my "video calling" turned back on. Which in turn re activated my WiFi calling. Just have them check i bet something got turned off on their end.
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Message:
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes