FORUMS
Remove All Ads from XDA

My Pixel 2 Randomly shut off

256 posts
Thanks Meter: 15
 
By imtiax, Senior Member on 27th October 2017, 09:05 AM
Post Reply Email Thread
Hi,

Earlier today I was using Google Maps and suddenly the phone went blank and a couple of lines showed up on the screen each a different color for 2-3 seconds and then the phone turned off.

Then I held the power button and it took longer than usual to come back on.

This is the first time this has happened.

And no this is not like what happens when an app hangs/crashes this was completely different and not normal.

Do I have a defective unit?

This is the first time something like this has happened.

Is there a way to check an error log or something?
The Following User Says Thank You to imtiax For This Useful Post: [ View ] Gift imtiax Ad-Free
 
 
27th October 2017, 05:11 PM |#2  
Member
Thanks Meter: 6
 
More
I've had this happen 3 times so far, twice in the first hour of usage and then once again the next day. Since then (several more days) it hasn't happened at all. Another user reported having this happen 10 times on the first day and support told him to uninstall twitter, I don't have twitter installed myself and hoping that the issue has cleared itself up as it seems to have gone away, though I can not imagine why it would.
28th October 2017, 06:13 PM |#3  
t2jbird's Avatar
Senior Member
Thanks Meter: 192
 
More
I received a new pixel yesterday and haven't had any issues at all out of it. It could be a software bug, but I didn't take any chances and contacted Google.. glad I did. If this new one does it I'll report back here.
28th October 2017, 08:19 PM |#4  
Junior Member
Thanks Meter: 0
 
More
Happened during one phone call... I have the next 3 hours in an airport and I'm leaving the laptop off so i think if anything is going to be so problem it will probably happen here.
28th October 2017, 08:25 PM |#5  
t2jbird's Avatar
Senior Member
Thanks Meter: 192
 
More
Mine new pixel has done it twice in the past hour.... IDK what to do.
29th October 2017, 10:54 PM |#6  
Senior Member
Thanks Meter: 93
 
More
Quote:
Originally Posted by t2jbird

Mine new pixel has done it twice in the past hour.... IDK what to do.

Run in safe mode and see what happens?

Call support? RMA?
29th October 2017, 10:57 PM |#7  
Senior Member
Thanks Meter: 81
 
More
mine crashed too while on a call using the usb dongle. wth
30th October 2017, 02:09 AM |#8  
t2jbird's Avatar
Senior Member
Thanks Meter: 192
 
More
Quote:
Originally Posted by foosion

Run in safe mode and see what happens?

Call support? RMA?

Been down that road; this is a replacement, because my original one did the same thing. I'd like to be able to use my phone normally.
31st October 2017, 02:20 AM |#9  
Senior Member
Flag Vancouver, BC
Thanks Meter: 75
 
More
This happened to mine about 3-4 times a day and happened once during safe mode. Most of the times I was unaware and found the phone had spontaneously rebooted and I'd be forced to enter my password to get in. Sometimes it would reboot while doing something (send a text or checking something out in settings) and at other times would reboot while just sitting at my desk.

I contacted Google and they asked me to get a new one from my carrier (Rogers), so that's what I did today. I'll try the new one and see what happens.

BTW, I found the Bluetooth really flaky on mine.
4th November 2017, 03:40 PM |#10  
Junior Member
Thanks Meter: 1
 
More
Pixel 2 Issues
Yeah. My pixel 2 did the same exact thing yesterday. Two vertical blue lines show up. My phone went black then turned off. Took several minutes to restart. Forget this! I've had so many issues with Google.
The Following User Says Thank You to mdogbrown For This Useful Post: [ View ] Gift mdogbrown Ad-Free
7th November 2017, 05:49 PM |#11  
Junior Member
Thanks Meter: 2
 
More
This just happened to my phone, on the new update so assumed it was something to do with that as never noticed it on the original firmware. Was on the XDA app, screen went black, completely dead, didn't respond to anything apart from a very long press of the power button, and eventually got the Google boot logo.

What is going on?

---------- Post added at 06:49 PM ---------- Previous post was at 06:40 PM ----------

Just happened again within the space of 15 minutes, again I was in the xda app, screen went unresponsive, then black with two horizontal white bars that faded out. Left it this time and it eventually rebooted itself. What the hell
The Following User Says Thank You to bloomylicious For This Useful Post: [ View ] Gift bloomylicious Ad-Free
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Message:
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes