FORUMS
Remove All Ads from XDA

Delayed notifications until I check my phone

388 posts
Thanks Meter: 11
 
By roadrunnerx7, Senior Member on 3rd September 2019, 07:00 AM
Post Reply Email Thread
Hello,
I recently purchased the pixel 3, I've had it for less than a month. I couldn't resist the $300 off, and my OnePlus 3T was starting to show signs of it's age

One reason I switched was hoping notifications would be more reliable and on time, since I've read OnePlus severely restricts background services, and I would always get delayed notifications, even when I was using the phone!

But now with the pixel 3, if I'm away from my phone for a while, I won't get nearly any notifications, then when I go to check my phone just to see if I missed something, when I turn the screen on, immediately the notifications come in, and in one app for work, when I open the notification it tells me that the job is already gone. That's one way I know the notification was actually sent out waaaaay earlier

I've seen this before on the OnePlus, and I've read about it a lot, I think it has something to do with doze mode. On the OnePlus it was really easy to turn off doze mode(though OnePlus is so bad at this that I wonder if turning it off did anything), but that was Android Oreo and oxygen os. I can't even find a switch for doze mode in Android pie. It's not in developer settings, the closest thing I could find was adaptive battery, which is off. And I already set those important apps to have battery optimization disabled. Yet this keeps happening, as if doze mode is running on everything.

How do I turn off doze mode?? Or what can I do to get my notifications on time?? The work app I use heavily relies on that Google/firebase cloud messaging thing, and if I don't get notifications for new jobs on time, I pretty much miss out on a whole bunch of work.

Got any ideas?? Please help
 
 
3rd September 2019, 11:15 AM |#2  
Senior Member
Thanks Meter: 170
 
More
Have you tried disabling Battery Optimisation for the apps which notifications are delayed?

For Android Pie it's in Settings > Apps & Notifications > Advanced > Special app access > Battery Optimisation, then change the filter to All apps and disable optimisation for each app you want to.
3rd September 2019, 01:50 PM |#3  
Senior Member
Thanks Meter: 58
 
More
Turning off battery optimization doesn't do a thing. Notifications are always delayed for an app like Gmail, even after battery optimization are turned off.
3rd September 2019, 02:16 PM |#4  
sliding_billy's Avatar
Senior Member
Flag North Texas
Thanks Meter: 357
 
More
Quote:
Originally Posted by Fille84

Turning off battery optimization doesn't do a thing. Notifications are always delayed for an app like Gmail, even after battery optimization are turned off.

I have seen that happen especially when installing from a TB restore. Go into the app and disable notifications, and then re-enable them. If that doesn't work, delete and add the app back from the Play Store. That has worked for me in the past.
3rd September 2019, 03:15 PM |#5  
Senior Member
Thanks Meter: 170
 
More
Quote:
Originally Posted by Fille84

Turning off battery optimization doesn't do a thing. Notifications are always delayed for an app like Gmail, even after battery optimization are turned off.

I never had to turn off battery optimization to have instant notifications for Gmail maybe check @sliding_billy 's tips
3rd September 2019, 04:04 PM |#6  
Senior Member
Thanks Meter: 58
 
More
Quote:
Originally Posted by sliding_billy

I have seen that happen especially when installing from a TB restore. Go into the app and disable notifications, and then re-enable them. If that doesn't work, delete and add the app back from the Play Store. That has worked for me in the past.

I will try that, even though I believe I've tried that before. I Started to use Outlook instead that gives me instant notifications.
The Following User Says Thank You to Fille84 For This Useful Post: [ View ] Gift Fille84 Ad-Free
3rd September 2019, 05:35 PM |#7  
sliding_billy's Avatar
Senior Member
Flag North Texas
Thanks Meter: 357
 
More
Quote:
Originally Posted by Fille84

I will try that, even though I believe I've tried that before. I Started to use Outlook instead that gives me instant notifications.

Yeah, the new Outlook app is damn good. I don't use it for other accounts, but I use it for my outlook.com account that I have had literally since Microsoft launched Hotmail. Now that the Activesync works on the deleted folder (which it didn't for a long time), I rarely use my Gmail account for anything not coming from Google.
6th September 2019, 01:24 AM |#8  
roadrunnerx7's Avatar
OP Senior Member
Thanks Meter: 11
 
More
Quote:
Originally Posted by bafforosso

Have you tried disabling Battery Optimisation for the apps which notifications are delayed?

For Android Pie it's in Settings > Apps & Notifications > Advanced > Special app access > Battery Optimisation, then change the filter to All apps and disable optimisation for each app you want to.

Yes I mentioned this in my post.

Quote:
Originally Posted by Fille84

Turning off battery optimization doesn't do a thing. Notifications are always delayed for an app like Gmail, even after battery optimization are turned off.

Yeah it seems battery optimization toggles are useless

Quote:
Originally Posted by sliding_billy

I have seen that happen especially when installing from a TB restore. Go into the app and disable notifications, and then re-enable them. If that doesn't work, delete and add the app back from the Play Store. That has worked for me in the past.

I've tried this before but it doesn't help. Something within Android is messing up the notifications really badly. It's like it's putting Android into a really deep sleep, and maybe the notifications are being received, but the system is not waking up the phone to tell you,
so they just linger around until you check your phone, only when you check the phone does the system all of sudden tell you that notifications had been received. It's so annoying!
10th September 2019, 07:48 PM |#9  
roadrunnerx7's Avatar
OP Senior Member
Thanks Meter: 11
 
More
Does this method still work on Android 10?
https://youtu.be/SB3-k-3Cem4
10th September 2019, 10:24 PM |#10  
Member
Thanks Meter: 8
 
More
Any chance you have flip to shh on? Do not disturb when face down?

Do notifications come in with screen on?

I'm on my second pixel 3 (first one warrantied after it stopped charging randomly) and neither gave me trouble with notifications.

My dad disabled notifications rather than just dismissing them when I got him his first smart phone last year, but it sounds like you're a lot more savvy than that.

Someone mentioned a titanium backup, which I was happy to do on my op3, but part of the appeal to me of the pixel was a totally clean and Google-managed backup process. Are you on a stock install?
11th September 2019, 11:39 AM |#11  
Junior Member
Thanks Meter: 3
 
More
Any chance you are using a MVNO? I went years on a MVNO with no push/sync issues. Over the last year I developed notification issues. I switched multiple phones & carriers, the only way I could fix delayed notifications was to switch to a real carrier, that or use WiFi.
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Message:
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes