FORUMS
Remove All Ads from XDA

Enable Soli for any contries through Magisk module

4 posts
Thanks Meter: 13
 
By fortunedemj, Junior Member on 4th November 2019, 05:48 AM
Post Reply Email Thread
The last post i write a EdXposed module to enable Soli.
Now I'm write a Magisk module to enable Soli without restart zygote,and reboot the device will keep Soli to enabled.
Please go to github and download this module ,the url is https://github.com/demj1206170/EnableSoli
and feedback if there have any issues.
The Following 8 Users Say Thank You to fortunedemj For This Useful Post: [ View ] Gift fortunedemj Ad-Free
4th November 2019, 10:41 PM |#2  
DinarQ8's Avatar
Senior Member
Flag Kuwait City
Thanks Meter: 102
 
More
I download the file and flashed by Magsik i got failed " This zip in not a Magsik Module
I am new in root+Magsik game

Pixel4XL - Oct
6th November 2019, 08:30 AM |#3  
Junior Member
Thanks Meter: 2
 
More
Quote:
Originally Posted by DinarQ8

I download the file and flashed by Magsik i got failed " This zip in not a Magsik Module
I am new in root+Magsik game

Pixel4XL - Oct

If the error states that it's not a Magisk zip, or invalid zip in TWRP, the zip is not packaged correctly. Open up the zip and you'll likely see a folder (probably named something like <nameofmodule>-master or similar, or something completely different). Take all the contents of that folder and repack it to the root of the zip and try flashing it again.
The Following 2 Users Say Thank You to dengxm For This Useful Post: [ View ] Gift dengxm Ad-Free
6th November 2019, 08:41 AM |#4  
DinarQ8's Avatar
Senior Member
Flag Kuwait City
Thanks Meter: 102
 
More
Quote:
Originally Posted by dengxm

If the error states that it's not a Magisk zip, or invalid zip in TWRP, the zip is not packaged correctly. Open up the zip and you'll likely see a folder (probably named something like <nameofmodule>-master or similar, or something completely different). Take all the contents of that folder and repack it to the root of the zip and try flashing it again.

Thank you so much work great

Sent from my Pixel 4 XL using Tapatalk
6th November 2019, 04:54 PM |#5  
OP Junior Member
Thanks Meter: 13
 
More
Quote:
Originally Posted by DinarQ8

I download the file and flashed by Magsik i got failed " This zip in not a Magsik Module
I am new in root+Magsik game

Pixel4XL - Oct

i download the release file and flush it, no issue occured. Did you download this file from release page?
The Following User Says Thank You to fortunedemj For This Useful Post: [ View ] Gift fortunedemj Ad-Free
6th November 2019, 05:04 PM |#6  
DinarQ8's Avatar
Senior Member
Flag Kuwait City
Thanks Meter: 102
 
More
Quote:
Originally Posted by fortunedemj

i download the release file and flush it, no issue occured. Did you download this file from release page?

Just now i see i downloaded wrong file something name clone file this file not flashing. After edit the file i see there a original file on the site flashing without any issues Click image for larger version

Name:	Screenshot_20191106-190109.jpg
Views:	456
Size:	33.7 KB
ID:	4868279

Sent from my Pixel 4 XL using Tapatalk
23rd December 2019, 03:40 AM |#7  
Senior Member
Thanks Meter: 17
 
More
Works great! I had to repackage the zip contents into a new zip folder but after that, no problem with the Magisk flashing. Thanks for the effort
1st January 2020, 07:14 PM |#8  
Junior Member
Thanks Meter: 0
 
More
i try to enable by this models
but nothing
i had edxpose models and disabled it and try to insall the magisk models and after flashing and reboot didnt work
do i need to uinstall the xdpose app and models and riru core and riru edxpsosed
thanks
or maby i clone wrong the files
3rd January 2020, 03:54 PM |#9  
Junior Member
Thanks Meter: 0
 
More
hello, i repackaged the zip file but it is still saying that it is not a magisk module. Is there a specific program for repackaging or am i missing something?
4th January 2020, 08:40 AM |#10  
Junior Member
Thanks Meter: 1
 
More
Not working for me.

It's installed with no problem, but when I reboot, the Motion Sense is still disabled.

By the way, the following command still works.
Code:
setprop pixel.oslo.allowed_override true
setprop persist.pixel.oslo.allowed_override true
setprop ctl.restart zygote
4th January 2020, 11:18 PM |#11  
lapapunk's Avatar
Senior Member
Flag Odessa
Thanks Meter: 155
 
More
Quote:
Originally Posted by dotcink

Not working for me.

It's installed with no problem, but when I reboot, the Motion Sense is still disabled.

By the way, the following command still works.

Code:
setprop pixel.oslo.allowed_override true
setprop persist.pixel.oslo.allowed_override true
setprop ctl.restart zygote

U can do this with magisk Hide props conf.
U should install this module, then install terminal, type :
Su
Props
Add new props (u should choose it from the list)
Add only this: pixel.oslo.allowed_override true

Reboot / profit
The Following 3 Users Say Thank You to lapapunk For This Useful Post: [ View ] Gift lapapunk Ad-Free
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Message:
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes