FORUMS
Remove All Ads from XDA

[ROM][OFFICIAL][LineageOS][15.1][dragon] / [Lineage-16.0] -> 20190604

3,490 posts
Thanks Meter: 9,320
 
By followmsi, Senior Member on 17th April 2017, 10:31 PM
Post Reply Email Thread
21st August 2017, 08:59 PM |#231  
OP Senior Member
Thanks Meter: 9,320
 
More
Quote:
Originally Posted by stevehanler

So, I just uninstalled Magisk using the official uninstaller. Wiped the system partition and reinstalled LineageOS for good measure. Booted to make sure everything works correctly. Rebooted into TWRP and installed the 13.6 Beta of Magisk. Everything seems to be in working order.

Confirmed .. no boot-loops anymore !
Tested Magisk 13.6 BETA on Android Oreo Final version from today .. works fine.

Cheers
The Following 3 Users Say Thank You to followmsi For This Useful Post: [ View ] Gift followmsi Ad-Free
 
 
22nd August 2017, 10:59 AM |#232  
Member
Thanks Meter: 6
 
More
hi guys,

I was wondering if you also noticed a battery drain with the 2 last nightly builds.
Usually one battery charge could last me 3 to 5 days when I work (not using it much). But nowadays, the battery level goes down very fast.
PS: I already disabled most crap social apps from starting etc., and prevent most apps from running in the background.

Any hints on how to identify the culprit here?
Thx.
25th August 2017, 10:20 AM |#233  
OP Senior Member
Thanks Meter: 9,320
 
More
Quote:
Originally Posted by xda_jm

hi guys,

I was wondering if you also noticed a battery drain with the 2 last nightly builds.
Usually one battery charge could last me 3 to 5 days when I work (not using it much). But nowadays, the battery level goes down very fast.
PS: I already disabled most crap social apps from starting etc., and prevent most apps from running in the background.

Any hints on how to identify the culprit here?
Thx.

Sorry .. already running Oreo.

Did you check logcat ?
Anything related ?

Battery stats .. a lot of "miscellaneous" ?

Did you try with factory reset too ?

Cheers
27th August 2017, 11:04 AM |#234  
Member
Thanks Meter: 6
 
More
Quote:
Originally Posted by followmsi

Sorry .. already running Oreo.

Did you check logcat ?
Anything related ?

Battery stats .. a lot of "miscellaneous" ?

Did you try with factory reset too ?

Checked logcat, nothing suspicious.
No "miscellaneous" in Battery stats. Only android-system using more battery than usual (from memory).

And no - I will not do a factory reset? Why? I don't do many special things, and have barely games on it.
27th August 2017, 11:25 AM |#235  
OP Senior Member
Thanks Meter: 9,320
 
More
Quote:
Originally Posted by xda_jm

Checked logcat, nothing suspicious.
No "miscellaneous" in Battery stats. Only android-system using more battery than usual (from memory).

And no - I will not do a factory reset? Why? I don't do many special things, and have barely games on it.

Taking a backup first and start from scratch may help to solve your battery problem.
Even you have not much apps installed.

Maybe you install latest gapps over your current installation .. solves sometimes strange issues.

No idea what is causing your problem .. seems not to be a general problem.

There were no dragon device related changes.
Had to update the kernel sources and changed the vendor image, that's all.

Still need to play with Oreo .. to get some things tested.
Not sure when I will go back to Nougat .. but once back I will try to replicate your issue.

Sorry ... can't help you better now.

Sent from my AOSP on dragon using Tapatalk
27th August 2017, 12:57 PM |#236  
Member
Thanks Meter: 6
 
More
Quote:
Originally Posted by followmsi

...

Still need to play with Oreo .. to get some things tested.
Not sure when I will go back to Nougat .. but once back I will try to replicate your issue.

Sorry ... can't help you better now.

Sent from my AOSP on dragon using Tapatalk

No worries. I'll figure something out ...
28th August 2017, 11:57 PM |#237  
OP Senior Member
Thanks Meter: 9,320
 
More
Let's start with first (BETA) release of Android Oreo .. "lineage-15.0"

lineage-15.0-20170828-UNOFFICIAL-dragon.zip
lineage-15.0-20170828-UNOFFICIAL-dragon.zip.md5sum


Pls use Opengapps from here ..
open_gapps-arm64-8.0-stock-20170823-UNOFFICIAL.zip

Pls use the following config file as example ..
.gapps-config-dragon

Pls read this link below to have a better understanding of the opengapps config file - if needed at all.
https://github.com/opengapps/opengap...es-and-Options

Did not test this ROM myself .. not yet - but soon !

The "lineage-15.0" kernel is ready to be uploaded to LineageOS Github .. will do this in the next days.
https://github.com/followmsi/android...e/lineage-15.0

The dragon device tree will need some small changes .. overlays, fstab .. but not much to do here.

But no need to rush anyway ..
As I know it's not sure when Lineage will start to build official Oreo ROMs.

Enjoy

EDIT:
The LineageOS installer script for Oreo is still very basic and does include all the various "asserts".
To prevent error 7 inside TWRP I have made a new package using "my" installer ..

lineage-15.0-20170828-UNOFFICIAL-dragon-followmsi.zip

This version should not produce any Error 7 messages ..
The Following 13 Users Say Thank You to followmsi For This Useful Post: [ View ] Gift followmsi Ad-Free
29th August 2017, 12:22 PM |#238  
liam_davenport's Avatar
Senior Member
Flag Wakefield
Thanks Meter: 4,492
 
More
@followmsi Getting Error 7 When Trying To install. On OPR6 Bootloader And Latest O TWRP, Attached A Recovery Log In Case You Can See What The Problem Is

recovery.log
29th August 2017, 12:48 PM |#239  
OP Senior Member
Thanks Meter: 9,320
 
More
Quote:
Originally Posted by liam_davenport

@followmsi Getting Error 7 When Trying To install. On OPR6 Bootloader And Latest O TWRP, Attached A Recovery Log In Case You Can See What The Problem Is

Attachment 4256083

Have a look here ..
https://forum.xda-developers.com/sho....php?t=2522762

But I made a new version quickly ..

My "edit" from above ...

The LineageOS installer script for Oreo is still very basic and does include all the various "asserts".
To prevent error 7 inside TWRP I have made a new package using "my" installer ..

lineage-15.0-20170828-UNOFFICIAL-dragon-followmsi.zip

This version should not produce any Error 7 messages ..
The Following 2 Users Say Thank You to followmsi For This Useful Post: [ View ] Gift followmsi Ad-Free
29th August 2017, 01:28 PM |#240  
liam_davenport's Avatar
Senior Member
Flag Wakefield
Thanks Meter: 4,492
 
More
Quote:
Originally Posted by followmsi

Have a look here ..
https://forum.xda-developers.com/sho....php?t=2522762

But I made a new version quickly ..

My "edit" from above ...

The LineageOS installer script for Oreo is still very basic and does include all the various "asserts".
To prevent error 7 inside TWRP I have made a new package using "my" installer ..

lineage-15.0-20170828-UNOFFICIAL-dragon-followmsi.zip

This version should not produce any Error 7 messages ..

Thanks bro installed perfectly Also thx for the tut some good info
29th August 2017, 09:05 PM |#241  
Reuben_skelz92's Avatar
Senior Member
Thanks Meter: 452
 
More
How's this running? Any bugs? Does it have night light?
Post Reply Subscribe to Thread

Tags
dragon, lineage, nougat, oreo, pixel c

Guest Quick Reply (no urls or BBcode)
Message:
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes