FORUMS

Bluetooth keeps stopping- even after factory reset

1 posts
Thanks Meter: 0
 
By Jiggly_Jellyfish, Junior Member on 30th April 2019, 03:15 AM
Post Reply Email Thread
Hello everyone,

I purchased a used google pixel from eBay about a month ago, and I have used it happily ever since, until this past saturday. I use my device with 2 bluetooth devices constantly, a medical device (dexcom) that connects every 5 minutes, and a raspberry pi, which is always connected via bluetooth tethering. I had very reliable connections to both devices 24/7, until suddenly I started getting the message: 'Bluetooth keeps stopping.'
the error message
whenever this happened, it would turn off bluetooth tethering and then turn off bluetooth altogether. I would try to press the bluetooth icon to turn it back on, but it would aggressively turn it back off again. After several frustrating minutes, it would sometimes go back to normal and work just fine for 2 minutes-8 hours. But this error started appearing more and more often, to the point that my devices became useless, because they were never connected to my phone for a reasonable amount of time (and even then only because I was manually turning bluetooth back on over and over.)

I...
tried changing the dexcom app settings
tried forgetting dexcom device then re-pairing
tried turning off bluetooth tethering
tried turning off the raspberry pi
tried clearing the bluetooth cache
tried clearing bluetooth data
tried restarting the device more times than I can count

nothing at all worked. per the suggestion of one of my developer friends, I ran adb tools on my computer to see what was going on in the HCI bluetooth logs. According to what he said, it looks like it is trying to connect to Bluetooth headset service, failing, crashing, and disconnecting from all bluetooth devices. We decided to eliminate all variables, it would be best to factory reset the device and carefully install only my important medical apps first, then slowly any other apps over a period of days to see if the culprit became obvious.
So I performed a factory reset. I logged into my wifi, then was about to log into google, when...
error message after factory reset
the same message, popping up constantly, after a factory reset!
at this point I was almost convinced it was a hardware problem, until I heard some others have had the same issue due to their android version. But I have used 9.0 Pie ever since I got the phone, so that still doesn't make sense to me.

Please let me know if you have any solutions, ideas, or suggestions. If you want more screenshots, more information, or anything like that then please ask and I will try to post it. Thank you.

edit: since I am a new user, the image links aren't working. Basically, they both say
'Bluetooth keeps stopping
(i) App info
(x) Close app
(!) Send feedback'

edit 2: I also tried rebooting in safe mode, still getting the same 'bluetooth has stopped' message
15th September 2019, 01:28 AM |#2  
Senior Member
Flag Temecula, Ca
Thanks Meter: 20
 
More
I'm having the same exact problem on my daughters phone
27th September 2019, 05:36 PM |#3  
Junior Member
Thanks Meter: 0
 
More
Guys, I had this problem, I found the "solution" to the floating bluetooth error message, but I can't activate it since it starts to fail again.

What I did was the following: activate and deactivate the bluetooh from the notification panel, waiting for at least 5 notifications of bluetooth error to come out, then blocked the cell phone for a few minutes and I can use it quietly. By the way, you should not restart it or turn it off or it will fail again.
23rd October 2019, 04:39 PM |#4  
Meatbag_1's Avatar
Member
Flag North Kilttown
Thanks Meter: 9
 
More
I was also having the problem. I tried everything. Still not right.
12th February 2020, 08:50 PM |#5  
scandiun's Avatar
Senior Member
Thanks Meter: 949
 
More
You have to report the issue to LineageOS GitLab issues. Apparently dozens of users are having the bluetooth issue with latest version LineageOS 16.0 but now with older versions.
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Message:
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes