FORUMS

Google Pixel - Android 9 - Lineage 16.0 - Gapps Nano Install

16 posts
Thanks Meter: 3
 
By birdman59, Junior Member on 3rd March 2020, 05:41 AM
Post Reply Email Thread
Pixel 32GB AND Pixel 128GB - I have loaded and tested these instructions at least ten successful times on each of these phones. If at any time you get a failure or the phone does a long buzz/vibrate START OVER!. I started over & went back to default Factory Settings at least a dozen times on each phone without any issues.

Prerequisites:
• Google Pixel (sailfish) with Android 9.0
• Phone unlocked
• ADB installed and working on your PC
• Download to PC: latest Lineage Nightly 16.0 zip, Nano GAPPS zip, and TWRP-3.3.1-0 image (not zip)

The Pixel Phone has two partitions, called Slot A and Slot B. There are many links out on the web talking about partitions and slots. It is very confusing, but once you get this phone up and working it is designed to do updates automatically. If a problem occurs with a new update the phone will revert back to the working slot/partition. Due to this dual partition architecture there is currently no a way to install TWRP to the phone so each time you need it you have to boot the image from bootloader. I have tried a hundred ways to make it work, but this seems to be the new norm for dual partition phones.
  • Turn phone off.
  • Load boot loader – Hold Pwr Button + VolumeDown at same time until you see the bootloader Start Menu
  • Select “Recovery Mode” (this will bring you to the Default Lineage Recovery Screen, NOT TWRP!!!!)
  • Select “Factory Reset”
  • Select “Wipe system” and click yes to continue
  • Select “Wipe data / factory reset” and click yes to continue
  • Go back to main Recovery Screen and select “Advanced” then “Power Off”
  • Load boot loader – Hold Pwr Button + VolumeDown at same time until you see the bootloader Start Menu
  • Loading TWRP – From PC at adb prompt type: fastboot boot <twrpfilename>.img ----NOTE: Only tested TWRP Version 3.3.1-0. Currently I believe this is the first version that handles dual partitions correctly.
  • Phone will load to the TWRP main menu.
  • From the Reboot Button ensure slot b is active: “Current: Slot b” If not change!
  • Go back to Advanced tab and click “ADB Side load”
  • From PC at adb prompt type: adb sideload <lineagenightlyfilename>.zip (this will take about 5 minutes)
  • Go back and click “Reboot”. Set slot A active: “Current: Slot a”
  • Go back and click “Reboot” and select “Recovery” NOTE: leave TWRP check boxes as is!
  • Select “Apply update”
  • Select “Apply from ADB”
  • From PC at adb prompt type: adb sideload <gappsfilename>.zip (my preference is nano gapps & the only one I tested) . NOTE: most likely you will get a warning the file is not signed – just click “Yes”
  • From main default Recovery Screen click “Reboot”
After a few minutes your phone should be booted to the “Hi” screen. Continue and click on “Start”.
  • For now skip connecting WiFi
  • Leave Google Services as Default (you can change all this later if you want)
  • Skip Fingerprint (can add it later)
  • Skip Pin (can add it later)
  • Lineage OS Features – Leave Stock/Default and click Next
  • Click Start
  • Enable one WiFi connection (add other WiFi connections later)
Enable Development Mode: Setting -> About Phone -> tap “Build Number” about seven times until it says enabled.
Enable USB Debugging: Setting -> System -> Advanced -> Developer Options -> click “Android Debugging” on.
  • Add Google Account in Settings -> Accounts -> add your google account
  • Go to Play Store and add any apps you want.
NOTE: if you get/see “Data Transfer Tool Keeps Stopping” message pop up DO NOT close the window, rather click on “App Info” and click “Uninstall”. Everything should load fine from this point.

*** SUCCESS – WORKING PHONE! ***

A lot of steps here, but I have tried many, many configurations/attempts with “slot a” and “slot b” and the directions above are the only ones I can consistently repeat.
The Following User Says Thank You to birdman59 For This Useful Post: [ View ] Gift birdman59 Ad-Free
12th March 2020, 02:21 AM |#2  
Junior Member
Thanks Meter: 2
 
Donate to Me
More
I've installed twrp to the phone several times. On the download page there are images and zips. Once booted into twrp, you can flash the zip and it will patch twrp into both boot slots. If you install a rom, it will overwrite the recovery so always reflash the zip. You can also install the image from a booted twrp. Install > select image, flash the image to recovery. On mine it boot loops, there's an option somewhere to fix a boot loop. If you fastboot flash twrp, it will overwrite the whole partition, leaving you with twrp but no kernel, it will always boot into twrp.
12th March 2020, 02:49 PM |#3  
OP Junior Member
Flag Denver
Thanks Meter: 3
 
Donate to Me
More
130rne, if you follow the directions exactly as listed your phone (only tested with Pixel) will work perfectly. Flashing TWRP into both slots will certainly cause you a bootloop. The directions say to flash the TWRP Image (NOT ZIP). Go back and follow the directions step by step WITHOUT ANY DEVIATION.
12th March 2020, 05:02 PM |#4  
Junior Member
Thanks Meter: 2
 
Donate to Me
More
The instructions on the lineage site have been updated. They work if you follow them step by step. Ends up with the same result as yours. This is the most confusing device I've ever owned lol. But yeah, you can install twrp, I just tried it. Once I set everything up, I made sure I could access lineage recovery. I made sure I was on the correct slot to boot the system. Then I fastboot booted twrp 3.3.0.0, installed the twrp zip, and rebooted system. It will reboot into recovery, I made sure it said 3.3.0.0. Then I went Advanced > Fix recovery bootloop > reboot system. I'm at the lineage boot screen with twrp installed. I tried 3.2.1.0 and it didn't have the fix for a bootloop, so recent twrp versions only. Works fine, and I can backup my data. Not sure about decryption, you should be able to remove lockscreen security and decrypt data before booting into twrp. I'll test it right quick and find out.

Edit- decryption doesn't work on 3.3.0.0. Make sure to remove the lockscreen security first. I rebooted into twrp and data, system, vendor can all be mounted and files show up correctly in file manager. Good deal, I can make backups now.
22nd March 2020, 10:39 AM |#5  
Flipz77's Avatar
Senior Member
Milan
Thanks Meter: 159
 
More
Why go through all of this when you can flash the latest official 10 firmware with a double click and a 5 minute wait lol
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Message:
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes