FORUMS
Remove All Ads from XDA

severe battery drain again pixel xl

541 posts
Thanks Meter: 20
 
By dieselboy, Senior Member on 19th December 2019, 02:22 AM
Post Reply Email Thread
I came here because I have a severe battery drain issue. Sometimes I can fix the issue by rebooting the phone and then not using it. This issue has been coming and going I think since android 10 but it may have occurred in android 9. I had this issue a few months ago and the issue stopped on its own. To workaround the issue I was rebooting the phone when I noticed the severe drain and then tried to avoid using the phone.

For example I charged my phone (pixel 1 XL) before I went to sleep. I charged it to about 85% at 11pm. I took it off charge and went to sleep. At 530am I woke and checked the phone to check the time. The battery was at 15% and in power saver mode.. Usually I get 1 day usage (6am to 6pm, with streaming music to my headphones at the gym and messaging throughout the day) and get home with 65% battery. This issue has come back again now that I am traveling abroad.

I reset the phone to factory yesterday and only installed webex teams and whatsapp. The issue persisted yesterday. At lunch, we spent around half an hour eating and the phone was screen off and on the table and the phone dropped from 65% to 55%. I decided to remove webex teams and reboot the phone. The battery remained at 53% for approx 2 hours. I thought eurika, webex teams is the culprit. But unfortunately last night the same battery drain issue occurred and I had to charge the phone again at 5am.

I dont know that the issue is occurring until it is occurring.
The battery usage shows no usage by apps during this issue, and same when I show all device usage - for example I'll have say webex teams using 1% and screen using 1% but the device has dropped 60% of battery and there is no indication of where.

I dont mind to install a custom rom but I have not done any custom installs on this phone at all at this point.

Also I never used NFC until a few months ago for the banking app which I used to have. I just realised NFC was on yesterday and I've just switched it off. I just wont know if this helps until later today when the battery is dropping quickly. Although it just dropped 2% while typing this so I dont think it has helped. I just turned on data saver and battery saver and will see.

I am at a bit of a loss - has anyone else had this problem and found the culprit or a fix?

Update - battery saver and data saver does not stop the battery drain. 2% drop in 20 minutes with phone on the desk with screen off.
19th December 2019, 01:14 PM |#2  
dieselboy's Avatar
OP Senior Member
Thanks Meter: 20
 
More
I decided to give up, re-install webex teams and go for breakfast; while leaving nfc off, battery saver on and data saver on. At breakfast, the battery did not drop at all. Uptime is 9 hours 50 minutes (cant remember if I rebooted before breakfast) So almost 10 hours later and I have been using the phone over wifi on occasions and a few phone calls and whatsapp. The battery level is now 55% so it appears that the issue has gone away at the moment.

It's driving me nuts as I cannot work out a trigger. It almost seems like something within the android system is doing something and it's being hidden from the systems battery usage calculation. 3rd party apps also do not show any battery drain but the battery drains. If the battery was faulty then I would expect this issue to not get fixed after reboot (or even by itself). I have reset the phone 2 or 3 times now and the issue is still present afterwards.

Tried to google for answers and didnt really find anything apart from one guy saying his phone was draining and getting hot at the same time. Mine does not get hot.

I suspected malware or something like that but I dont see how it can be possible that malware is there after factory reset.
20th December 2019, 06:50 AM |#3  
dieselboy's Avatar
OP Senior Member
Thanks Meter: 20
 
More
OK I think I have made some progress - although can't be sure because this issue does go away and then comes back! However, this time I am refusing to reboot my phone so I can work on it. I am flying back tomorrow at 4am and so I need battery to last as long as possible. I have installed all of my important apps that I need to use. Given the issue is there when I have only 2 apps, the issue cannot be related to the apps I removed so I installed all of the important ones.

What I have done now:
1. turned off dark mode
2. opened the app permissions for the "google" app and changed the location permission from "always" to "only while using the app".

GPS Location is always off unless I am using google maps anyway but it did not stop battery drain previously!

As soon as I changed the permission app for point 2 above, the severe battery drain stopped. Take a look at the screenshot. You can see the severe drain on the left of the graph. Then the very severe drain was when I Was actively using the phone during the issue. Then I charged the phone. Then I changed the permission and you can see the graph have a flat horizontal line which is showing next to zero battery drain! I do not have battery saver or data saver turned on anymore. And I have been using the phone a fair amount.

Touch wood and fingers crossed. May be this will also stop google from emailing me every month with a google map breadcrumb trail of where I have been going.

EDIT - uptime of the phone is 28 hours and counting. Although you can see the charging points in the screenshot.
Attached Thumbnails
Click image for larger version

Name:	Screenshot_20191220-110950.png
Views:	82
Size:	200.0 KB
ID:	4906351  
21st December 2019, 07:47 AM |#4  
Junior Member
Thanks Meter: 2
 
More
I have the same issue. My battery was just recently replaced too. I'm going to try the suggestions in your latter posts and see if anything improves.
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Message:
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes