FORUMS

[Guide]Enabling VoLTE on stock ROM (Calls and SMS)

76 posts
Thanks Meter: 21
 
By WingXBlade, Member on 10th September 2018, 05:39 AM
Post Reply Email Thread
Hi all.
I just want to post a guide for people wondering how to enable VoLTE in unsupported countries. Apparently, Xiaomi only enable VoLTE for SEA countries etc. and Japan (Where I'm staying) is not supported.
So, I have been having problems receiving SMS and calling other numbers. After reading this blog post, I have solved that problem and maybe I can help others solving this problem. This is the procedure written in the blog post in English.

1. Setting APN (Might not be applicable for other countries)
-----------------
for Au user with VoLTE enabled sim, create a new APN and set it as below
・NAME:ims
・APN:ims
・MCC:440
・MNC:51
・TYPE:ims

for DoCoMo user with VoLTE enabled sim, create a new APN and set it as below
・NAME:ims
・APN:ims
・TYPE:ims
・APN protocol:IPv4v6

2. Go to dial and dial *#*#86583#*#* . It should show carrier check disabled or something along the lines.
3. If the phone does not have a signal after step 2. reboot the device and it should connect after that.

Hope this will help anyone who is having trouble enabling VoLTE.
The Following 5 Users Say Thank You to WingXBlade For This Useful Post: [ View ] Gift WingXBlade Ad-Free
10th September 2018, 07:43 AM |#2  
Dilesh Perera's Avatar
Senior Member
Flag Colombo
Thanks Meter: 951
 
More
thanks man . *#*#86583#*#* did worked for me in Sri lanka
The Following User Says Thank You to Dilesh Perera For This Useful Post: [ View ] Gift Dilesh Perera Ad-Free
10th September 2018, 09:36 AM |#3  
WingXBlade's Avatar
OP Member
Flag Kuala Lumpur
Thanks Meter: 21
 
More
Quote:
Originally Posted by Dilesh Perera

thanks man . *#*#86583#*#* did worked for me in Sri lanka

I'm glad I was able to help
The Following User Says Thank You to WingXBlade For This Useful Post: [ View ] Gift WingXBlade Ad-Free
11th September 2018, 01:18 AM |#4  
fards's Avatar
Inactive Recognized Developer
Flag Currently Reverse Engineering 42
Thanks Meter: 1,836
 
More
its a pity there's not such a short code to enable the VoWifi in the same way

EDIT:

Turns out setprop persist.dbg.wfc_avail_ovr 1 enables the switch, but the service still shows as unavailable.

using the build.prop changes I came up with for this https://forum.xda-developers.com/one...abler-t3649647
enables UT interface.
The Following User Says Thank You to fards For This Useful Post: [ View ] Gift fards Ad-Free
22nd February 2019, 09:04 AM |#5  
Junior Member
Thanks Meter: 3
 
More
Volte Restore
Run the below code in your dialer app manually. You should see a message stating "Volte Carrier check disable" else run the code again.
After 30 seconds your volte network should be retored. Pull down the notification bar to check for the volte symbol.

*#*#86583#*#*

Cheers!!
The Following 2 Users Say Thank You to Mr.J_I For This Useful Post: [ View ] Gift Mr.J_I Ad-Free
26th June 2019, 06:08 PM |#6  
Junior Member
Thanks Meter: 4
 
More
Hi

Thanks for this topic.
I have a problem : my poco F1 (MIUI Global 10.3.5.0) says it is enabled only for SIM1.
But as I use a µSD card (which has to be plugged instead of SIM1) I only have SIM2 place to put my SIM.
So I only have SIM2, no SIM1, and my poco says "only for SIM1"...... WTF ?!!
Someone has an idea for having VoLTE (and VoWiFi) on SIM2 ???

Thanks !
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Message:
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes