FORUMS
Remove All Ads from XDA

[Lineage] [Unofficial] [2018-06-27] Phh-Treble

2,049 posts
Thanks Meter: 3,243
 
View First Unread Post Reply Email Thread
Hi all,

I've made my work on AOSP Phh-Treble as modular as possible, so that it can be reused on other ROMs.
As part of this effort, I'm releasing GSIs of LineageOS
This is a GSI, and true to the GSI spirit. It aims at supporting a maximum number of devices, but only with AOSP-available hardware features.

All credits obviously goes to LineageOS developers
v5: (2018-06-27)
Image for ARM64 A-only device with gapps
Image for ARM64 A-only device vanilla
Image for ARM64 A/B device with gapps
Image for ARM64 A/B device vanilla
Image for ARM32 A-only device with Android Go gapps
Image for ARM32 A-only device vanilla

v4: (2018-05-19)
Image for ARM64 A-only device
Image for ARM64 A/B device
Image for ARM32 A-only device
Image for ARM32 A-only devices, with Android Go gapps


V3: (2018-04-05)
Image for ARM64 A-only device
Image for ARM64 A/B device
Image for ARM32 A-only device

ChangeLog:
v4 (2018-05-19):
- Blackview A20 edition! Thanks to blackview for giving me this Android Go test device
- Fix Accents
- Update to latest AOSP Phh-Treble patches
- New Android Go variant with gapps

v3 (2018-04-05):
- Fix Galaxy S9 backlight control
- Support exfat sdcards on devices with exfat support in kernel
- Resize /system to maximum size on first boot

v2 (2018-03-26):
- Fix Galaxy S9 backlight control

How to build:
Code:
git clone https://github.com/phhusson/treble_experimentations
mkdir Lineage; cd Lineage
bash ../treble_experimentations/build-rom.sh android-8.1 lineage
The Following 150 Users Say Thank You to phhusson For This Useful Post: [ View ]
 
 
23rd March 2018, 09:58 PM |#2  
Junior Member
Flag Kiev
Thanks Meter: 1
 
More
Great Work!
23rd March 2018, 11:22 PM |#3  
Member
Flag Strasbourg
Thanks Meter: 8
 
More
Thanks for your work. I'll try this rom this weekend (I had problems with your other AOSP roms, I can't boot except the v9 one. I hope this version will boot).
23rd March 2018, 11:31 PM |#4  
phhusson's Avatar
OP Recognized Developer
Flag Paris
Thanks Meter: 3,243
 
Donate to Me
More
Quote:
Originally Posted by iBen68

Thanks for your work. I'll try this rom this weekend (I had problems with your other AOSP roms, I can't boot except the v9 one. I hope this version will boot).

I doubt it will boot.
What device is this? Could you get logs?
The Following 8 Users Say Thank You to phhusson For This Useful Post: [ View ]
23rd March 2018, 11:49 PM |#5  
Member
Flag Strasbourg
Thanks Meter: 8
 
More
Quote:
Originally Posted by phhusson

I doubt it will boot.
What device is this? Could you get logs?

Huawei Mate 10 Pro BLA-L09. I will try to get logs when I try this rom.
24th March 2018, 01:31 AM |#6  
KuwaLee's Avatar
Junior Member
Thanks Meter: 0
 
More
Great work
24th March 2018, 06:48 AM |#7  
Member
Thanks Meter: 8
 
More
bootloop on xperia xz1
i flashed it on stock rom and wipe userdata,cache on fastboot and also tried on twrp factory reset and cache,cache dalvik(i tried your aosp v9 v10 v11 it also doesn't work)
24th March 2018, 08:20 AM |#8  
Member
Flag Strasbourg
Thanks Meter: 8
 
More
Quote:
Originally Posted by phhusson

I doubt it will boot.
What device is this? Could you get logs?

How can I get logs at this point?
24th March 2018, 08:44 AM |#9  
phhusson's Avatar
OP Recognized Developer
Flag Paris
Thanks Meter: 3,243
 
Donate to Me
More
Quote:
Originally Posted by eggimong

bootloop on xperia xz1
i flashed it on stock rom and wipe userdata,cache on fastboot and also tried on twrp factory reset and cache,cache dalvik(i tried your aosp v9 v10 v11 it also doesn't work)

Can you try this?
https://www.google.fr/amp/s/forum.xd...-t3764851/amp/

What's the precise behaviour you're witnessing?
Do you get the White Android bootanimation, or only sony's logo?
Does it actually reboot when looping? You see the sony logo reappearing?
Does the device reboot to bootloader mode?
The Following 3 Users Say Thank You to phhusson For This Useful Post: [ View ]
24th March 2018, 09:10 AM |#10  
Member
Flag Strasbourg
Thanks Meter: 8
 
More
Quote:
Originally Posted by phhusson

I doubt it will boot.
What device is this? Could you get logs?

When I try
Code:
adb logcat
I got this:
Code:
PS C:\ADB> adb logcat
- waiting for device -
The adb daemon seems not to be started while the bootloop. When I go back to the AOSP v9 rom, I can see logs with the same command but it's pointless since this rom is booting well.
24th March 2018, 09:33 AM |#11  
phhusson's Avatar
OP Recognized Developer
Flag Paris
Thanks Meter: 3,243
 
Donate to Me
More
Quote:
Originally Posted by iBen68

When I try

Code:
adb logcat
I got this:
Code:
PS C:\ADB> adb logcat
- waiting for device -
The adb daemon seems not to be started while the bootloop. When I go back to the AOSP v9 rom, I can see logs with the same command but it's pointless since this rom is booting well.

Does adb devices -l sees it?
The Following User Says Thank You to phhusson For This Useful Post: [ View ]
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Message:
Previous Thread Next Thread