Remove All Ads from XDA

(4.2.1) RAZR i suddenly bricked

20 posts
Thanks Meter: 2
By psyb, Junior Member on 25th July 2014, 10:21 PM
Post Reply Email Thread
Hey, folks,

I have a Motorola RAZR i with Android 4.1.2. I never did any modification inside the system, even root, 'cause I prefer to not put it on my cellphone. Suddenly, when I was searching on Google Now at night, the phone freezed. I got nervous, but, I tried to restart the system using the combination to put in full power off, with success, but, after, i couldn't turn the phone on until today (I think it happened a one month ago), stoping all the boot process on the giant Motorola logo.

I can't enter in recovery mode too, but the computer detects the phone when I put it on.

Is there somebody who know how to fix it?
26th July 2014, 01:10 AM |#2  
xtr3m3's Avatar
Senior Member
Flag Midlands, UK
Thanks Meter: 64
Donate to Me
Have you tried turning the phone on using power + vol down? As soon as it vibrates let go of power and keep holding vol down until it enters fastboot.

If it doesn't turn on, have you tried plugging in a charger while holding vol down?

If you can access fastboot you can do a factory reset.

Sent from my XT890
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes