FORUMS
Remove All Ads from XDA

[Resolved] Every custom ROM has LTE signal drop

4,062 posts
Thanks Meter: 1,854
 
By k3lcior, Senior Member on 17th August 2017, 11:15 AM
Post Reply Email Thread
20th September 2017, 11:01 AM |#41  
huatz84's Avatar
Senior Member
Flag Binjai,North Sumatra
Thanks Meter: 308
 
More
I'm in Indonesia and I'm using Smartfren which is 850MHz and 2300 MHz. This LTE bug only occurs sometimes. The signal is fine only lost data if I use LTE data and the data signal won't work so I have to reboot or switching to airplane mode on and off to bring it back. I notice it occurs If I use wifi for a long time and switching to LTE or phone in standby without using for a long hour. This bug won't happen on MIUI only on custom AOSP based ROMs.
The Following User Says Thank You to huatz84 For This Useful Post: [ View ] Gift huatz84 Ad-Free
 
 
20th September 2017, 12:12 PM |#42  
Member
Thanks Meter: 23
 
More
Well that strange then, mine refuse to work with 2600 and perfectly work with 1800 MHz.
20th September 2017, 12:27 PM |#43  
Account currently disabled
Flag Novi Sad
Thanks Meter: 1,634
 
More
Quote:
Originally Posted by mark2k81

Well that strange then, mine refuse to work with 2600 and perfectly work with 1800 MHz.

Which rom? I only tried los based. Maybe aosp/caf based? Thinking of trying but I don't expect any changes
20th September 2017, 01:01 PM |#44  
Member
Thanks Meter: 23
 
More
Quote:
Originally Posted by Stevica Smederevac

Which rom? I only tried los based. Maybe aosp/caf based? Thinking of trying but I don't expect any changes

Linage OS 14.1 latest build
The Following User Says Thank You to mark2k81 For This Useful Post: [ View ] Gift mark2k81 Ad-Free
20th September 2017, 03:03 PM |#45  
baxtex's Avatar
Senior Member
Thanks Meter: 90
 
More
This happens to my Redmi 4x all the time. On latest Lineage and firmware. My calls constantly get disconnected. Would disable 4g and only using 3g fix the issue? What is the setting for that? If I go into settings, there is like 20 alternatives, not sure what to pick.
20th September 2017, 03:22 PM |#46  
OP Senior Member
Flag Kraków
Thanks Meter: 1,854
 
More
Quote:
Originally Posted by baxtex

This happens to my Redmi 4x all the time. On latest Lineage and firmware. My calls constantly get disconnected. Would disable 4g and only using 3g fix the issue? What is the setting for that? If I go into settings, there is like 20 alternatives, not sure what to pick.

Choose GSM/WCDMA, with that you should have H+
The Following User Says Thank You to k3lcior For This Useful Post: [ View ] Gift k3lcior Ad-Free
21st September 2017, 11:14 PM |#47  
Member
Thanks Meter: 23
 
More
Quote:
Originally Posted by Stevica Smederevac

Which rom? I only tried los based. Maybe aosp/caf based? Thinking of trying but I don't expect any changes

I think I found where the problem is.

Choose Settings->Sim Card->Sim Settings->Access Point Names. Edit your APN, choose in both APN Protocol and Roaming APN Protocol - "IPv4/IPv6". Don't forget to save new settings.


By default there was "IPv4", after I've change it to "IPv4/IPv6" it start working properly. LTE signal becomes stable.
The Following 7 Users Say Thank You to mark2k81 For This Useful Post: [ View ] Gift mark2k81 Ad-Free
22nd September 2017, 06:54 AM |#48  
Account currently disabled
Flag Novi Sad
Thanks Meter: 1,634
 
More
Quote:
Originally Posted by mark2k81

I think I found where the problem is.

Choose Settings->Sim Card->Sim Settings->Access Point Names. Edit your APN, choose in both APN Protocol and Roaming APN Protocol - "IPv4/IPv6". Don't forget to save new settings.


By default there was "IPv4", after I've change it to "IPv4/IPv6" it start working properly. LTE signal becomes stable.

Unfortunately my APN is already like that.. Tested allso AOSP based rom and same problem is present.

Back to Miui . Really frustrated.
22nd September 2017, 01:26 PM |#49  
Member
Thanks Meter: 23
 
More
But it definitely smth with settings, I've change it back to defaults, and LTE instantly drop down.
23rd September 2017, 02:58 PM |#50  
Junior Member
Thanks Meter: 5
 
More
Quote:
Originally Posted by mark2k81

I think I found where the problem is.

Choose Settings->Sim Card->Sim Settings->Access Point Names. Edit your APN, choose in both APN Protocol and Roaming APN Protocol - "IPv4/IPv6". Don't forget to save new settings.


By default there was "IPv4", after I've change it to "IPv4/IPv6" it start working properly. LTE signal becomes stable.

This seems to be working for me, thanks!
23rd September 2017, 07:33 PM |#51  
Junior Member
Thanks Meter: 8
 
More
Quote:
Originally Posted by mark2k81

I think I found where the problem is.

Choose Settings->Sim Card->Sim Settings->Access Point Names. Edit your APN, choose in both APN Protocol and Roaming APN Protocol - "IPv4/IPv6". Don't forget to save new settings.


By default there was "IPv4", after I've change it to "IPv4/IPv6" it start working properly. LTE signal becomes stable.

Thanks! This worked!
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Message:
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes