FORUMS
Remove All Ads from XDA

Quick Info

318 posts
Thanks Meter: 147
 
By SyeedAhmed, Senior Member on 16th September 2019, 03:52 PM
Post Reply Email Thread
after flashing Android 10 if anyone want to go back in pie.
WiFi and hotspot no connection could be face. don't panic
go to recovery put persist.img in storage go to flash img flash persist.img in persist it will fix it... you can also flash it via cmd in fastboot... I know I'm maybe not the first person to notice it but just wanna make sure no one going to think they brick their device or something... thanks
The Following 5 Users Say Thank You to SyeedAhmed For This Useful Post: [ View ] Gift SyeedAhmed Ad-Free
21st September 2019, 06:20 AM |#2  
Junior Member
Thanks Meter: 0
 
More
Ok, but where do i have to flash it? (Recovery, boot, etc)
21st September 2019, 09:09 AM |#3  
OP Senior Member
Flag Dhaka
Thanks Meter: 147
 
More
Quote:
Originally Posted by ugomaugo

Ok, but where do i have to flash it? (Recovery, boot, etc)

in persist.
twrp don't show it so use orangefox recovery
25th September 2019, 09:23 AM |#4  
MadK9's Avatar
Senior Member
Thanks Meter: 38
 
More
Your solution works only if the phone is rooted?
25th September 2019, 02:32 PM |#5  
OP Senior Member
Flag Dhaka
Thanks Meter: 147
 
More
Quote:
Originally Posted by MadK9

Your solution works only if the phone is rooted?

your phone need to be bootloader unlocked
25th September 2019, 04:52 PM |#6  
MadK9's Avatar
Senior Member
Thanks Meter: 38
 
More
I wonder if your solution would fix network switching issue I have? I cannot get data to work when I go underground by subway. The phone does not switch from band 38 (above ground) to band 1 (under ground) unless I toggle Airplane mode for 2 seconds at least. After this everything is fine.
Having my bootloade unlocked it would be an easy fix for my issue. I already tried flashing Oreo chinese modem but issue is still present...
25th September 2019, 05:17 PM |#7  
OP Senior Member
Flag Dhaka
Thanks Meter: 147
 
More
Quote:
Originally Posted by MadK9

I wonder if your solution would fix network switching issue I have? I cannot get data to work when I go underground by subway. The phone does not switch from band 38 (above ground) to band 1 (under ground) unless I toggle Airplane mode for 2 seconds at least. After this everything is fine.
Having my bootloade unlocked it would be an easy fix for my issue. I already tried flashing Oreo chinese modem but issue is still present...

don't think so cause persist.img from miui stock rom.
maybe you can remove your back over sometimes back cover cause this kind of problem
25th September 2019, 07:31 PM |#8  
MadK9's Avatar
Senior Member
Thanks Meter: 38
 
More
Sorry but I do not agree with this method. Phone is a few months old and this issue ocurrs after Pie update.
27th September 2019, 07:18 PM |#9  
Senior Member
Thanks Meter: 63
 
More
Quote:
Originally Posted by MadK9

Sorry but I do not agree with this method. Phone is a few months old and this issue ocurrs after Pie update.

you'll know it instantly when there's no way out repairing corrupt persist partition that cause no wifi/sensor/camera focus/bt etc. persist can't be flashed without authorized account to flush at EDL mood thus spending money or without opening the device.

beware of flashing any other then the persist.img from the stock fastboot rom .and mount the persist partition before flashing the img file at recovery.

and one thing fastboot method or fastboot from cmd can't flash persist partition as its protected by xioami tobring hell upon us at country like BD
If your at ARB 3 you still can mi flash to flash in EDL mood but at ARB4 your done for as you may already know that

---------- Post added at 11:17 PM ---------- Previous post was at 11:12 PM ----------

Quote:
Originally Posted by MadK9

I wonder if your solution would fix network switching issue I have? I cannot get data to work when I go underground by subway. The phone does not switch from band 38 (above ground) to band 1 (under ground) unless I toggle Airplane mode for 2 seconds at least. After this everything is fine.
Having my bootloade unlocked it would be an easy fix for my issue. I already tried flashing Oreo chinese modem but issue is still present...

This is not a problem with persist rather its modem Issue.. after unlocking bootloader try different farmware/rom and the issue will be gone .

---------- Post added at 11:18 PM ---------- Previous post was at 11:17 PM ----------

Quote:
Originally Posted by SyeedAhmed

after flashing Android 10 if anyone want to go back in pie.
WiFi and hotspot no connection could be face. don't panic
go to recovery put persist.img in storage go to flash img flash persist.img in persist it will fix it... you can also flash it via cmd in fastboot... I know I'm maybe not the first person to notice it but just wanna make sure no one going to think they brick their device or something... thanks

vaia cmd fastboot will not work only flashing .img from recovery after mounting the partition is real .
The Following User Says Thank You to ecrum For This Useful Post: [ View ] Gift ecrum Ad-Free
27th September 2019, 07:25 PM |#10  
OP Senior Member
Flag Dhaka
Thanks Meter: 147
 
More
Quote:
Originally Posted by ecrum

you'll know it instantly when there's no way out repairing corrupt persist partition that cause no wifi/sensor/camera focus/bt etc. persist can't be flashed without authorized account to flush at EDL mood thus spending money or without opening the device.

beware of flashing any other then the persist.img from the stock fastboot rom .and mount the persist partition before flashing the img file at recovery.

and one thing fastboot method or fastboot from cmd can't flash persist partition as its protected by xioami tobring hell upon us at country like BD
If your at ARB 3 you still can mi flash to flash in EDL mood but at ARB4 your done for as you may already know that

---------- Post added at 11:17 PM ---------- Previous post was at 11:12 PM ----------



This is not a problem with persist rather its modem Issue.. after unlocking bootloader try different farmware/rom and the issue will be gone .

---------- Post added at 11:18 PM ---------- Previous post was at 11:17 PM ----------



vaia cmd fastboot will not work only flashing .img from recovery after mounting the partition is real .

sry to mention I was trying to say without flashing orangefox recovery just boot into it fastboot boot method persist.img can be flash... and i don't give any link or anything it can be found in miui fastboot rom.
also I didn't know dev already mention it how to come in pie rom in their telegram channel.in Bangladesh we don't use telegram that much so I thought I would be a helpful post if i post it that's it.
28th September 2019, 08:04 AM |#11  
MadK9's Avatar
Senior Member
Thanks Meter: 38
 
More
@ecrum:
This is not a problem with persist rather its modem Issue.. after unlocking bootloader try different farmware/rom and the issue will be gone .

I know and already tried chinese modem... Issue is still present... So frustrating!!!
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Message:
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes