FORUMS

[ROM][UNOFFICIAL][violet][9] LineageOS 16.0

886 posts
Thanks Meter: 3,578
 
By Dyneteve, Recognized Developer on 6th April 2019, 07:51 PM
Thread Closed Email Thread


Code:
/*
 * I'm not responsible for bricked devices, dead SD cards, thermonuclear war, or you getting fired because the alarm app failed (like it did for me...). 
 * Please do some research if you have any concerns about features included in the products you find here before flashing it! 
 * YOU are choosing to make these modifications, and if you point the finger at me for messing up your device, I will laugh at you. 
 * Your warranty will be void if you tamper with any part of your device / software.
 * Same statement for XDA.
 */

LineageOS is a free, community built, aftermarket firmware distribution of Android 9 (Pie), which is designed to increase performance and reliability over stock Android for your device.

LineageOS is based on the Android Open Source Project with extra contributions from many people within the Android community. It can be used without any need to have any Google application installed. Linked below is a package that has come from another Android project that restore the Google parts. LineageOS does still include various hardware-specific code, which is also slowly being open-sourced anyway.

All the source code for LineageOS is available in the LineageOS Github repo. And if you would like to contribute to LineageOS, please visit out Gerrit Code Review. You can also view the Changelog for a full list of changes & features.

Instructions :
  • Make sure you have latest memeui
  • Boot to recovery
  • Flash the latest build
  • Flash fcrypt disabler if you want twrp to boot ( You just need to flash it 1 time since it replaces vendor fstab )
  • Flash our gapps
  • Reboot
Downloads :Reporting Bugs
  • DO NOT Report bugs if you're running a custom kernel or you installed Xposed
  • Grab a logcat right after the problem has occurred. (Please include at least a few pages of the log, not just the last few lines, unless you know what you're doing.)
  • If it is a random reboot, grab /sys/fs/pstore/console-ramoops and /sys/fs/pstore/dmesg-ramoops-0. (Do not bother getting a logcat unless you can get it just before the reboot. A logcat after a reboot is useless)
  • If the problem disappears after running "setenforce 0" from a root shell, grab /data/misc/audit/audit.log
Remember to provide as much info as possible. The more info you provide, the more likely that the bug will be solved. Please also do not report known issues. Any bug not reported in the bug report format below may be ignored.

Code:
What is your--
LineageOS version:
LineageOS Download url:
Gapps version:
 
Did you--
wipe:
 restore with titanium backup:
reboot after having the issue:
 
Are you using--
a task killer:
a non-stock kernel:
other modifications:
 
Provide any additional information (observations/frequency of problem/last version it worked on/etc) as needed:
XDA:DevDB Information
[ROM][UNOFFICIAL][violet][9] LineageOS 16.0, ROM for the Xiaomi Redmi Note 7 Pro

Contributors
Dyneteve, merothh
Source Code: https://github.com/Dyneteve/android_..._xiaomi_sm6150

ROM OS Version: 9.x Pie

Version Information
Status: Stable
Current Stable Version: 2.0

Created 2019-04-06
Last Updated 2019-05-13
The Following 43 Users Say Thank You to Dyneteve For This Useful Post: [ View ]
6th April 2019, 07:51 PM |#2  
Dyneteve's Avatar
OP Recognized Developer
Flag In The Dark
Thanks Meter: 3,578
 
More
Changelog

Code:
lineage-16.0-20190522-UNOFFICIAL-violet.zip
Enforcing 
Merged latest sm6150 CAF in kernel
FM radio fixed
Offline charging works
Improved notif led
A lot more but too long to
* Note: This will brick old twrp don't forget to flash new one after upgrade
* If you are comming from miui you need new twrp first before attempting to flash

lineage-16.0-20190512-UNOFFICIAL-violet.zip
Fixed IR blaster
Updated panel fw ( fixes touch delay ) thanks to @TheStricted

lineage-16.0-20190509-UNOFFICIAL-violet.zip
May sec patch
Kernel side changes ( Lazy to list )
Fixed prefered network
Fixed manual network selection
Fixed notif led
Fixed d2tw
Fixed encryption
New power hal based on qcom's
Maybe more
Note: From now on you must be on stock vendor for any rom to boot ( See new flash instructions to if you want to know how to prevent forcecrypt )

lineage-16.0-20190420-UNOFFICIAL-violet.zip
Rebased Trees
Offline charging works now (xiaomeme one)
Upstream from LineageOS

lineage-16.0-20190415-UNOFFICIAL-violet.zip
Updated vendor to V10.2.8.0 ( Don't forget to flash new vendor before los )
Moved back to aosp off charger ( Xiaomi one seems to be broken )
Fixed radio jumping signal bars
Moved to OSS kernel

lineage-16.0-20190409-UNOFFICIAL-violet.zip
Update to april security patch
Added fm radio
Adjusted rounded corners
Added ota server ( If a new build comes out you can download from ota )
Updated carrierconfig
Enabled volte for all carriers that are not listed in carrierconfig
Fixed sound distortion for some cases
Fixed manual network selection
Fixed any kind of sim manager derpness
More stuff i'm lazy to list
The Following 16 Users Say Thank You to Dyneteve For This Useful Post: [ View ]
6th April 2019, 08:13 PM |#6  
Member
Thanks Meter: 10
 
More
Amazingg!! 😍😍😍😍
6th April 2019, 08:30 PM |#7  
Junior Member
Thanks Meter: 0
 
More
reserved
6th April 2019, 08:32 PM |#8  
Vatumb's Avatar
Senior Member
Thanks Meter: 96
 
More
Attached Thumbnails
Click image for larger version

Name:	884b52c2-9087-45c1-818f-40a7e6a93e27.jpg
Views:	5544
Size:	126.7 KB
ID:	4738050  
GuestK00155
6th April 2019, 09:39 PM |#9  
Guest
Thanks Meter: 0
 
More
Quote:
Originally Posted by Vatumb

Which twrp did you use?
6th April 2019, 09:54 PM |#10  
Junior Member
Thanks Meter: 0
 
More
Have you installed LineageOS 16.0, ROM for Xiaomi Redmi Note 7 Pro?
GuestK00155
6th April 2019, 11:00 PM |#11  
Guest
Thanks Meter: 0
 
More
It says the system has been destroyed for me fml. I can go fastboot idk what to do now ;-;

---------- Post added at 10:00 PM ---------- Previous post was at 09:51 PM ----------

I've got your system has been destroyed.

Someone please help

Where do I get the stock firmware? I know I'm in deep waters right now, but I'd really love some help
Thread Closed Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes