Remove All Ads from XDA


1 posts
Thanks Meter: 0
By savagethakidd, Junior Member on 6th November 2015, 09:56 PM
Post Reply Email Thread
Hey im new here so please excuse me if this is in the wrong category

hi, i currently have a Samsung s2 skyrocket which was rooted and recently acting up so i tried factory resetting it, after factory resetting it the phone kept freezing at the boot up so i looked up possible solution for this problem which only made it worse. after trying to load my stock firmware back onto my phone using Odin i got an error afterwards from accidentally disconnecting it which read "Firmware upgrade encountered an issue. Please select recovery mode in kies & try again" I've tried connecting to Kies only for my computer to not recognize my phone even after running the connection error solution in the Kies application. i cant even get into recovery mode for my phone only shows a blank screen and starts to vibrate.
8th November 2015, 10:10 PM |#2  
Welcome to XDA.
Samsung Kies should have correctly installed your drivers and you should still be able to flash the stock firmware via Odin even in this state. I've had to do this more than a few times on S2, try doing a google search for "USB drivers for samsung phones" and install them manually if you haven't tried that already, sometimes you have to uninstall the drivers then reinstall them, try other USB ports also. Are you certain that you have the correct firmware, just to be sure before you start?

Once you have the drivers properly installed and your PC recognizes the device, charge the battery to full if you can even if you have to do it with an external charger(you don't want it dying in the middle of flashing), open Odin, try to boot to download mode, when the "connect to kies" screen or if download mode comes up then connect to Odin(don't use Kies), if recognized you'll get a blue or yellow comm# box and it will say <ADDED!> in the dialogue box, select the AP tab in Odin, browse to the stock firmware file and select it, when back in Odin screen select Start, give it a few to flash, when done you'll get a green PASS and the device will reboot, give it time to load into system, sign in to google account and you should be good to go. sometimes you have to flash a couple of times to get it. I hope this helps. Good luck.
20th January 2016, 01:30 PM |#3  
wonderbars's Avatar
Junior Member
Thanks Meter: 2
get into recovery, install the newest twrp, either through custom recovery already on your phone via zip or through odin using a tar.
reboot into recovery again (should be the newest twrp at this point)
if you still have anything on your internalSD, back it up through mount>mount as usb, plug phone into pc, browse, backup, or use file manager
wipe everything except externalSD
install rom then suggested gapps pack for that rom
reboot to system
wait like 15 mins for phone to do its thing during first boot
good luck
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes