FORUMS
Remove All Ads from XDA

Guide How to root Android 8.0 Oreo Stock ROM on Galaxy S7 ( 100% Working )

125 posts
Thanks Meter: 66
 
By Arona67, Senior Member on 9th September 2018, 09:57 AM
Post Reply Email Thread
2nd April 2019, 11:04 PM |#101  
Account currently disabled
Flag Waterloo
Thanks Meter: 47
 
More
Quote:
Originally Posted by veepe

Thanks for the guide, it works great, but how do I restore backups in TWRP? Getting errors and stuck on boot animation.

https://forum.xda-developers.com/s7-...ackup-t3917485
 
 
6th April 2019, 01:01 PM |#102  
Junior Member
Thanks Meter: 1
 
More
Hello to all,

i'm sorry, but i'm very f....up right now.
I postponed to root my s7 SM-G930FD 2 years an wanted to do it now, to get rid of the space consuming bloatware...

unfourtunately the given hints in this thread didn't work for me.

I'am using the latest stock-rom (march 2019)
1. flashing twrp (ltehero 3.2.3.0 ) worked fine
2. rebooting to recovery without any problems
3. wiping date worked well
4. rebooting to recovery without any problems again
5. ?? wondering about the necessary decision "allow or deny modifications to the system partition" when entering twrp (in further actions, i used both ways), but can somebody tell, which way is required?
6a. flashing "no-verity-op" was displayed as "done" and "successful", then navigating back in twrp and flashing "magisk 18.1", also displayed as "done" and "successful" (i didn't use the mechanism to select both zip-files and letting them to be flashed in one sequence by twrp)
6b. due to some hints, that there might be problems with current stock-rom-versions, i found this post and tried this alternatively to step 6a, including the flashing of magist 18.1. Here also no errors were displayed, "done" and "successful"
7. BUT, after rebooting the system and installing "root checker", root was displayed as not available. "Root access is not properly installed on this device"
i can't find any "magisk" on the phone

What were my mistakes?
Can you help me solving this issue?


One thing, i noticed, but am not sure about if it is relevant, was, that when rebooting to recovery mode after step 6 the question 5 is not displayed. But when entering the recovery mode after step 7, it reappears, each time.

BTW: i tried to backup my data prior to this action with samsung smartswitch to my pc. I restored it once and found out, that no data was backed up nor restored. F.... F..... F......
This wouldn't have happened with root. Are there any suggestions how to backup almost everything without root, next time?
6th April 2019, 03:42 PM |#103  
Junior Member
Thanks Meter: 1
 
More
hey guys,

meanwhile i thought about flashing an earlier oreo Stock ROM.
In Odin i get "Fail" and my Phone shows me the message ""sw rev. check fail (bootloader) ..."

Maybe this way can help me and many others with similar issues.

I'm not sure, if the word "downgrade" is the correct term for this action.
And i have already searched the forum therefore, but only find mayor downgrade issues, which relate to earlier OS-versions and are, imho not comparable to the currently by samsung inventet security mechanisms.

so, i hope for good input from you.

all the best
mario
6th April 2019, 09:36 PM |#104  
Junior Member
Thanks Meter: 3
 
More
Quote:
Originally Posted by Arona67

1- Download Odin 3.13.1 -------- TWRP 3.2.3 Recovery -------- Android 8.0 Oreo Stock Rom -------- Magisk v 17.1 -------- no-verity-opt-encrypt-6.0 .

The no-verity-opt-encrypt-6.0 download link from the OP is now returning a 404 File Not found.
6th April 2019, 10:15 PM |#105  
Junior Member
Thanks Meter: 1
 
More
Quote:
Originally Posted by OldFeller

The no-verity-opt-encrypt-6.0 download link from the OP is now returning a 404 File Not found.

c'mon old feller, the fact is well known.
I suggest, you check out this thread or use google.

if your phone hasn't got the latest patch/firmwareupdate, be happy about it, because this guide does no longer work for current roms. (wath my post above)
I suppose there have been relevant changes by the end of 2018.

If you find a method to flash an earlier Oreo ROM, than the currently installed one, let us know.
10th April 2019, 01:23 AM |#106  
Right2Bear's Avatar
Member
Thanks Meter: 11
 
More
Quote:
Originally Posted by mario.a

c'mon old feller, the fact is well known.
I suggest, you check out this thread or use google.

if your phone hasn't got the latest patch/firmwareupdate, be happy about it, because this guide does no longer work for current roms. (wath my post above)
I suppose there have been relevant changes by the end of 2018.

If you find a method to flash an earlier Oreo ROM, than the currently installed one, let us know.

This does not work? I was just about to try it out and update my 7.0 android.
I also have a question about odin, it says to delete your samsung and google accounts before doing anything. Do I need to wipe my phone before I start? I downloaded the latest oreo from sammobile. I am just trying to update and keep/not keep root.
11th April 2019, 04:28 AM |#107  
Account currently disabled
Flag Waterloo
Thanks Meter: 47
 
More
Flash my twrp backup to get root and bloatfree stock oreo rom. I like magisk but having trouble since magisk enforces encryption. Root with magisk is easy but after reboot to twrp, data is encrypted again so I'm sticking with SuperSu
12th April 2019, 12:39 PM |#108  
Junior Member
Thanks Meter: 0
 
More
will this work on 128gb oreo??
13th April 2019, 04:50 AM |#109  
Junior Member
Thanks Meter: 0
 
More
no verify opt link not working
15th April 2019, 10:48 AM |#110  
Member
Thanks Meter: 1
 
More
Is it working for Samsung C9 Pro (China version)? Tks
23rd April 2019, 04:51 AM |#111  
Junior Member
Thanks Meter: 0
 
More
Trying, but no success
Hey, Ive been trying to root my g930u for a while now and ive had no success at all. Ive tried a few different ways so far. I have done a factory reset and wiped the cache, flashed the 8.0 g930u firmware, but for some reason I cant seem to flash the TWRP file. it shows that its connected and then fails every time. After the factory reset, wiped cache, reboot into download mode, then attempted to flash twrp with no success. What am I missing? Any help would be greatly appreciated, thanks
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Message:
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes