Search results

  1. J

    Post [MOD] USB Audio Support

    Bad news on the volume control side of things. It can't be patched at runtime on the N7 as the volume control has been locked in the audio HAL. It can be patched by replacing a file but this is not universal. It would only work on the N7 and any devices that share the same HAL however. It may...
  2. J

    Post [MOD] USB Audio Support

    I'll submit the required patches to CM at the weekend (I promise :p) that should at least get things going for CM based ROMs. I am also hoping to release something based on the Xposed framework for people who either don't have a CM based ROM or don't want to change/update. Using Xposed should...
  3. J

    Post [MOD] USB Audio Support

    Still on with this, I have just been really busy unfortunately! I will post something soon.
  4. J

    Post [MOD] USB Audio Support

    Just a quick update to let you guys know that I will be posting a new simpler patch method soon which will also include the option to enable volume control. I'm hoping to finish things off tonight/tomorrow.
  5. J

    Post [MOD] USB Audio Support

    Of course :) There are a few issues with the patching process at the moment. It will not be reliable across devices so I am reworking a few things.
  6. J

    Post [MOD] USB Audio Support

    Yes I did :good:. Will post the updated patch in the morning. Odd! I've probably been lazy and "assumed" something about the device. I'll take a look at that. When does it freeze and does the device work again with having to reflash ?
  7. J

    Post [MOD] USB Audio Support

    The source has been in the OP since release :) I plan to submit the patches soon but I want to be sure that everything is working as intended across most devices. The reason the audio works when plugging in the DAC before boot is that the kernel module for USB audio is loaded before any of the...
  8. J

    Post [MOD] USB Audio Support

    Excellent news :). 4.2 changes the way volume control is locked so the current patch won't work. I never really looked into it again after that but I'll have another look tomorrow for you.
  9. J

    Post [MOD] USB Audio Support

    I could compile it with support for a lower version of .NET when if that helps?
  10. J

    Post [MOD] USB Audio Support

    Apologies for my absence. There appears to have been a lot of posts since I last visited the thread so catching up will take some time. I am looking into the headphone switching issues at the moment, if anyone can summarise the issues for me that would be great as I'll probably miss a few...
  11. J

    Post [MOD] USB Audio Support

    Hi Nosferatu If you want me to look into this for you let me know, I will need your assistance with testing. I am also going to look into the headphone issues that some of you have reported.
  12. J

    Post [MOD] USB Audio Support

    Almost sounds like an incompatible DAC ? Apologies if you have already answered this but does the DAC work when plugged in before booting with a totally stock ROM with a USB audio kernel?
  13. J

    Post [MOD] USB Audio Support

    For those of you still having issues getting the patch to work on the Nexus 7 (Nosferatu?) can you please try the following CM-10.1 build? It contains a pre-patched kernel and an updated hot plugging patch, so there is no need to manually patch this after you have flashed it to your device...
  14. J

    Post [MOD] USB Audio Support

    No problems with that at all. :) Though the code is essentially the same, are you sure you are not experiencing freezes after disconnecting the DAC? Particularly when attempting to adjust volume just after the DAC is removed? It doesn't happen that often but 3 times out of 10 the main thread...
  15. J

    Post [MOD] USB Audio Support

    I am not sure yet, I think I have found the issue but it is going to require more time unfortunately :( That's the plan ;) However it appears to be unstable in certain conditions at the moment. As soon as I iron out the major bugs I will submit the patch.
  16. J

    Post [MOD] USB Audio Support

    Reflash your ROM back over the top, this will replace your patched files.
  17. J

    Post [MOD] USB Audio Support

    I have been able to replicate the no sound / freeze issue on my Nexus 7. :good: Going to bed now but will look into the cause in the morning.
  18. J

    Post [MOD] USB Audio Support

    Also using a FiiO E17 ?
  19. J

    Post [MOD] USB Audio Support

    I will try and replicate this today, although I do not have a FiiO E17. You are correct, this patch effectively routes all audio from any app out via a USB dac.
  20. J

    Post [MOD] USB Audio Support

    Thanks for you help so far CZ Eddie :) If you get time would you please try flash this kernel onto your LiquidSmooth ROM and let me know if the DAC still works? No need for any logs. d2att-test-kernel-1_signed.zip
  21. J

    Post [MOD] USB Audio Support

    Excellent news! I have actually identified the problem with CM10/10.1 and will write a patch for it after work tonight. I will submit the patches to AOSP/CyanogenMod once a few more people have successfully tested the patch and the bugs are ironed out. You would have to give it a try I would...
  22. J

    Post [MOD] USB Audio Support

    Really sorry about that haha, totally forgot that you were using adb over usb! Thanks for updated information. No need for another other logs yet. Let me know how you get on, the Nexus 7 is the easiest to get working.
  23. J

    Post [MOD] USB Audio Support

    That's interesting... Is that with the DAC plugged in? Does the Ultimatum ROM work with the DAC out of the box? Ideally I need the output from the TW ROM that works already :)
  24. J

    Post [MOD] USB Audio Support

    Yeah I posted the wrong command for /dev/snd, I've updated my post try those commands if you can ;)
  25. J

    Post [MOD] USB Audio Support

    Excellent, I'll go ahead and make some kernel changes with lots of logging :) In the meantime if you get chance could you please try the following commands on your TW rom and the CM10.1 rom? *EDIT* adb su cat /proc/asound/cards ls /dev/snd
  26. J

    Post [MOD] USB Audio Support

    Excellent, I'll go ahead and make some kernel changes with lots of logging :) In the meantime if you get chance could you please try the following commands on your TW rom and the CM10.1 rom (with the DAC attached)? adb su cat /proc/asound/cards cat /dev/snd
  27. J

    Post [MOD] USB Audio Support

    Thanks for the files :) Unfortunately they don't give enough information about the connection of the DAC which is strange, not sure if Samsung removed the logging or never implemented it in the first place. Could you let me know which DAC you are using?
  28. J

    Post [MOD] USB Audio Support

    That would be very helpful, thank you.
  29. J

    Post [MOD] USB Audio Support

    Hi CZ Eddie/djthread Please can you download and run this? (You will need to be rooted of course) download-device-logs.zip Restart device Plug in DAC Wait 15 seconds Unplug DAC Run download-logs.bat Send me the "logs" folder If download-logs.bat doesn't work for you please re-try ALL of...
  30. J

    Post [MOD] USB Audio Support

    I have not tested volume control with 4.2.1 actually. I will go test this and upload a new volume patch if required. Glad to hear it's working for you! :) Not sure on the US S3 yet - hopefully CZ Eddie can give the patch + custom d2att CM10.1 ROM that I compiled a go. If it doesn't work it...
  31. J

    Post [MOD] USB Audio Support

    Okay you might need to fill in some blanks for me here, I don't have access to an NA S3 and I haven't really been following the device so I am totally out of the loop. Looking at the d2att kernel the USB audio drivers should be compiled in by default, so in theory my patch should enable hot...
  32. J

    Post [MOD] USB Audio Support

    Hah fair enough, well I have CM10.1 for the d2att compiling now I'll see how far I get. In the meantime could you try download the following for me? Extract it to a folder and run debug.bat and then please PM me the contents of debug.txt ? It will dump out your init.rc file, root directory...
  33. J

    Post [MOD] USB Audio Support

    If nothing pops up and the program doesnt throw up an error then everything is working as expected. The allow permission is probably being remembered. Forgive me if I am missing something but is there any particular reason you are testing this if your ROM is already working? :p Or are you after...
  34. J

    Post [MOD] USB Audio Support

    I have updated the main post with v1.1 which should detect root a bit better. I am still interested to hear of results with other devices. If there are issues I may be able to create device specific patches that can be applied in the same way. I am looking into the driver situation now, just...
  35. J

    Post [MOD] USB Audio Support

    Not the NA version unfortunately. International S3 running CM 10.1. Glad to hear that it actually worked without killing the OS this time around. I will update the app to check for the ability to SU. I'm not sure on the drivers for the NA S3. Is there a significant hardware difference between...
  36. J

    Post [MOD] USB Audio Support

    Stock versions of Note/S3 may have issues but CM10/10.1 should be fine. I have tested it on a friends S3 and it works without issue. What OS are you running on your Note 2?
  37. J

    Post [MOD] USB Audio Support

    Please could you run the following adb command on your device(s) and reply or PM me with the output. shell su cat /init.rc eg. adb.exe shell su cat /init.rc Thanks
  38. J

    Post [MOD] USB Audio Support

    Can you guys make sure your device is on and unlocked/on the home screen when running the software? It may be that SuperSU/Superuser has popped up asking for permission to run as root.
  39. J

    Post [MOD] USB Audio Support

    Original post updated with new patch method. Please give it a go and let me know! Remember to backup your device first, bugs will be bugs!
  40. J

    Post [MOD] USB Audio Support

    Haha, I wish! Sorry for the delays. I found an issue when patching the stock ROM that I would like to fix - thankfully it doesn't appear to be too much work. I'll avoid giving dates but I would rather release something that actually works for the majority this time around :) And in response to...
  41. J

    Post [MOD] USB Audio Support

    Sorry for the lack of updates. Going to post something after work tonight ;)
  42. J

    Post [MOD] USB Audio Support

    Sorry for the lack of updates, Christmas was busier than I expected... I am still working on a more reliable patch method, the tests so far appear to work rather well so far across devices and roms. I will post more updates later but it may not be today unfortunately.
  43. J

    Post [MOD] USB Audio Support

    I'm still working on an alternative method to distribute the patch as clearly the services.jar file replacement isn't working across devices or roms. I will post most information soon.
  44. J

    Post [MOD] USB Audio Support

    Thanks for the input. As previously mentioned changing the entire services file is probably not the best solution as you have seen it has caused a few roms to stop responding. As for things not working entirely I am not sure yet. I will attach the separate service soon, providing I can get it...
  45. J

    Post USB DAC works, but no audio input. Need Alsa guru!

    As discussed earlier in the thread this is actually something I have managed to get working -> http://forum.xda-developers.com/showthread.php?t=2029728 It probably wont work correctly on other devices but I am working on an alternative solution that should work across devices + roms.
  46. J

    Post USB DAC works, but no audio input. Need Alsa guru!

    Could you explain further? I always classed hotplug as making something work without having to power down or reboot.
  47. J

    Post [MOD] USB Audio Support

    I am working on moving the code to a separate service which should allow switching to USB audio without having to patch any files you could instead install an APK, it would also be much safer than replacing the entire services file. I'm afraid that a config modification alone isn't going to make...
  48. J

    Post USB DAC works, but no audio input. Need Alsa guru!

    Originally a cheap £1.50 USB sound card from ebay in order to test a proof of concept without wasting money. I now use a Fiio E7 without issue and from what I understand the E17 works as long as you turn USB charging off. As for the external microphone, that too shouldn't be that difficult. The...
  49. J

    Post [Q] OTG USB Audio possible without reboot?

    Hotplug USB audio is indeed possible on the Nexus 7, it seems that a few of us all have similar plans for our Nexus's :) Give this a try -> http://forum.xda-developers.com/showthread.php?t=2029728 If you have any issues try and reply in that thread so we keep them all in the same place.
  50. J

    Post [MOD] USB Audio Support

    To be honest I really don't know ;) HTC tend to do alot of things to their ROMs so it could break things horribly for you. Without a working services.jar the device doesn't even boot - it will just hang at the boot animation and you may never be able to restore the backup. If you can get a copy...