Find Your Device:
Or Continue to Thread: [Resource] Epic 4G Touch Owner…
27th December 2011, 11:53 PM
Just_s's Avatar
OP Senior Member
Flag Denver/Albuquerque
Thanks Meter: 631
 
More
Always make a NANDROID before you do anything!


New Modems - First, do not run out and flash the latest modem just for the hell of it. Use some restraint and think before you act. There are sometimes unknown hazards, such as the issue of no return from the EG31 modem to EG30 a few weeks back. Consider why you want the new modem. Are you having legitimate issues or do you just want the latest stuff? It's your phone, do as you please, just remember that you had a choice if something bad happens, like being stuck on an unofficial build.

LoS issues - LoS issues really should be a thing of the past since the EK02 and EL13 modems emerged, but if for some reason you have not moved to those modems and you are having LoS issues flash a stock kernel! I prefer Rogue *STOCK* kernels, but pretty much any kernel listed as "stock" should help.

Data/signal Issues - If you are having data/signal issues after flashing a modem, perform a Hands Free Activation, if that doesn't work, try pulling the battery for a few seconds (thanks Guillo1). If that still doesn't work you may need to call Sprint.

Poor Battery Life - If you have poor battery life make sure you have calibrated your battery and given yourself several full charging cycles. And use either Battery Repair (Doctor Boost) ($2.69) or Battery Calibration (FREE). User evolart passed on this method as well: Best way to calibrate S2 Battery. I'm not quite ready to believe that calibration does nothing for us, but this is an alternative method to try for those who feel compelled. I sent messages to both app developers. I'll test and keep an eye out for other user's opinions and update this as necessary.

Bootloops? -
  1. Make sure that you have a default launcher selected and if using a 3rd party launcher that it is NOT set to auto update in the market as an update overnight would leave you without a default selected. (Thanks to 1BadHEMI, rickyq12 and playya for jogging my memory.)
  2. If that didn't solve it and you are absolutely sure you wiped properly, you probably didn't so you might want to try that again. Recovery > Wipe Cache + Dalvik cache > Reboot (see Issues Flashing ROM below re: wiping)
  3. If that doesn't work, flash a stock kernel via recovery or odin and start from fresh ROM again. This time let everything settle in before applying any changes (voltage tweaks, themes, mods, new apps, restoring settings, etc.)

Issues Flashing ROM - If you are having issues flashing a ROM or an update here are some tips.
  • With some ROMs like Calkulin's ROMs, you generally do not need to wipe anything when going from one version to another. Just boot into recovery and apply the zip, his wipes for you. I have had the most success doing this and the Dev will note otherwise if the process changes. (It doesn't hurt to wipe cache + dalvik cache, so do that if you are fearful of not wiping anything.)
  • If coming from one ROM to another, you should wipe everything. I do it manually and use the Format_All zip, but you can do it anyway you like so long as everything (cache, dalvik, system, battery stats) gets wiped at least once. Some format system for good measure, I don't. Your choice.
  • If you have done either of these processes and are having issues it could be anything from a bad download to wiping issue to bad luck. Do it again and take a look at the Bootloops note above.

Google Voice - when I answer my phone I get a recording where I have to press 1 to answer
Open Google Voice > Options (gear icon top right) > Voice Settings > Calls > Call Screening > toggle to "Off"

Apps Issues - Apps missing, not working, acting strangely?
  • Reboot your phone
  • Reboot your phone
  • Reboot your phone
  • Fix permissions (ROM Manager > Fix Permissions or boot into recovery > Advanced > Fix permissions)
  • Clear app data (Settings> Applications > Manage applications > All > [the app] > Clear data)
  • Uninstall and reinstall the app
  • If it is something like Google music, Amazon Appstore, Spotify, etc. you may need to go to the web and clear some connected/authorized devices from the settings, there is a limit.

Fresh Start - If you've tried everything else, try flashing the STOCK EG30 TAR or Stock EL13 TAR via Odin. Either will help you start fresh.

More Links And a whole bunch more useful links in qbking77's thread.

Post Logs - Super easy way to grab logs and post them for review. Install a log collector such as aLogcat and Pastebin from the market. Then run alogcat after the event, click share from the log and select Pastebin from the popup list. Copy the URL it provides you and send that or post it here.
The Following 14 Users Say Thank You to Just_s For This Useful Post: [ View ] Gift Just_s Ad-Free