Find Your Device:
Or Continue to Thread: [ROM][4.3][CM10.2][UNOFFICIAL]…
11th December 2013, 10:35 AM
Senior Member
Thanks Meter: 1,185
 
More
Adventures with the New "eng" Build
Ok, I flash imaged that 6.0.4.5 with selinux support recovery. Very nice. Did backup -- this version does (claim to) backup sd-ext as well!
Did my usual (unorthodox) procedure:
Formatted system, wiped cache and dalvik cache.
Flashed my trimmed version of the ROM
Flashed my trimmed version of Rashuldy's mini-gapps.
Rebooted.
When I got the animation.
Checked sdcard. Nada
data/sdext2. Nada
Ran script to mount that.
data/sdext2/dalvik-cache was missing! Does wipe-dalvik take that out as well?? I do not think it does but I do not know, would explain why my relinking script did nothing.
Let it go, quite a while, monitored logcat: A lot of oops style errors, classes not found.
But low and behold, the thing came up!
Most apps, of course, FC's because most everything downloaded is MISSING its dexes!
Got up in launcher3--Surprise.
Since nothing will work with all downloaded apps missing, tried reboot for laughs. EVENTUALLY back up in launcher 3.
Booted to recovery
Attempted restore. It restored everything except the sd-ext, tried to format the partition and thankfully this failed.
My /data/sdext2/dalvik-cache was still missing so restored from (unfortunately, a week old) backup on my box. May have a few missing apps but fixing will be manageable. Titanium and Play. Since I never had to do this before, I would conclude that the wipe-dalvik (at least in 5.0.2.7?) does not remove the /data/sdext2/dalvik-cache. So what did?
It was meanwhile updating apps but no untoward side-effects.
Froze up when I tried to unlock.
Took out battery. Rebooted. Up and running. That was scarey.

Observations:

1. Backup and restore should be be self consistent!! If it thankfully will backup sd-ext partition (5.0.2.7 failed), then it MUST restore it as well.
2. ROM has a way to go but hey, it came up and worked. Even, for a laugh, turned bluetooth on and yes, off.
3. No mounted sdcard and failure to runparts the /data/local/userinit.d scripts are showstoppers (I could, in adb shell, run them fine). Since selinux is permissive, cannot blame that.
4. If it were not for all the errors in the logcat and the amount of time getting through the dalvik startup (animation), might be worthwhile to try it the orthodox way, from bare metal. Would just need to trim the keyboard instead of removing it. But without the sdcard and sd-ext, nope.
5. The animation runs a very very long time (because of all the errors?). Those who complained about boot loop, either: A little, no, a lot of patience. OR make sure there is enough space of /system (My methods left me 13 meg, more than enough, but untrimmed ... suspect!).
The Following 10 Users Say Thank You to Dovidhalevi For This Useful Post: [ View ] Gift Dovidhalevi Ad-Free