Remove All Ads from XDA
Post Reply Email Thread
When my samsung galaxy tab 10.1 (p7500) tab shut down I tried to open it by pressing the power button a couple of times, it turned on after several tries. I really had a hard time turning it on. Then after a week or so with this problem my battery icon showed a red x symbol. It disappears when I unplug-plug-unplug-plug the charger to the tab. It charges very slowly. Suddenly when I brought it to work fully charged, I tried to open it bu it was turned off and won't turn on. I have been trying to do all button pressing combinations but to no avail. When I plugged it in and tried to long press the power button, the camera flash would blink, but it stopped for awhile. What seems to be wrong? How can I solve this? Battery? motherboard? Thanks. I really need to solve this fast because I use it for my work.
3rd March 2014, 03:36 PM |#2  
Senior Member
Thanks Meter: 202
normally, it means your tab is out of battery.

Sent from my GT-I9305 using XDA Premium 4 mobile app

---------- Post added at 02:36 PM ---------- Previous post was at 02:35 PM ----------

try to back up your tab and do a factory reset if the problem persist.

Sent from my GT-I9305 using XDA Premium 4 mobile app
31st October 2014, 10:27 AM |#3  
Junior Member
Thanks Meter: 6
Just let it charge for an hour or so and try rebooting it.
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes