Remove All Ads from XDA
Post Reply Email Thread
I have a Sprint Samsung Galaxy S4 that was running JB 4.3. When I decided to root and ROM it, I read a lot. I'll tell you what I did and where I got my files so you know exactly what happened:

In Download Mode:
First I Odined UnknownForce's NAE Modem Only Firmware with No Bootloader
Then I Odined Philz Touch Recovery 6.15.6

I booted to Recovery.
I cleared Cache and Davlic Cache twice.
I did Wipe/Factory Reset twice.
Then I flashed using Rawintellect's Stock(ish) Rom.

I install Ktoonsez Kernel for Sprint Touchwiz

At this point I am running a custom rom with a custom recovery and a custom kernel. It runs great.

I have no SEAndroid messages about the kernel or recovery at this point.

I decided to upgrade to Kit Kat 4.4. I did a nandroid backup. Then I took the official Sprint MD5 update and Odin it right over my rom. It worked. When the system boots up, it is running the Touchwiz version of Kit Kat. But I don't have root.

So I go to recovery to flash but I'm back to stock recovery. So I go to download mode and re-Odin Philz Touch Recovery 6.15.6. Then I reboot to recovery.

There is an SEAndroid Recovery Message! But it lets me into recovery and I flash the zip. Reboot.

Since I was back to stock recovery, I check the kernel in settings. It's back to stock to. So I boot back to recovery and reinstall the custom kernel. Reboot to system.

There is an SEAndroid Kernel Message now! But it lets me into the system and I have root. I run Titanium Backup and remove Knox Files according to these instructions. I used method two for rooted phones. I also use method three.

Rebooted. Still showing the SEAndroid messages.

So I booted to download mode and re-Odined the NAE Modem Only Firmware with No Bootloader. Shut down phone and rebooted.

Still have the messages! Now I'm frustrated. So I do a Nandroid Backup of the KitKat Version and restore my nandroid backup of the Stock(ish) rom.

Phone works but I still have the SEAndroid messages! So I restore my nandroid backup of Kit Kat and started researching this.

What I know:

Though the messages may cause issues and boot loops for some, it is not doing it for me.
The messages do not hurt the functioning of the system.
I know the Knox counter was tripped from 0x0 to 0x1. (I never saw the Knox counter till I did this In fact!)
I know going back to stock recovery and kernel will remove the messages.

What I want:

I know the "Kernel/Recovery is not seandroid enforcing" doesn't hurt the phone but I want the message gone. I was on a rooted phone with custom rom, recovery and kernel without these messages showing up. Something is different from the way the phone was setup before and now. I don't want to go back to stock anything.

The SEAndroid is software. Software can be removed.

How do you remove it?

I know Knox was tripped somewhere in this process. Will that cause the message to appear even if your running without a boot loader?

How can I remove the SEAndroid software so it doesn't even run? Any ideas?
26th March 2014, 10:19 PM |#2  
leaderbuilder's Avatar
Senior Member
Somewhere in the dark and wet Northwest.
Thanks Meter: 1,289
When you created your backup via Philz/CWM did you make sure to set the nandroid settings to back up SE Linux context? if not that is probablye your issue.
26th March 2014, 10:27 PM |#3  
OP Member
Thanks Meter: 8
SE Linux context?
Originally Posted by leaderbuilder

When you created your backup via Philz/CWM did you make sure to set the nandroid settings to back up SE Linux context? if not that is probablye your issue.

I don't know what SE Linux context is? Is it something I can do now? If not, what other options do I have?
26th March 2014, 10:31 PM |#4  
leaderbuilder's Avatar
Senior Member
Somewhere in the dark and wet Northwest.
Thanks Meter: 1,289
It's in the misc nandroid settings.
Too late now if you didn't do it when you created your 4.3 backup though.
The Following User Says Thank You to leaderbuilder For This Useful Post: [ View ] Gift leaderbuilder Ad-Free
26th March 2014, 11:02 PM |#5  
OP Member
Thanks Meter: 8
Talking Will Any Nandroid Backup Work?
My wife and I bought the exact same phones on the same day. When it came to installing the Stock(ish) rom, I did the exact same thing to her phone. She insist that I experiment on mine before I do anything to her phone.

She does not have the "Kernel/Recovery is not seandroid enforcing" messages.

Can I do a complete Nandroid back up of her system and the SE Linux Context, copy it to my SD card and install it? I know it would be an exact duplicate of her system but I have all my apps backed up with Titanium Backup so I can re-install them easily. And of course I would have to log into my Google account and delete her account. Would that put me back the way I was?
26th March 2014, 11:08 PM |#6  
leaderbuilder's Avatar
Senior Member
Somewhere in the dark and wet Northwest.
Thanks Meter: 1,289
I doubt it -device id stuff in Android.
BUT there is a way to get you back most likely.
IF you didn't upgrade to NAE(or MK2) bootlader and just the modem (as you mentioned) the simplest thing to do would be to install stockish fresh.
Let it boot and then add your google account and let all the apps update - about 1/2 hour on wifi
Then load/install titanium ( if it didn't install) go to preferences and let it find/search for your backup directory and restore - you'll be asked first to 'restore device ID' choose YES and let it reboot!
Then you should be good to go. I know I've done this a few times.
Another bonus is that you'll have a fresh install to 'start from'
30th March 2014, 02:53 PM |#7  
OP Member
Thanks Meter: 8
Here's an update:

I made a fresh nandroid backup of my wife's phone. Copied it to mine. Wiped the phone and installed backup. Phone worked fine but the seandroid message is still there.

Wiped phone again. Reinstalled Stockish rom. Then installed an old nandroid backup I had from January. Message till there.

Then I went crazy. I went to Odin, did a nandroid wipe and re-partioned the whole phone. (Don't not try this at home! Seriously. DON'T.) I was able to bring back the phone because I had the pit file for the partitions.

No pit file, no partitions, no phone. You will have a brick.

Then I installed the modem without the boot loader and recovery. Booted to recovery.

The message was still there.


Installed Rom and brought phone back to life. I'm on the NAE bootloader. When I've tried to downgrade, Odin errors out.

Where does the boot loader reside? It wasn't there when I bought the phone. It was installed later so it had to go somewhere.

Thoughts anyone?

Sent from my SPH-L720 using xda app-developers app
31st March 2014, 12:28 AM |#8  
leaderbuilder's Avatar
Senior Member
Somewhere in the dark and wet Northwest.
Thanks Meter: 1,289
Well right now I'd just Odin the NAE .tar. It's got all partition info and will load, boot, recovery(stock), system, data, modem/baseband. Wiping all other/old partitions.
Only thing is you'll have the knox bootloader. BUT that really isn't a big deal - you can root using the LATEST CF-Autoroot from Chainfire's thread/site. Install a custom recovery and then install just about anything (well following the devs instrucions as per their OP).
The 'knox bootloader' is more than just a simple 'boot' partition - it's an actual cmos/chip write change! That's how they know and can track if you've tripped it. So far no, that I know of, has found away around this. The boot partition - in standard terms is still editable; hence the ability to create custom recoveries.
Good luck.
1st April 2014, 07:38 PM |#9  
Mistertac's Avatar
Recognized Contributor
Flag Springfield, Ma
Thanks Meter: 2,776
My girls S4 is Sprint.. Also with the NAE bootloader and I've wondered how to get rid of this stupid boot screen.

I've Odin the thing at least 3 times and rooted with CF then installed Philz. Each time no dice.

Now my Verizon S4 automatically backs up SE Linux Context. I never noticed a setting for that in Philz. Now maybe I just missed it since her phone doesn't get flashed all that much and like I said I'm on a Verizon S4.

I figured this was just a bi product of having a Knox Bootloader and having the phone rooted/custom recovery.

I'd love to figure out how to get rid of that screen though. I'll have to do some searching. Tri Angle Away gets rid of my " custom" Splash screen at boot... It'd be nice it it also got rid of this screen on the Sprint S4. I'll at least give it a whirl but something tells me its not that easy.

Sent from my SCH-I545 using Tapatalk
15th June 2015, 03:00 PM |#10  
Senior Member
Thanks Meter: 3
running this rom and gapps. upon boot up i receive this message in the top left hand corner: kernel is not seandroid enforcing, set warranty bit: recovery.

the phone seems to function fine. Whats up with it?
Post Reply Subscribe to Thread

seandroid, seandroid enforcing

Guest Quick Reply (no urls or BBcode)
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes