FORUMS
Remove All Ads from XDA

[PATCH] Working Superuser/su for newer Sense ROMs

1,361 posts
Thanks Meter: 4,588
 
By rmk40, Retired Recognized Developer on 25th December 2010, 10:20 AM
Post Reply Email Thread
26th December 2010, 01:28 PM |#11  
Senior Member
Thanks Meter: 6
 
More
I dont understand, or I miss some information. The 1,72 ROM is not patched yet (or what?).. Then. If I install 1,72 I will loose root. So in what cases I will need this patch?
26th December 2010, 01:47 PM |#12  
steviewevie's Avatar
Retired Forum Moderator
Flag UK
Thanks Meter: 621
 
More
Quote:
Originally Posted by denich

I dont understand, or I miss some information. The 1,72 ROM is not patched yet (or what?).. Then. If I install 1,72 I will loose root. So in what cases I will need this patch?

Check this thread - http://forum.xda-developers.com/showthread.php?t=886023

The patched su/Superuser is just part of the solution.
26th December 2010, 03:03 PM |#13  
Senior Member
Thanks Meter: 20
 
More
Quote:
Originally Posted by steviewevie

That's a DHD thread and this is the DZ/G2 forum. So you're either in the wrong forum, or looking at the wrong procedure (which could brick your phone).

Oh! You're right. I just followed some links. Okay thanks.
26th December 2010, 03:05 PM |#14  
Senior Member
Thanks Meter: 6
 
More
Quote:
Originally Posted by steviewevie

Check this thread - http://forum.xda-developers.com/showthread.php?t=886023

The patched su/Superuser is just part of the solution.

According to this- there is now root method to 1.72.. I don't understand, why this patch is needed if rooting 1,72 is not availeble?
b1oh4zard
26th December 2010, 04:50 PM |#15  
Guest
Thanks Meter: 0
 
More
Quote:
Originally Posted by denich

According to this- there is now root method to 1.72.. I don't understand, why this patch is needed if rooting 1,72 is not availeble?

Cause the Virtuous 0.8.X is build from the Egypt 1.72.X Release, if I understood it right
26th December 2010, 05:52 PM |#16  
Account currently disabled
Flag Glasgow
Thanks Meter: 56
 
Donate to Me
More
Quote:
Originally Posted by b1oh4zard

Cause the Virtuous 0.8.X is build from the Egypt 1.72.X Release, if I understood it right

Is the Egypt RUU rootable?
That could solve our problems!
26th December 2010, 11:16 PM |#17  
seo's Avatar
Retired Recognized Developer
Flag Plovdiv
Thanks Meter: 1,066
 
More
&partialy working for me.. still creating read-only -wal and -shm files

here is an another solution: http://saraev.ca/su/
it is modified to "chmod" own databases - have a look at README file included

don't forget to grant permissions to superuser itself

EDIT: this is a dirty workaround, I hope someone can make it better...
27th December 2010, 12:05 AM |#18  
rmk40's Avatar
OP Retired Recognized Developer
Thanks Meter: 4,588
 
Donate to Me
More
Quote:
Originally Posted by seo

&partialy working for me.. still creating read-only -wal and -shm files

here is an another solution: http://saraev.ca/su/
it is modified to "chmod" own databases - have a look at README file included

don't forget to grant permissions to superuser itself

EDIT: this is a dirty workaround, I hope someone can make it better...

The one in your link is a dirty workaround for sure, it modifies baksmali code. Mine is working as intended. The wal and shm files are only present when you're actually sitting in the Superuser app. I'll modify the code some more to close the DB anytime it's not being read or written from. As it stands it's already rare to trigger a case where a request would fail.
27th December 2010, 12:11 AM |#19  
seo's Avatar
Retired Recognized Developer
Flag Plovdiv
Thanks Meter: 1,066
 
More
Quote:
Originally Posted by rmk40

The one in your link is a dirty workaround for sure, it modifies baksmali code. Mine is working as intended. The wal and shm files are only present when you're actually sitting in the Superuser app. I'll modify the code some more to close the DB anytime it's not being read or written from. As it stands it's already rare to trigger a case where a request would fail.

yeah i know that..
27th December 2010, 12:44 AM |#20  
gominolo2002's Avatar
Senior Member
Flag Madrid
Thanks Meter: 44
 
More
Hi,

This patch works only on Desire Z or I can install in my Desire HD?

Regards,
27th December 2010, 03:52 AM |#21  
rmk40's Avatar
OP Retired Recognized Developer
Thanks Meter: 4,588
 
Donate to Me
More
Quote:
Originally Posted by gominolo2002

Hi,

This patch works only on Desire Z or I can install in my Desire HD?

Regards,

It'll work for any ROM actually.
The Following 2 Users Say Thank You to rmk40 For This Useful Post: [ View ] Gift rmk40 Ad-Free
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Message:
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes