Remove All Ads from XDA
Honor View 10

[TUT] Ubuntu on Adam Methods - 03/12/11

496 posts
Thanks Meter: 35
By webs05, Senior Member on 27th January 2011, 04:07 PM
Thread Deleted Email Thread
1st May 2011, 01:44 AM |#161  
Senior Member
Thanks Meter: 31
It's nice to have encouragement, but not sure how much more I'll be able to do. ubuntu-netbook packages are all downloaded now, but have been having issues configuring them. Have asked (nicely) my adam to install them anyway, whether it likes it or not. See what happens. I'll post the files I'm working from up later on today. Sorry webs05, haven't sorted out the google code thing yet, not sure what's happened to those emails you've sent. Can you send me a link to the project page? Maybe I can try and register from there. For now I'll continue posting them on my server, though at some point moving them would be great. I haven't done much more other than making a minimal rootfs with wicd-curses installed, and fixed up some dependency problems (mainly with libc, etc). You should be able to connect to a wireless network through it, and have oodles of fun installing. It's not hard, and if we want Ubuntu running on this piece of hardware, we're going to need some help. That means everyone watching and following this forum thread that hasn't posted yet.

Ok, back into it, will write an update later today, hopefully with a link to some updated files for you to try. Cheers
1st May 2011, 02:45 AM |#162  
Senior Member
Thanks Meter: 31
Ok folks, here are the files I've been working with. Please have a go building this yourself, it's not hard, fairly simple. If we have enough people working on this, we'll get a working version of Ubuntu up shortly. Of course, all the usual things apply... we are not responsible for bricked adams, etc. But of course, if that were an issue, I doubt you'd be reading this anyway. The files to use are:

minimal-ubuntu-wicd.tgz is the same as the armelbuild-6.tgz, except that I've fixed up the libraries that break the system, configured fstab, etc. Basically, when you install anything you will be asked to fix the installation with apt-get first. It's fine to follow those commands and upgrade the packages, providing when you're done you downgrade them again... otherwise you won't be able to boot into the GDM on next boot, and will have the pleasure of adam spewing errors at you. To revert, run this command:
sudo libc-fix
The login details are:
user: dickens
password: dickens

Why dickens? Why not...

In order to use this, you will need to format an external micro-sdcard to ext2/3/4 (doesn't matter which, though I'm using ext 4), and extract the rootfs onto the card. Edit fstab appropriately. (i.e., ext 2, ext 3) Assuming you've named your card "ubuntu", I use this command from a ubuntu system:
 sudo tar -C /media/ubuntu -pxzvf minimal-ubuntu-wicd.tgz
You will then need to follow rayman's method to flash the bootloader. I have this booting from my recovery partition, so I can dualboot. For more info, go here:

The easiest way I found to do this was to use the files from NI to unbrick your adam, and replace the recovery.img with rayman's linux-boot.img, of course renaming it to recovery.img.

A note for linux users:
For some reason, I couldn't easily use notion ink's unbricking files to do this. I needed an extra step not listed. Get the files for your adam here:
Then after extracting them, go two folders UP, then symlink the files into that folder. I don't know why it works, but it does. Ie, if you extract them into /home/user/working/extract/adam, you will need to symlink the extracted files to /home/user/working, then run them from there. You'll also need to make and nvflash executable. Also, running this will revert your adam install back to stock. As in, ALL YOUR DATA WILL BE WIPED! Wipe on baby...

Feel free to post back if you need clarification. If you aren't comfortable with possibly bricking your adam, I'd recommend not following this. If you are, please help us get this running! Running: sudo apt-get install ubuntu-netbook will spew errors at you, and might not be the best way to do this. The meta-package seems specific to omap4 boards. It might be better to try and install unity-2d first on it's own, with gdm to get it booting.
1st May 2011, 04:00 AM |#163  
Senior Member
Thanks Meter: 31
Last post for today. Here you go folks, Natty Narwhale on the Adam:

Md5sum: 711b1731d8a91d64c360da89e71d0842
*Uploading now, will be up in about an hour.

What is working:
- Unity 2d
- Wireless networking
- screen resolution

What is not working:
- touchscreen

Not tested:
- everything else

This is a development build, and hopefully enough to spur people reading this post into action. Flash rayman's boot.img, untar this image onto an sdcard, stick it in your adam and boot. It should boot into Ubuntu. Password is dickens, user is dickens, or whatever the system tells you on first login. You will need a keyboard and mouse.

No idea why the touchscreen is hosed, think it's because I used the ubuntu-netbook meta package, and it wanted to install some kernels. Rayman's method already has a kernel in the boot image, so this may conflict with it. This system is sloooow. From an external sdcard, what would you expect? On the desktop you will see 2 other sdcards however... the internal one the adam uses, as well as the 2gb partition NI uses for the adam files they don't want you to touch. It's probably possible for some clever person to reformat both these into an ext partition, then untar the file above onto it, if they can figure how to get rayman's boot.img to point there. My guess is this would run faster... as well as getting rid of android.

If I was going to remake this again, I would try installing only unity-2d. This "should" give you a gui without everything else.... no idea if it would work, but it's possible you could get a very minimal system up and running without losing the touchscreen.

I would encourage anyone else reading this thread who has actually created something more useful to please post it and let us know. This is a very small first step, and should be treated as such. It is also twice the size of the vega image, so my guess is they built theirs differently Cheers.
1st May 2011, 12:55 PM |#164  
Junior Member
Thanks Meter: 0
I'm finally through the 10 post trial!
Fantastic work mate!
Downloading this now. I'll start torrenting it as soon as I have downloaded so we are not putting as much load on your server.
As soon as I have it working on mine I'll knock together a youtube video which will hopefully get the slightly more cautious having a go!
3 hours to go until play time!
1st May 2011, 01:57 PM |#165  
Senior Member
Thanks Meter: 31
Awesome on all counts, thanks for getting involved. Made another build with just unity-2d, and gdm. Worked fine, but still no touchscreen. As rayman said it was working, I wonder what needs to be done? Makes me wonder if it's something simple like the xorg config. Might be worth looking at the vega ubuntu image and seeing what their xorg configuraton is. For what it's worth, I think a custom build from a minimal install using unity 2d is the go. Too many things (like banshee, at least for now, as no sound) won't have much use, and cups is a pain.

Thinking about about the internal flash drive... shouldn't be too hard to wipe android, and put Ubuntu there, then point the bootloader in that direction. Heck, we could probably do it through a Ubuntu install. I'm pretty sure it's mmc1, though would need to check on that. If we can pull apart rayman's boot.img, then we can probably point it to another part of the tablet. I'm game... I think we will have a very slow device until we are using that drive.

Looking forward to seeing what people come up with. Cheers.
1st May 2011, 06:41 PM |#166  
Junior Member
Thanks Meter: 0
Ubuntu Natty Image
To give Tillium some breathing room on his server, here is the Natty Narwhal image in a torrent.
Beware this is my first torrent so if it doesnt work the call me an idiot and I'll try and get it right !

p.s. Sorry for the archive, I had to zip up the torrent file before I could upload it.


OH for ***** sake the ******* card is not ******* big enough....*breathes* Hehe ah well I've got some on order now so should only be a few days!
Attached Files
File Type: zip - [Click for QR Code] (34.2 KB, 67 views)
2nd May 2011, 01:21 AM |#167  
Senior Member
Thanks Meter: 31
Thanks matey, the torrent looks fine. Keep in mind it will only work when you're computer is on to seed it to others.... at least until enough people are seeding it.

How big is your sdcard? You can also grab the minimal image, and have a go with that... you'll be able to make something much smaller than the other image I have... just don't install ubuntu-netbook!

Look forward to seeing where this goes.

2nd May 2011, 06:20 AM |#168  
Senior Member
Thanks Meter: 75
fantastic work... ill try and get working on it but school is a very real time constraint. btw why dont you just use the terminal command for flashing the image to recovery... should work something like this:

adb shell
flash_image recovery /sdcard/recovery.img

should be good to go. while some people say you need to check system and make sure there isnt a recovery there that will over write this one, i dont think it is needed... but here are the commands anyways:

adb shell
cd system
mount -o rw,remount /dev/block/mtdblock1 /system
rm recovery.img
mount -o ro,remount /dev/block/mtdblock1 /system

remember the boot image needs to be renamed to recovery... oh and if you have a recovery image prior to doing this, do a nand back up because if tis goes south your going to do a factory reset.... and the back up will still be there even though you reflash recovery with this.... bc its stored on the sdcard.
4th May 2011, 06:53 AM |#169  
Senior Member
Thanks Meter: 31
That's really interesting, particularly because adb shell gets you into the shell of the actual device, i.e., with my nexus one, into android. So does that mean in android, (or Eden here) there is a command to flash the bootloader within the system, or have I missed something? The other possibility would be doing this within apx mode, which I'd find even more interesting... as that's without android running at all... could you clarify this?

I'm familiar with the mount commands, etc. For remounting the /system folder in android, and get what you're doing there. Next time I flash it I'll have to give it a go.

Has anyone had a go with the gui version of Natty I put together? Any luck with the touchscreen? I just realized I forgot to clean the package cache, so ... sudo apt-get clean should fix that. Also I tried it with an ext 2 partition. Good luck.

I'm passing my Adam onto professor arronax (parronax) tonight, I just don't have the time to be playing with it right now. Study, work, and family is taking up all my time. I might have another play in a few months, but for now need to focus on other things. I'm still happy to post things up on my server, either pm me or parronax and we'll sort it from there.

I still think the Adam is an awesome machine with some great hardware, but I'm more interested atm in getting something like the samsung sliding pc 7, with an oaktrail chip, and running Ubuntu on it. No Pixel QI, and battery is unlikely to be as good, but the sliding keyboard would suit my work flow better, and 'should' be easier to get a fully working version of Ubuntu from the word go. See what happens.

Cheers folks, catch you around.

5th May 2011, 04:54 AM |#170  
Senior Member
Thanks Meter: 75
yea i saw those... looks like a pretty sweet device.

anyways that is supposed to be run from a command prompt in windows, it can be run within android on a terminal emulator the same way but without the adb shell commands. terminal emulator is what i use... its free... it works. ik this method works with my android phone and am confident it will work with any android device.

i think it requires the android system... i dont think it is busy-box but the native built in version. but all it does is write an image file to a partition, the recovery does the same thing... im sure it uses basically the same commands but with a different partition. like you can flash using that command to any partition by changing recovery to something else... there was a guide online but idk where it is.
6th May 2011, 09:52 AM |#171  
Junior Member
Thanks Meter: 0
@tillum: I'm still waiting on my micro sd cards but I'l' be testing as soon as they arrive. The slider is very cool but the arm and pixel qi combo is just too alluring for me to leave the adam! Hope all goes well in the real world!

@tmckenn2: Thats very cool, I wa hoping for that as after flashing the recovery partition android has the boot loop issue and trying to go to recovery just loads ubuntu on the sdcard.
Again I'll have a tinker when I have the sdcards.
Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes