FORUMS
Remove All Ads from XDA

[FIX] Final fix for nonworking WIFI on unlocked ATT Atrix in some countries

1,797 posts
Thanks Meter: 396
 
By crnkoj, Senior Member on 13th May 2011, 02:57 PM
Post Reply Email Thread
15th May 2011, 04:41 AM |#11  
Junior Member
Flag Doha
Thanks Meter: 1
 
More
Still doesnt work for me. I can see my wireless, and can connect to it. but if I try to go to the market, or anywhere using the browser.. nada
The Following User Says Thank You to wargame1 For This Useful Post: [ View ] Gift wargame1 Ad-Free
 
 
15th May 2011, 09:59 AM |#12  
OP Senior Member
Thanks Meter: 396
 
More
uhm, but your laptop can use the wifi? is it any special encryption maybe, maybe you have to do vpn or stuff?
did you try ping from a terminal emulator?
16th May 2011, 11:24 PM |#13  
OP Senior Member
Thanks Meter: 396
 
More
guys, motorola is gonna fix it with an update it seems
https://supportforums.motorola.com/t...rt=15&tstart=0
The Following User Says Thank You to crnkoj For This Useful Post: [ View ] Gift crnkoj Ad-Free
13th June 2011, 07:58 AM |#14  
_Dennis_'s Avatar
Senior Member
Thanks Meter: 835
 
Donate to Me
More
I made an update.zip for CWM if you need it. THis way you just have to apply the update after SBF/root. It SHOULD work....I did not try it.
Attached Files
File Type: zip Wi-Fi Fix.zip - [Click for QR Code] (489.7 KB, 681 views)
The Following 2 Users Say Thank You to _Dennis_ For This Useful Post: [ View ] Gift _Dennis_ Ad-Free
13th June 2011, 10:41 AM |#15  
OP Senior Member
Thanks Meter: 396
 
More
Thanks Dennis, i was too lazy to do it
24th June 2011, 12:31 AM |#16  
jjwatmyself's Avatar
Senior Member
Thanks Meter: 1,242
 
More
Thumbs up
Quote:
Originally Posted by crnkoj

So guys, here is a quick tutorial how to fix your nonworking wifi in certain countries. The problem for it not working is that motorolas wifi driver is missing some country codes ... i guess they still live 20-30 years back, if anyone has the will to do it, we might post on motos forums to change the driver int he upcoming updates/releases. Here is the link to working wifi drivers: http://www.megaupload.com/?d=V8TGAY0C
if anyone can host it on a better location, feel free to do so.
I AM NOT RESPONSIBLE FOR ANYTHING THAT HAPPENS TO YOUR PHONE, YOU OR TO ANYTHING THATS IN RELATION WITH THE PHONE OR YOU.
this tutorial will be for use with adb shell (if anyone wants to make a script or a batch or even cwm flashable out of it, be my guest, i dont really have the time and my knowledge is a tad limited in doing those things )
Prerequisites:
1.the wifix.zip
2.adb on your computer with at least some adb/linux terminal knowledge
3.rooted ATT Atrix (i tested it on mine thats from ATT and several others did too, dont know if anyone tried with the bell or other atrix's but im sure it should work)
4.some common sense
5. i assume you have am external sdcard aswell (if not swap the sdcard-ext for sdcard only to use the internal card)

Code:
TURN OFF WIFI in the settings/wireless networks menu
1.connect phone to computer with us on usb mass storage mode and without adb debugging, create a folder called wififix on your external sdcard, unzip and copy the three .bin files to that folder
2.do the safely remove on windows/linux and than change connection to none, disconnect usb, enable adb debugging and reconnect your phone to the usb
3. run cmd/terminal
4. write as follows, after each line press enter:
adb shell
su (allow su on your phones display if its the first time you are using adb with su)
mount -o rw,remount -t ext3 /dev/block/mmcblk0p12 /system
rm /system/etc/firmware/wifi/*.bin
cp /sdcard-ext/wififix/*.bin /system/etc/firmware/wifi/
chmod -R 0755 /system/etc/firmware/wifi   (you can use chmod 755 /system/etc/firmware/wifi/*.bin )
reboot
5. let your phone reboot, disconnect usb, unlock phone, enter pin, enable wifi and its working.
Feel free to comment in the thread and help eachother with problems and ideas

Quote:
Originally Posted by _Dennis_

I made an update.zip for CWM if you need it. THis way you just have to apply the update after SBF/root. It SHOULD work....I did not try it.

Contribute, collaborate, conquer!! Outstanding.

It just seems strange that the OS wouldn't let you choose your country, like most routers already do... or is that taboo? Is wifi on Android mobile/cellular dependent? If so... what think tank came up with that...? How does Windows (desktop) handle this? It's not like laptops don't go on airplanes and visit other countries!!! BTW I can't believe I had to specify 'desktop'... I was thinking/worried ... "What if someone thinks I mean Windows (phone)." Seriously... who has a Windows phone? Let me re-phase... Who would be reading this specific thread and have a windows phone?
24th June 2011, 10:04 PM |#17  
shawnbuck's Avatar
Retired Recognized Developer
NY
Thanks Meter: 88
 
More
Quote:
Originally Posted by genatsvale

on the line: chmod -R 0755 /system/etc/firmware/wifi

I get: Bad Mode

then I use: chmod 755 /system/etc/firmware/wifi/*.bin

and after reboot the same problem... WiFi appears for few seconds and gets lost

The fix for that is to switch the numbers and -R, chmod expects to the the numbers first.

Code:
chmod 0755 -R /system/etc/firmware/wifi
1st July 2011, 12:44 PM |#18  
Senior Member
Flag Halifax
Thanks Meter: 17
 
More
Guys, before applying this method to my Bell Atrix (using it in Qatar, WiFi not working), I need to know:

1) Given it's a Bell Atrix, is there anything different I need to do?
2) Which root method should I use?
3) Did Bell's update fix this? Will this conflict with Bell's update? I'm planning to update my software once I get WiFi working.

Thanks
1st July 2011, 10:02 PM |#19  
Senior Member
Flag Halifax
Thanks Meter: 17
 
More
Can I apply this fix AFTER deodexing?
2nd July 2011, 08:48 AM |#20  
Senior Member
Flag Halifax
Thanks Meter: 17
 
More
NOT WORKING for me either.

Rooted using Gladroot.
Non-deodexed Bell Atrix.
Followed all instructions.
2nd July 2011, 09:19 AM |#21  
OP Senior Member
Thanks Meter: 396
 
More
it should be working, it worked for anyone who tried with this problem until now... have you chown chgrp and chmod the files properly?
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Message:
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes