FORUMS
Remove All Ads from XDA

[RECOVERY] CWM for the SK4G. Enjoy!

2,226 posts
Thanks Meter: 3,118
 
Post Reply Email Thread
15th June 2011, 03:16 AM |#11  
Retired Forum Moderator / Retired Recognized Developer
Thanks Meter: 641
 
Donate to Me
More
Post Nand backup error
with the new recovery (remapped buttons) i tried to do a nand backup and it wouldnt start and it'd auto matically say error while backing up boot image... can anyone see if they come across this aswell ..
 
 
15th June 2011, 03:17 AM |#12  
Quote:
Originally Posted by mattpall

Krylon... quick question... how much effort would it be to make a "reorient kernal" similar to wat the captivate had so it could use i9000 roms. Since this phone is basically a galaxy s...

Sent from my SGH-T839 using XDA App

this phone is not basically a galaxy S. heck, when the SGS4G came out people said it was basically a vibrant. NOPE. Wrong.

It would be hard to do, but might be doable.
The Following User Says Thank You to krylon360 For This Useful Post: [ View ] Gift krylon360 Ad-Free
15th June 2011, 03:18 AM |#13  
Quote:
Originally Posted by ayoteddy

with the new recovery (remapped buttons) i tried to do a nand backup and it wouldnt start and it'd auto matically say error while backing up boot image... can anyone see if they come across this aswell ..

didn't you test this?
15th June 2011, 03:21 AM |#14  
Retired Forum Moderator / Retired Recognized Developer
Thanks Meter: 641
 
Donate to Me
More
Quote:
Originally Posted by mattpall

Krylon... quick question... how much effort would it be to make a "reorient kernal" similar to wat the captivate had so it could use i9000 roms. Since this phone is basically a galaxy s...

Sent from my SGH-T839 using XDA App

if we could get a stock kernel with just the ext4 patch so we would be able to run our system, data and cache on ext4 i'd be pleased enough . idk if anyone with this phone would be able to rebuild the kernel with that patch but if so our phones would easily be 3x faster
15th June 2011, 03:22 AM |#15  
Retired Recognized Developer
MN
Thanks Meter: 333
 
Donate to Me
More
I also see the same problem. I didn't think to test backups. What was all changed from the working version to the current version? all that needed to be changed was the lun map and BOARD_USES_CUSTOM_KEYMAP
15th June 2011, 03:24 AM |#16  
Retired Forum Moderator / Retired Recognized Developer
Thanks Meter: 641
 
Donate to Me
More
Quote:
Originally Posted by krylon360

didn't you test this?

yes i tested the original one completely and everything worked, the new one you sent me i only tested the buttons and mapping which were fine . but it seems now the nand backup/restore has a problem.

Edit: i just made another nand backup with the original recovery without the back button mapping and it works. seems the edited one got the backup/restore broken somehow
The Following User Says Thank You to ayoteddy For This Useful Post: [ View ] Gift ayoteddy Ad-Free
15th June 2011, 03:24 AM |#17  
Quote:
Originally Posted by ayoteddy

if we could get a stock kernel with just the ext4 patch so we would be able to run our system, data and cache on ext4 i'd be pleased enough . idk if anyone with this phone would be able to rebuild the kernel with that patch but if so our phones would easily be 3x faster

not hard to do at all. unpack, add in ext4 mount options, repack, then flash kernel, and script to convert.
The Following User Says Thank You to krylon360 For This Useful Post: [ View ] Gift krylon360 Ad-Free
15th June 2011, 03:25 AM |#18  
Senior Member
Thanks Meter: 19
 
More
Quote:
Originally Posted by sduvick

I also see the same problem. I didn't think to test backups. What was all changed from the working version to the current version? all that needed to be changed was the lun map and BOARD_USES_CUSTOM_KEYMAP

Omg didn't test backups? :facepalm

Sent from my SGH-T839 using XDA App
15th June 2011, 03:26 AM |#19  
Quote:
Originally Posted by ayoteddy

yes i tested the original one completely and everything worked, the new one you sent me i only tested the buttons and mapping which were fine . but it seems now the nand backup/restore has a problem.

Edit: i just made another nand backup with the original recovery without the back button mapping and it works. seems the edited one got the backup/restore broken somehow

the new one all I did was change key mapping and UMS path... odd.
15th June 2011, 03:27 AM |#20  
Datlilboricua's Avatar
Senior Member
Flag new jersey
Thanks Meter: 65
 
Donate to Me
More
Ok I did the recovery to system bin and did the update it changed to cwm and I tried nand errors out I reboot and reboot back into recovery I'm back to stock recovery

Sent From My Rooted Sidekick 4g Premium XDA App
15th June 2011, 03:28 AM |#21  
Retired Recognized Developer
MN
Thanks Meter: 333
 
Donate to Me
More
Quote:
Originally Posted by mattpall

Omg didn't test backups? :facepalm

Sent from my SGH-T839 using XDA App

I don't customarily use backups, so that was not my focus.

Odd, the lunfile mapping in my version never caused any issues with backup. Perhaps the original modded version depended on the lunfile?
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Message:
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes