FORUMS
Remove All Ads from XDA

[Ad hoc] Ad hoc problem on i9003 not solved

48 posts
Thanks Meter: 3
 
By mohamadfar, Member on 3rd July 2011, 03:43 PM
Post Reply Email Thread
13th July 2011, 09:27 AM |#11  
bala242's Avatar
Senior Member
panruti,tamilnadu
Thanks Meter: 73
 
More
Quote:
Originally Posted by mzone1510

Try BZEEK Its really good, I Use it quite often and it really works well for me!

ya man u rock,it working.finely i use my Internet thank you
 
 
13th July 2011, 01:48 PM |#12  
micmaccc's Avatar
Senior Member
Thanks Meter: 39
 
More
Quote:
Originally Posted by bala242

ya man u rock,it working.finely i use my Internet thank you

u should change the title to solved
13th July 2011, 04:55 PM |#13  
Junior Member
Flag Nanjing
Thanks Meter: 0
 
More
It is said that using win7 instead of XP can perfectly solve this problem, but my laptop is too old for win7. Bzeek creates an ad-hoc connection, I used a software which also creates one, but my device can't find it. WiFi Manager can find it, but it says "Android does not support connecting to Ad-Hoc(IBSS) type networks".
14th July 2011, 05:58 PM |#14  
Senior Member
Flag Goa\Kuwait
Thanks Meter: 19
 
More
Quote:
Originally Posted by bala242

ya man u rock,it working.finely i use my Internet thank you

No problem mate! Even I tried searching so hard for what you were looking out for, tried everything but only this worked, It seems that connectify & virtual router don't work with intel Wi-fi chipsets which I guess is the most common one...
22nd July 2011, 05:42 PM |#15  
Senior Member
Flag Here >
Thanks Meter: 48
 
More
it works on some htc and galaxy s i9000 and other old galaxy s models
24th July 2011, 12:53 PM |#16  
OP Member
Flag Tehran
Thanks Meter: 3
 
More
BZEEK & connectify & virtual router don't work with my Vaio loptop (LAN-Express AS IEEE 802.11g PCI-E Adapter)

Ad-hoc is most problem of android. Plz help ...
25th July 2011, 11:09 AM |#17  
krazy_about_technology's Avatar
Retired Recognized Developer
Flag Pune
Thanks Meter: 65
 
Donate to Me
More
If you are using Windows 7, you can use a hidden feature called HostedNetwork which essentially does the required thing, Creating a virtual wifi router. This functionality is in Windows 7 half baked, there is no UI for this but it works very nicely. To enable it:

1. Go to an Administrative command line window and run the following command:

Code:
netsh wlan set hostednetwork mode=allow ssid=<AnyName> key=<Any 8 character Password>
2. Configure Internet Connection Sharing (ICS)

- Press Win Key+R, type ncpa.cpl in the Run dialog and hit enter.

- Select the interface that currently has Internet connection (like your Ethernet or normal wifi). Go to its properties, go to Sharing tab and then enable the sharing. Choose the special “hosted” interface (sometimes called a Virtual Wifi Miniport) in the drop down. Close the dialog by hitting OK.

3. Start the hosted interface by typing in this command on command line:

netsh wlan start hostednetwork


4. Connect to the internet using the dialer if you have one of those USB internet dongles.

Thats it, search for the Wifi network you created from your phone and connect to it. You're done!

Sometime, if you get an error while starting up the HostedInterface try doing this :

First, try rebuilding your tcp ip stack by doing the following:

1. Start an elevated/administrative command prompt window.
4: Type the command :
Code:
netsh int ip reset
in the Command Prompt shell, and then press the Enter key.

5: Restart the computer.

If this doesn't help, then disable internet sharing. After that disable the HostedNetwork by using command:

Code:
netsh wlan set hostednetwork mode=disallow
After that restart your computer and set up the connections again.

By default when you share a internet connection it will automatically make the wifi mini port a DHCP server, however some phones may have an issue with this so you could also try setting a static IP address on the phone that is in the same class and subnet as your Virtual Miniport connection.

As a sub note when you set this up make sure you only have one wifi device available (i mean one physical device) if you have two wifi cards on your computer unplug one of them or disable it when you first setup the wifi mini port (the steps in my original post).

Hope this post be helpful to you. Good luck!
9th August 2011, 12:39 PM |#18  
OP Member
Flag Tehran
Thanks Meter: 3
 
More
I try it, but not work in my vaio. need more help for android ad-hoc.
11th August 2011, 06:53 PM |#19  
Senior Member
Flag Here >
Thanks Meter: 48
 
More
Quote:
Originally Posted by mohamadfar

I try it, but not work in my vaio. need more help for android ad-hoc.

you need a new usb wifi device that can support Soft-AP
14th December 2011, 07:53 PM |#20  
Junior Member
Thanks Meter: 7
 
More
I have tried all ways to get ad-hoc wifi on my phone , yet nothing till date seems to work.
1)wpa_supplicant method (Wifi Analyser can see the ad-hoc connection but can't connect)
2)reverse tether by bridging connections and then dhcp eth0 method (here this doesnt work because it only shows tiwlan0 and 'dhcpcd tiwlan0' doesnt work)
3)softwares like connectify , mhotspot etc do not work for me either.

Now i hope , developers come out for a way to provide this feature as soon as possible.

Hopefully , i find this link hxxp://code.google.com/p/adhoc-on-android/

Somebody pls get behind this!
25th December 2011, 07:13 PM |#21  
Member
Flag Hyderabad
Thanks Meter: 9
 
More
Ive searched for week to get my phone connect to the ad-hoc networks. but i failed miserably. instead i used connectify to generate access point network. my phone connects and ive been using it for 4-5 months without any problem.

My advice would be to try that.. you can see the supported wireless drivers in the connectify website.. All the best
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Message:
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes