FORUMS

[WARNING] Do not downgrade to 1.0xxxxx after root.

6,332 posts
Thanks Meter: 15,901
 
By jcase, Retired Forum Moderator / Senior Recognized Developer - Taco Vendor on 26th March 2011, 05:10 AM
Post Reply Email Thread
I should of published this notice sooner. This was discussed early on, but we didn't think anyone would downgrade to the buggy firmware after rooting.

We were wrong.

Newer hboots (like the one in stock, hboot version 1.04.0000) flash/check images in an way that prevents the phone from encountering a SECURITY WARNING mid flash. This is good, prevents us from bricking.

Older hboots, like the one in 1.03.605.10 (hboot version 0.95.0000) on the otherhand do not, and flashing over custom firmware with them can lead to the dreaded SECURITY WARNING. This firmware is from January 3rd, is buggy and well should not be used for any reason outside of initail root. Avoid it.

A tester helping develop a one click root encountered this today, he tried to downgrade from custom firmware.

So, do not downgrade below 1.12.605.6 without a reason, if you do understand how to recover. You most likely have no reason to be on old firmware at this point, outside of initial root.


If you have a SECURITY WARNING, don't freak.

Recovering from this error:

Until we have newer RUUs, you only have one maybe two chances to do this. Since you obviously know how to flash an RUU, I am not going to go through the
process again.

Flashing this firmware the stock (1.12.605.6) firmware will fix this error.
LINK: http://www.multiupload.com/JWLPZAS15T

However if you get a MAIN VERSION HIGHER error while flashing, you only have one choice to recover, by flashing the newer than stock (1.12.605.9) firmware.
LINK: http://www.multiupload.com/UF40S2HZA7

If you are having issues, or are freaked out come find me in the chat (check my signature for a link). If I help you, I expect a donation to the Boys and Girls Club in the name of REWT.

-jcase


The Following 22 Users Say Thank You to jcase For This Useful Post: [ View ]
29th March 2011, 07:00 AM |#2  
Captainkrtek's Avatar
Retired Recognized Developer / Retired Forum Moderator
Flag Seattle
Thanks Meter: 568
 
1010
More
bumpity bump!
29th August 2011, 08:43 AM |#3  
Member
Thanks Meter: 0
 
More
hello there i got the exact thing on my TB and i downloaded the files to fix it but i get back a Main Version Older am i doin somethin wrong
29th August 2011, 01:26 PM |#4  
scotty1223's Avatar
Inactive Recognized Contributor
Thanks Meter: 3,071
 
More
you can only flash files that are newer than your firmware. what were you trying to flash,overtop of what, when you got this security warning?
29th August 2011, 10:41 PM |#5  
Member
Thanks Meter: 0
 
More
Quote:
Originally Posted by scotty1223

you can only flash files that are newer than your firmware. what were you trying to flash,overtop of what, when you got this security warning?

i was trying to flash this [ROM][TH3ORYROM] SHIFTAO5P V1.2X [AOSP/CM7] Eclipse B5 Kernel (8/26/2011) but when i was trying to flash the radio, i wasnt getting any receptions and i tried all four radio listed, so my stupid self thinkin hey let me use the radio PM05IMG from the root process and see if that would work, well as soon as the bootloader started flashin the files it pop back into bootloader with the security warning, i tried the file the jcase said to use to get out of that problem but the file never open or go thru it come back saying Main Version Older file not updated.
29th August 2011, 11:20 PM |#6  
scotty1223's Avatar
Inactive Recognized Contributor
Thanks Meter: 3,071
 
More
"Main version higher" means that the firmware you're trying to flash is older than the firmware on the phone.

Have you tried both files above? If so,the next thing I would do is try and flash the mr2 ruu(1.70.605.0) it is newer than both files above,and both of the root files(downgrade and mr1 upgrade) so that one should work for you.

Afterward,you can run revolutionary to reroot and not encounter this prollem again when you flash something that you should have researched more before flashing.

Sent from my SHIFTAO5P using XDA Premium App
29th August 2011, 11:52 PM |#7  
Member
Thanks Meter: 0
 
More
Quote:
Originally Posted by scotty1223

"Main version higher" means that the firmware you're trying to flash is older than the firmware on the phone.

Have you tried both files above? If so,the next thing I would do is try and flash the mr2 ruu(1.70.605.0) it is newer than both files above,and both of the root files(downgrade and mr1 upgrade) so that one should work for you.

Afterward,you can run revolutionary to reroot and not encounter this prollem again when you flash something that you should have researched more before flashing.

Sent from my SHIFTAO5P using XDA Premium App

Hey there Scotty i really appreciate you helping me out here, im sitting at work with my TB stuck in Bootloader, getting ready to bust out my old rooted Eris out, but ima go and try that MR2 RUU do you have a link to where i can download that. and also where you said Main Version Higher mines Said Main Version Older,

and yes i thought i did everything correctly i mean i guess since i had the rom flashed but wasnt getting any reception made me make the stupid mistakes, by the way scotty do you have a tb
30th August 2011, 01:58 AM |#8  
scotty1223's Avatar
Inactive Recognized Contributor
Thanks Meter: 3,071
 
More
i have never seen "main version older" but it means the same thing... the firmware youre trying to flash is older that what is on the phone.

you can download MR2 from here: http://forum.xda-developers.com/show....php?t=1160286

just put your sd card in a cardreader to transfer and rename PG05IMG and flash in hboot. let us know how it goes.

and yes,i have a TB.
30th August 2011, 02:13 AM |#9  
Member
Thanks Meter: 0
 
More
Quote:
Originally Posted by scotty1223

i have never seen "main version older" but it means the same thing... the firmware youre trying to flash is older that what is on the phone.

you can download MR2 from here: http://forum.xda-developers.com/show....php?t=1160286

just put your sd card in a cardreader to transfer and rename PG05IMG and flash in hboot. let us know how it goes.

and yes,i have a TB.

Ok ima download it but my other prblem is that the phone doesnt charge the battery its not enough voltage to run the files, i have no other way of charging the phone i might have to buy a battery charger or somethin
30th August 2011, 11:26 AM |#10  
scotty1223's Avatar
Inactive Recognized Contributor
Thanks Meter: 3,071
 
More
only thing i know of is to use an external charger,or swap it into a good TB. if you have to,you could take it to a store and see if they will put it in a phone and charge it for you,tho i would take some care in what you tell them as to why you need to do that

i got an external charger and 3 extra generic batterys on ebay for about $30 so i wont ever ben in that situation. i dont like charging my phone during the day so i just go until it shuts off then put in a new battery.

ive heard of people hacking up usb cables to directly power the phone,but thats not something id really reccomend.

at any rate youre good to be caustious,an hboot flash is NOT a time that you want to run out of battery
30th August 2011, 05:10 PM |#11  
marcogiudice's Avatar
Member
Flag J-town, fl
Thanks Meter: 13
 
More
take an old pair if headphones and strip them til you have only the cooper wire and connect them to the gold connector from your phone to your eris battery and that should work
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Message:
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes