FORUMS
Remove All Ads from XDA
H10 GPU

Permanently disable android market update

449 posts
Thanks Meter: 46
 
By @Class, Senior Member on 17th December 2010, 04:28 PM
Post Reply Email Thread
9th September 2011, 09:20 AM |#21  
Junior Member
Flag Poltava
Thanks Meter: 0
 
More
But what is worse new market apk size is 7Mb, previous was only ~1.5Mb.
On my Gigabyte GSMART that is a problem.

I also had freezed market updater.
 
 
24th September 2011, 11:10 AM |#22  
Junior Member
Flag Jeddah
Thanks Meter: 5
 
More
Lightbulb Diable android market update
I didn’t like the new android market application, and I’m not the only one. If you want to get back to old one, application name is Vending.apk available in the \system\app\ folder, you can just replace it from your old stock ROM. The easiest way is to send your old Vending.apk by bluetooth or cable to your phone and then use Root explorer to move it to the \app folder by overwriting existing one, of course to do that, you need root access. Do not forget to wipe Dalvik cache. Some developers offer a convenient package to be installed in recovery mode.

But even after rolling-back, Android Market application gets automatically updated and there’s is no option to disable this update. We can fix this by using Terminal Emulator. We will gain root access and then disable the updater application:

1) su -
2) pm disable com.android.vending.updater
That’s it, and if by chance things go wrong, you can just enable updating.
The Following 5 Users Say Thank You to frsfrs For This Useful Post: [ View ] Gift frsfrs Ad-Free
26th September 2011, 01:19 PM |#23  
Member
Thanks Meter: 3
 
More
Quote:
Originally Posted by dorqus

"pm disable com.android.vending.updater" should stop the market from auto-updating on you (You need to do this from a terminal session (or via adb shell) and you need to be rooted.

Thanks from me too! A very useful information for me!!

schnurzelat
27th September 2011, 10:29 AM |#24  
Member
Thanks Meter: 2
 
More
Market 3.1.3 always crashes on my HTC Desire CM 7.0.3 and I really must find a way for market not to update itself... Somebody got a solution?


edit: Messages here comes so fast.... someone said that terminal emulator fix in the meantime, thanks... will try that.
3rd October 2011, 03:57 PM |#25  
Junior Member
Thanks Meter: 0
 
More
Quote:
Originally Posted by dorqus

"pm disable com.android.vending.updater" should stop the market from auto-updating on you (You need to do this from a terminal session (or via adb shell) and you need to be rooted.

Hi, have exactly the same problem and would like to use your suggested fix. Don't know anything about ADB programming and have just rooted my phone over the weekend. Could you pls provide the exact steps to get to "pm disable com.android.vending.updater"? Thank you.

Edit: have read multiple threads and have tried to put together the following steps below but I have no clue if they are correct and would like to seek advice.

1. with phone turned on normally (in Redux 1.2) and Market v3.1.5 uninstalled and rolled back to Market v2.3.3 and Force Closed
2. enable USB Debugging
3. disable Fastboot (how do you do this with Redux 1.2? I can't find a Fastboot toggle anywhere)
4. connect via USB cable
5. place in "Charge Only" mode (again I can't find this option with Redux 1.2. It only says USB connected and has the option to turn on/off USB storage. Before rooting there were 3 or 4 options provided - charge only, HTC sync, disk drive are what i remember)
6. from computer go to Start, type "cmd". I have set up my ADB pre-rooting, so I assume the next steps should be to type in:
7. "adb devices" <enter> and my device serial number appears
8. "adb shell <enter>
9. now I get a "#" sign (is this correct or should it be a "$" sign?)
10. from the thread comments above should I do the following?
11. type "su" <enter>
12. type "pm disable com.android.vending.updater" <enter>
13. close cmd window
14. unplug phone
15. turn off phone
16. turn on phone

Thanks again
6th October 2011, 06:16 AM |#26  
Prawesome's Avatar
Senior Member
Flag Error 404- Not found
Thanks Meter: 1,740
 
More
Cool
Try freezing market updater using antTek app manager
7th October 2011, 02:00 AM |#27  
Junior Member
Thanks Meter: 0
 
More
Hi, thanks for all your replies. I did the following and it worked

1. with phone turned on normally (in Redux 1.2) and Market v3.1.5 uninstalled and rolled back to Market v2.3.3 and Force Closed
2. enable USB Debugging
3. disable Fastboot (apparently already disabled even though I can't a toggle anywhere)
4. connect via USB cable
5. place in "Charge Only" mode (again is apparently already on charge mode until I enable USB storage)
6. from computer go to Start, type "cmd". I have set up my ADB pre-rooting
7. "adb devices" <enter> and my device serial number appears
8. "adb shell <enter>
9. now I get a "#" sign (which reflects my superuser status; if not I would have gotten a $ sign)
10. type "pm disable com.android.vending.updater" <enter>
11. close cmd window
12. unplug phone
13. turn off phone
14. turn on phone

Works great now.

I have also installed the Terminal Emulator as suggested above, and will use that in future to re-enable the updater if goggle fixes the Market problem. In any case I prefer the look and feel of the older market vs the new one.

Regards
7th October 2011, 05:55 AM |#28  
Junior Member
Thanks Meter: 3
 
More
I got this idea from

prepaidandroids.net/topic/2405-guide-disable-market-update
(sorry, i can't use url when post)

and need root explore or something like that to change MarketUpdater.apk to MarketUpdater.apk.bak

---origin post---

If for some reason you choose to stick with the earlier version, rather than the latest version of the market, here's how to disable the update.

NOTE: Phone must be rooted and have super user rights.

1. Go into your system/app folder and rename MarketUpdater.apk to MarketUpdater.apk.bak. (I would suggest a rename instead of deleting the apk)
2. If the market has already updated, after doing step 1, go to Settings > Applications > Manage applications.
3. Scroll down to Market, click on it and choose Uninstall updates.

Done. No more market update.
The Following 3 Users Say Thank You to wordsleft For This Useful Post: [ View ] Gift wordsleft Ad-Free
31st October 2011, 08:29 AM |#29  
ayyu3m's Avatar
Senior Member
Flag System Error
Thanks Meter: 272
 
More
thankx guys. worked for me using a terminal emulator on device.
26th March 2012, 01:38 PM |#30  
Junior Member
Thanks Meter: 1
 
More
Quote:
Originally Posted by dorqus

"pm disable com.android.vending.updater" should stop the market from auto-updating on you (You need to do this from a terminal session (or via adb shell) and you need to be rooted.


and how exactly to re-enable ?
I tried pm enable com.android.vending.updater but that didn't work.
22nd September 2012, 06:00 PM |#31  
Junior Member
Thanks Meter: 0
 
More
Unhappy Auto Update
Quote:
Originally Posted by phuthanvinh

Android apps don't update themselves unless you allow them by checking the "automatic update" box. Uncheck that and see what happen. I've never encounter an app updates itself without my permission, unless I misunderstand your question?



Yeah (misunderstood)
Iv'e got the same frustrating issue with Android Market updating itself.
The problem is that unlike other apps Android Market does not have the little
check box to uncheck auto update.It just updates whenever there's an update available.
Same goes for Google Maps.I don't know why that is but I do know that it's darn irritating!
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Message:
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes