Remove All Ads from XDA

Linux ON droid not IN android question????

60 posts
Thanks Meter: 8
By darkreaper476, Member on 25th October 2011, 03:19 AM
Post Reply Email Thread
Ok, this goes out to any and all DEVs out there. We all know by now that we (some people not me) can run linux within android using the loop mounts, vnc viewer, etc... Now how about REPLACING android with a linux distro like debian or maybe even what these guys use ..... its linux based and has an arm CPU.. Any way I'm talking about flashing over android wiping the internal sorage and installing linux on it or even using the boot loader to flash over android???, of course this is getting rid of any 3g connection and phone usage. I understand that, I am talking about giving our RETIRED droid 1s a use. I wanna see my D1 run a linux distro in full hardware mode NO MORE ANDROID. now dont get me wrong I love android as much as the next guy, but why now flash something else to it???

Another link I found, this is for windows mobile but hey, similar idea.

P.S. I AM NOT A DEV JUST AN IDIOT WITH AN IDEA!! my ignorance is NOT bliss and I would love to know if this is even possible. I'm willing to help ANY WAY I CAN. lol

The Following 2 Users Say Thank You to darkreaper476 For This Useful Post: [ View ] Gift darkreaper476 Ad-Free
25th October 2011, 07:17 AM |#2  
Eiertschik's Avatar
Senior Member
Thanks Meter: 67
I don't think it's possible. Because of the locked bootloader we're forced to use Motorola's bug-ridden Kernel and as Android's Kernel is a heavily modified Linux Kernel it most likely won't run an ordinary Linux distro.

But I'm no expert either
25th October 2011, 10:41 AM |#3  
Thanks Meter: 8
Milestone is locked, Droid is not ...
25th October 2011, 03:40 PM |#4  
adamz667's Avatar
Senior Member
Flag Warsaw
Thanks Meter: 648
Donate to Me
Maybe this will help (if you don't know german, you can use Google Translate):
25th October 2011, 06:39 PM |#5  
OP Member
Thanks Meter: 8
Thanks for the replies. Again the USA Droid 1 is nit locked or at least has been completely unlokcked. I've read a million "run debian on android" posts... I don't need to know German to see that the post above is the same thing. Like I said before I have NO INTEREST IN RUNNING LINUX ON ANDROID. I want TO REPLACE android completely with Linux to make a device like the openpandora handheld from my first link.

Any one up to the challenge????

Thanks again!
26th October 2011, 06:30 PM |#6  
OP Member
Thanks Meter: 8
Really, no one??
27th October 2011, 04:45 AM |#7  
Senior Member
Thanks Meter: 209
Donate to Me
I've been running Debian on my Droid booting from the SD card for a while, more recently trying Arch Linux after realizing that anything optimized for ARMv7, VFPv3, NEON, or Thumb-2 (I'm not sure which unfortunately) won't boot because of a page fault or something. Ubuntu, MeeGo, and Angstrom just kernel panic and don't give any useful information even at the highest debugging level. I'm back to using an ARMv5te Arch Linux build ( although I could just as well use Debian. I really wish Ubuntu worked for multitouch.

Well, I got the touchscreen calibrated! I forgot that my screen rotation hack only rotated the framebuffer It's stuck in portrait for now. I decided to use mtev (MeeGo's multitouch X11 input driver) after being fed up with evdev's aversion to being rotated, but now that I'm back to the stock portrait rotation evdev should work fine.

If you want instructions, either PM me or wait until I post a full guide and/or my patched kernel tree. It's not super difficult, but it's a lot of command line use and compiling.

What works:
*CPU and SD card (obviously :P)
*Touchscreen (single touch/portrait only for now)

What needs work:
*Keyboard mapping is wrong, the number keys and symbols don't work. I need to figure out how Android handles Alt. I had to patch the GPIO keyboard driver because the keyboard worked in the console but not in X11, which expects EV_SYN.
*Sound is OSS only, but there is no mixer device, so aumix is useless and there's no volume control or sound output.
*I haven't tried the SGX driver, so I can't comment on hardware acceleration yet.
*Battery charging relies on battd, which is a proprietary Android binary from Motorola. It might run on Debian with "ls -s / /system" and the creation of the socket it expects (init.sholes.rc I believe), but I'm not getting my hopes up.

*WiFi (needs firmware, but should work)
*Sensors (although the accelerometer and compass seem to be recognized by evdev)

I'll upload my kernel, either as patches or on GitHub (or binaries if there's enough demand) once I get around to fixing the keyboard issue. Fingers crossed that I don't get carried away cleaning up the kernel, or worse yet, give up...
The Following User Says Thank You to DrGit For This Useful Post: [ View ] Gift DrGit Ad-Free
27th October 2011, 06:38 PM |#8  
OP Member
Thanks Meter: 8
This is incredible news! I'm so glad to hear it. Of course you are running in hardware mode? Not through android? If so I'm super exited about this! I love arch Linux, I run it on all my computers and I understand it more than any other distro I've tried. I would love to give it a shot, though I'm not that great at compiling I think it will be worth it.

As I said before I am in no way a dev or even a Linux pro, but I can get by and if theres any way I can help this project become "complete" I'm willing to learn what ever is necessary to do so.

Also were u able to get an x server running? Possibly a DE? That would be crazy awesome.

Thanks a million, looking foreword to work with you and make this happen!
28th October 2011, 12:39 AM |#9  
Senior Member
Thanks Meter: 209
Donate to Me
For anyone who's interested, I put together a quick package containing my kernel patches, configuration notes, and an automated kernel build script.

It's pretty self-explanatory aside from the installation of the root filesystem, which I leave up to your imagination :P

As I've probably repeated several times now, I've run Debian and Arch Linux natively on my Droid with my patched kernel (no chroot or VNC "hack"). With enough determination, it's possible to run practically anything on it - personally, I'm determined to get Ubuntu on it.
Attached Files
File Type: zip - [Click for QR Code] (48.1 KB, 313 views)
The Following User Says Thank You to DrGit For This Useful Post: [ View ] Gift DrGit Ad-Free
28th October 2011, 01:42 AM |#10  
OP Member
Thanks Meter: 8
WOOT... insta-fail for me LOL you have it set up to work in specific directories? I thought i placed everything right but I guess not.. I got an error on the first line of output lol

Welcome to gTan64\'s lazy Droid kernel compiler\! line 5: [: missing `]' line 5: -z: command not found line 5: -z: command not found
Entering $WORK
Applying patches line 16: /*.patch: No such file or directory
mv: cannot stat `/arch/arm/boot/compressed': No such file or directory
cp: cannot stat `/compressed': No such file or directory
Setting up build
cp: cannot stat `/GNUmakefile': No such file or directory
cp: cannot stat `/sholes_config': No such file or directory
FIXME! No numeral or symbol input until someone finds a third-level
modifier key to use instead of AltGr for the keyboard.
cp $MISC/ $K_SRC/drivers/char
Building kernel!
make: *** No targets specified and no makefile found. Stop.
Kernel build done!

You have done something amazing, I'm just to stupid to figure it out my self. XD

I can understand why you would want ubuntu with all its pre-setup glory and support for nearly all hardware but dont you think its a little heavy for this hardware? lol I doubt you would try to use the Unity UI but I doubt that alone would even fit in ram LOL you could just use the ubuntu packages and drivers with debian maybe?

28th October 2011, 05:21 AM |#11  
Senior Member
Thanks Meter: 209
Donate to Me
That's what happens when I don't test my own scripts :P
I was thinking too much about making it easy. Just try applying my patches to your tree manually.
cd kernel_src
patch -p1 <../patches/first.diff
patch -p1 <../patches/next.diff #and so on...
#Obviously, substitute the paths of the actual patches ;)
#Finally, copy sholes_config to .config and invoke 'make'.
It's actually much simpler than my script makes it, and you don't need my convoluted folder setup.
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes