Remove All Ads from XDA

[Q] Help! Stuck in Kindle Fire Recovery

137 posts
Thanks Meter: 41
By bjanice44, Senior Member on 21st November 2011, 04:22 PM
Post Reply Email Thread
I tried the unbricking guide on here but did not work. I could not get fastboot to work.

Here is the exact message I get on the screen:
'Your Kindle has detected a problem and must clear app storage. The recovery process will erase some applications and data from your device. Apps from the appstore are stored in the cloud and can be reinstalled later.

This will reset your kindle to its original factory settings. you will need to re-register your kindle prior to downloading items from your Amazon account.

Please press power button to proceed.'

After i press the power button I get a status bar indicating the restore, it then says success, then reboots and ultimately comes back to the same restore screen as noted above.

Any help is appreciated.
1st December 2011, 03:36 AM |#2  
Junior Member
Thanks Meter: 0
I have the same issue, I had just used one click to gain root access and was changing permissions to instal Vending.apk under /system/apps

A bit more information I've gathered:

* I can run adb push/shell before the Kindle Fire starts the recovery mode.
* BUT when I try to run a adb shell command I get the error
/system/bin/sh failed permission denied (13)
I've spent the best part of the day trying to find a solution to no avail. I had a good read through this post too.

I did find a couple of threads talking about a factory reset cable, I don't know if this would be any good?

1st December 2011, 06:20 AM |#3  
Senior Member
Flag Illinois
Thanks Meter: 298
Donate to Me
As soon as i get my factory cable and time I'll make a guide. But really all you need to do is flash the images from the 6.2 update via fastboot
1st December 2011, 05:55 PM |#4  
Junior Member
Thanks Meter: 0
Yeah I got to that point to where it doesn't just go into logo, but infinitely boots you into recovery mode. when you launch adb it even says its recovery mode and all the folders are hidden/missing.

Sigh, I fixed my kindle and got it working again then I broke it again by accidentally changing the entire system folder to chmod 644 haha.

Anyways so far I have found no fix around it so I just returned it :P and got a new one. live and learn I guess.
1st December 2011, 07:47 PM |#5  
Flag The Shire
Thanks Meter: 7
Donate to Me
What did you do exactly to put it in a boot-loop? I did this once before by tampering with some system files, but i was able to push the regular one's back using adb.
2nd December 2011, 03:38 AM |#6  
Junior Member
Thanks Meter: 0
I made a factory cable and managed to get fastboot working to flash over a new system image.

Does anyone have a system.img file for the Kindle Fire?

OR know another way to bring up a shell via fastboot?

I might just wait till next week and see what the status is then on the CM7 ROM.
2nd December 2011, 07:29 AM |#7  
Junior Member
Thanks Meter: 0
I really need to get me one of those factory cables :S but they are sold out on black hat at the moment.
4th December 2011, 02:11 PM |#8  
Junior Member
Thanks Meter: 0
hey dk560 or JandD

how was u able to get ur kindle work again? where u get the recovery files or original files? my kindle stucks in flashin kindle fire screen over and over..

i try this

everything worked fine...but at the and had the same problem..i have normal acces with adb and all to the devide but iam not i get the original files back to the kindle? Or any help what i can try? i stuck....
plz any suggestions...thx!!
4th December 2011, 04:06 PM |#9  
Junior Member
Thanks Meter: 0
I dunno. But I think I may have the same issue. Got brick while doing wallpaper n now my fire stuck at fastboot and window cannot detect n fastboot nv finish the run always in waiting for device. Does this mean the doom for my 3 dar old kindle fire?
4th December 2011, 07:06 PM |#10  
Junior Member
Thanks Meter: 0
finally i solved it!!

thats what was my worked for me..after tmp root then this steps..and finally kindle was out of bootloop...thanks!!
5th December 2011, 12:15 AM |#11  
Junior Member
Thanks Meter: 0
I have follow that link, but my kindle now seem to be in fastboot n window detect kindle fire as unknown device. In cmd, device cannot be found, and fastboot rerun say waiting for device but nv work, I try, really wanna resolve the mess I created. I try to read n understand how to resolve but my current issue wasn't mention.
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes