Remove All Ads from XDA

CM7 for Kindle Fire (aka standing on the shoulders Giants)

88 posts
Thanks Meter: 264
By whistlestop, Member on 14th December 2011, 02:52 AM
Post Reply Email Thread

Ok, time to re-wrte the OP as there are now MUCH better tools for flashing the (and you can make backups) Make sure to say thanks to the TWRP team!!!. The file available here is a derivation of the work originally started by JackpotClavin (he did an initial proof of concept but a number of features that I wanted didn't work so I figured I'd pick up where he left off and see if I could get the ROM working for me with the missing features)

The initial thread was here if you care to look.

At this point sound, video (both in the browser and standalone) and hardware acceleration are now working with CM7 on the Fire. I'm off now poking at the MAC address issue and then I'm off to see about Bluetooth.

- 01/01/12 - Back from the break and starting to work on things again. I've had a number of people ask for my current configs so I set up a repo at https://[email protected]/whistlestop/CM7KF to let people track my progress. If you want to build your own KANG then below are the steps that I currently follow with the current repo files.

-Pull the CM7 source. Check out this link for a how to on that:

Symlink the amazon directories from the CM7KF repo into the CM7 tree. Specifically:
-cd <path to the CM7 tree>/vendor
-mkdir amazon
-ln -s <path to CM7KF tree>/vendor/amazon amazon
-cd <path to CM7 tree>/device
-mkdir amazon
-ln -s <path to CM7KF tree>/device/amazon amazon

Copy the file from <path to the CM7 tree>/vendor/amazon/blaze into <path to the CM7 tree>/vendor/cyanogen/products and add the following line to the file in the same directory.


Ok, go to the top of the CM7 tree and do ". build/ && brunch blaze" and go get a cup of coffee while it builds. It'll take awhile.

- 01/02/12 - New files uploaded that fix the MAC issue as well as the build issue with the library.

- 01/03/12 - New and files uploaded that fix the regression on the hardware acceleration. Sigh...

- 01/13/12 - Update to remove the recovery option on reboot (as it continues to cause problems for folks), removal of the search from the soft buttons by default, addition of the home to the soft buttons by default (again as that seems to be a constant question) While I built and tested the changes I didn't make the updates. You have IngCr3at1on to thank for that.

Backlog of tasks (as of 01/02/12)
-FIXEDSeems that all Wireless MAC IP's are the same (meaning that everyone that flashes the ROM will have the MAC of 08:00:28:12:03:58. While the first three octets register the MAC as being owned by Texas Instruments (the manufacturer of the OMAP chipset), the fact that the last octets don't vary is BAD. From a little Googling, I'm not sure this is something specific to this ROM/device as other CM7 ROMs on different devices seem to have the same issue but with a different MAC address it sounds. I'll look to make sure I'm not doing anything that is causing this issue. A tip of the hat to "TheKid2" for this post which appears to provide a hand workaround to the issue for now.
-The file is now signed but the isn't yet. I'll get to that but as it doesn't seem to cause any issue in flashing it's not too high on the list to chase given the two issues below.
-No Bluetooth (yet...) This is still my personal quest so once I get the base CM7 capabilities working then this is my next thing to poke at. From the postings/reading I've done so far this seems doable (just a matter of time and programming, no rocket science required it appears at this point)

Before you start, make sure your Kindle Fire is fully charged, rooted, you know your way around adb, your kindle fire actually connects to adb and works successfully and you've installed TWRP (and I recommend installing FireFireFire as well to keep from having to issue idme commands to get into the recovery image).

I used the directions here to get all the pre-requisites done. Assuming everything above is done, then it's time to install CM7.

First a note, installing CM7 will replace the current ROM on your device and I'm not responsible for any malfunctions :/ I've done this for versions 6.2 only so your mileage may vary (but there is a good group of members on this thread so they'll help out if possible)

If you're coming from a STOCK ROM then use this version to flash. It will wipe the data and cache partitions (as well as the system partition) as a part of the flash process which should get rid of any FC issues.
md5sum for

If you're upgrading from an EXISTING CM7 install then use this ROM instead. This one will NOT wipe the cache and data partitions which should mean that you can upgrade from one version of CM7 to another without losing any of your existing date (or that's at least the idea)
md5sum for
ab80c089d0c93f02bd7271c5e4401cf7 (CHECK THAT THIS MATCHES THE DOWNLOADED UPDATE.ZIP)

Copy the CM7 to the root of your sdcard, so it's /sdcard/ (e.g. "adb push /sdcard/")

If you want to add in the Google apps then:
-Download the gapps zip from here
-Copy them to your sdcard (e.g adb push /sdcard/ )

NOTE: if you have issues with the included Google Market FC'ing, then download this versions and it seems to fix the issue (again thanks to detnap in this thread for that tip)

Reboot into TWRP (when the FireFireFire screen comes up hit the power button to launch TWRP.
-If you reboot by holding the power button until the power screen comes up make sure when you select reboot that you DON'T say boot into recovery as this will put you into a loop where the device always boots into TWRP (even if you don't press the power button during the boot) READ THIS PART AS ALMOST EVERYONE IS MISSING THIS PIECE: If you find yourself in this loop then connect with "adb shell" and issue "idme bootmode 4000"
-For me I hold the power button until it goes orange. Just pressing it quickly doesn't do the trick at least for me.

Once it boots into TWRP then I ALWAYS recommend you perform a backup before you start anything (that way you can go back in case of a problem) You can do this by hitting the backup button.

Now that you have a backup, on the main TWRP screen hit the install button. This should put a list of the possible .zip files on your /sdcard partition in the right window. Tap the file you want to flash and hit the flash button (right now don't do any MD5 or signature checks as I've not yet got that included in the If you see some errors about not being able to load volume /misc don't worry, I see that right now as well and everything still seems to work. I'll chase that issue once some other bigger issues are run to ground.

If you are coming from a stock ROM then make sure to click the wipe Cache/Dalvik so that we rebuild everything for the new CM7 image. If you're coming from a previous CM7 ROM then you can skip this step (I at least have and everything appears to work fine and you don't have to re-install everything)

Now hit the reboot button and you should again see the FireFireFire yellow triangle again. It will sit there for a bit and then it will go away and you should be greeted with the CM7 boot screen. If everything goes well, then a few seconds later you should be sitting on the main page (in my case it takes me back to my lockscreen as I didn't wipe any of the cache or data partitions)

Ok, that's it or now. Have fun and I'll post an update when/if I get the MAC or Bluetooth issues resolved.
The Following 156 Users Say Thank You to whistlestop For This Useful Post: [ View ] Gift whistlestop Ad-Free
14th December 2011, 03:01 AM |#2  
Senior Member
Flag Atlanta, GA
Thanks Meter: 136
Donate to Me
So is the link to the the one with the sound fixed or calvins original?
The Following User Says Thank You to Unheard For This Useful Post: [ View ] Gift Unheard Ad-Free
14th December 2011, 03:07 AM |#3  
whistlestop's Avatar
OP Member
Flag Colorado Springs, CO
Thanks Meter: 264
Donate to Me
It's the updated ROM with the updated MD5SUM for the file.
The Following 3 Users Say Thank You to whistlestop For This Useful Post: [ View ] Gift whistlestop Ad-Free
14th December 2011, 03:19 AM |#4  
asatnik11's Avatar
Senior Member
Thanks Meter: 42
I can confirm this works. Thanks!

Sent from my Kindle Fire using xda premium
14th December 2011, 03:55 AM |#5  
Senior Member
Thanks Meter: 30

Sent from my Nexus S 4G using XDA App
14th December 2011, 03:56 AM |#6  
Senior Member
Thanks Meter: 79
woot woot! Can't wait til Christmas comes around so I can play with my moms new kindle fire

Sent from my SAMSUNG-SGH-I997
14th December 2011, 03:59 AM |#7  
Senior Member
Thanks Meter: 8
You mention the video is not working, is it meaning that the video player in CM7 can't play any format of video?

Or is it just the flash video in the browser?
14th December 2011, 04:07 AM |#8  
loki154's Avatar
Senior Member
Thanks Meter: 16
YouTube works, does Netflix?

Sent from my HTC Incredible 2 using XDA App
14th December 2011, 04:13 AM |#9  
Senior Member
Thanks Meter: 52
Just curious, how long does it take to go from stock to this cm 7?
14th December 2011, 04:15 AM |#10  
whistlestop's Avatar
OP Member
Flag Colorado Springs, CO
Thanks Meter: 264
Donate to Me
loki154: Veritass tested the for me and he said that netflix worked for him.

ck_looi: I haven't tried anything other than trying to play youtube videos in the browser and they cause the browser to exit.
The Following User Says Thank You to whistlestop For This Useful Post: [ View ] Gift whistlestop Ad-Free
14th December 2011, 04:17 AM |#11  
loki154's Avatar
Senior Member
Thanks Meter: 16
Ah yeah, flashing it now then.
Post Reply Subscribe to Thread

cm7, fire, kindle, sound, video

Guest Quick Reply (no urls or BBcode)
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes