FORUMS
Remove All Ads from XDA

[APP][25MAR10]Gen.Y DualBOOT v1.0.6.0[W|Q|VGA][CAB|EXT]

947 posts
Thanks Meter: 571
 
By yozgatg, Senior Member on 26th January 2010, 07:53 PM
Post Reply Email Thread
26th November 2011, 04:18 PM |#1111  
Retired Forum Moderator / Recognized Developer
Thanks Meter: 3,825
 
Donate to Me
More
Quote:
Originally Posted by sek2k

My problem is that the program erases the autostart entry as soon as I boot android. After a fresh installation or if I put in a new sim card the program loads automatically at start up (as it should).

But after I´ve started android the first time and have shut it down, the next time I boot windows mobile, Gen.Y Bootloader doesn´t´t start automatically anymore.

Does anyone know how to solve this problem?

P.S: I´m using HTC Touch Diamond with Windows Mobile 6.1 and Android NeoFroyo v0.1

I found that for whatever reason, WinMo's registry settings don't stick if you make a registry change and then boot Android. So what you need to do is make all your registry changes, close out of any registry editor (save if you have the option) then reboot the phone. Don't go to Android, reboot Windows Mobile. Make sure the registry options stuck, then boot Android. The registry settings should now persist. I have a feeling something is committed to the registry when Windows Mobile is properly shutdown, and getting kicked out of memory for Android is not a proper shutdown .

Quote:
Originally Posted by ny_2012

i use an htc t-mobile mda compact v, upgraded to 6.5, and i downloaded Gen Y dualboot and installed it but doesnt work, anyone please help me..

Please be more descriptive. No one can help you based on such little information. "doesn't work" isn't enough. What's wrong? Where are you failing? Did you bother reading the first post? Might have to read it several times, there's a lot of info to process there.
 
 
3rd December 2011, 06:58 PM |#1112  
Junior Member
Thanks Meter: 0
 
More
i installed the vga GenY-DualBoot the internal storage option onto my htc t-mobile mda compact 6.5 internal memory not th SD storage card but the android option doesnt work when i press it only the windows option works, the android option is dark and i dont know what to do, i installed it good, please help me
12th December 2011, 04:14 PM |#1113  
Junior Member
Thanks Meter: 0
 
More
Can Gen.Y autoboot be a little slower?
Is there a way to make Gen.Y autoboot into Android a little slower than it boots regularly. I noticed that when my phone autoboots Android, wifi doesn't work, it just says error. But if I happen to wait for WinMo to boot fully before running Haret (either directly or by running Gen.Y) the wifi functions well.

Does anyone know how one can delay autoboot for about a minute, I figure this will help? My registry values are okay, so I'll rule that out.
I run Energy Rom 6.5 on Sprint TP2 (Rhod400) and XDAndroid 2.2.2 FRX07.1

Thanks in advance.
13th December 2011, 07:15 AM |#1114  
Junior Member
Thanks Meter: 0
 
More
Just wanted to post a success so the next person doesn't have to wade through a hundred pages if they have my same device.

Using a Sprint CDMA Touch Pro 2 with FRX07.1 already installed on the storage card with a working haret.exe file...(i.e. Android already runs, I just want dual boot)

-Clicked the Cabs link on the first page
-Selected WVGA Storage Card since the TP2 uses a WVGA display
-Downloaded the .Cab file to my desktop, then connected phone and copied file to Storage Card root directory
-Disconnect phone and reboot, DualBoot installs and runs (no registry work needed)
23rd December 2011, 02:54 PM |#1115  
Junior Member
Thanks Meter: 1
 
More
Question main_androidexistcheck error
Hi. Please, helpe to solve the main_androidexistcheck error.

I've installed Android (CyanogenMod beta 1) on Samsung GT-I800 Omnia II 8 GB (WindowsMobile 6.5.3) to the Phone (Internal) Memory (not the microSD memory) to the root.
So I can run Android from WM by executing <Phone Memory>/haret.exe successfully.

I've decided to try Gen.Y DualBOOT WVGA v1.0.6.0.
I've installed it and done the following settings in registry:
Code:
"AutoBootEnabled"=0 
"FastBootEnabled"=0
"AutoBootAndroid"=1 
"StorageBootMode"=0
"AndroidBootFolder"=""    // empty string with out spaces and quotes
But I get the following error when I run DualBOOT manually or when it runs automatically after restarting the phone:
Code:
Basic4ppc
An error ocurred on sub
__main_androidexistcheck.
An error occured retrieving 
the registry key
Continue?
Yes   No
'Yes' does not help - I get the same error when I click on droid.
I've reinstalled the Android OS from the very beginning - it also did not help.

What do I do wrong?
Thanks in advance!
25th December 2011, 03:32 AM |#1116  
n1nj4Lo's Avatar
Senior Member
Flag ★ATLANTA★
Thanks Meter: 472
 
More
Quote:
Originally Posted by yozgatg

Registry
Gen.Y DualBOOT checks for 5 registry keys, which allow some form of customiation. Apart from the last key (StorageBootMode), all keys can be modified utilizing the radio & check buttons in the GUI. All of these keys can be found in:

[HKEY_CURRENT_USER\Software\Gen.Y\DualBOOT]
Here's quick list describing what the keys are for

  • "AutoBootEnabled"=dword:1 (1: enable autoboot | 0: disable autoboot)
  • "FastBootEnabled"=dword:0 (1: enable fastboot | 0: disable fastboot)
  • "AutoBootAndroid"=dword:1 (1: boot Android | 0: boot Windows)
  • "StorageBootMode"=dword:0 (1: boot from Storage Card (SDMemory) | 0: boot from Internal Storage (moviNAND))
  • v1.0.6.0 and newer: "AndroidBootFolder"="string" ("": boot from root of storage (e.g. \Storage Card\haret.exe)| "andboot": boot from \Storage Card\Andboot\haret.exe, string can be edited in registry)
  • v1.0.5.0 and older: "AndroidBootFolder"=dword:0 (1: boot from \Android\ folder on storage (e.g. \Storage Card\Android\haret.exe)| 0: boot from root of storage)

Any help, I thought I edited and added the correct string AndroidBootFolder. But it's still not working...

I'm on a LG Fathom (SnapDragon processor) and am running a version of Android called TG01 (Found here @ XDA) and in a TG01 folder. I renamed the lengthy haret.exe's name to just haret.exe and added to the string "Storage Card\TG01\haret.exe" but it still says Android missing, also instead of a startup.txt I have a default.txt.

Is it possible to get this to work?
25th December 2011, 09:02 AM |#1117  
Junior Member
Thanks Meter: 1
 
More
Thumbs down
Finally, I've deleted Dual Boot and installed RapidBoot from here
windows . modaco . com /topic/330758-rapidboot-to-o2droid-updated-to-v11/#entry1579024
It works well.
The Following User Says Thank You to MankoMyk For This Useful Post: [ View ] Gift MankoMyk Ad-Free
27th December 2011, 04:42 AM |#1118  
Junior Member
Thanks Meter: 0
 
More
device compatibility??
hi..

i am newbie here..

can dual boot y be installed to sony ericsson aspen..QVGA 240 x320. And is it android files available for this phone.
31st December 2011, 02:59 PM |#1119  
Pingerek's Avatar
Member
Flag Wroclaw
Thanks Meter: 0
 
More
hi

i have haret exe on My Storage

what i changed:

StorageBootMode to 0 (my storage)
added path in android boot folder: \My Storage\haret.exe

when i start y.gen i got this message:

Code:
An error occured on sub __main_androidexistcheck. And error occured retrieving the registry key Contntinue?
can someone help me with launchind droid from my storage ?



FORGET GEN.Y !! just used RAPIDBOOT and managed to launch android automaticly in 5 seconds!!!
3rd January 2012, 11:01 AM |#1120  
Junior Member
Thanks Meter: 0
 
More
error
i installed the vga GenY-DualBoot the internal storage option onto my htchd mini (HVGA 320x480) 6.5 in SD storage card but the android option doesnt work when i press it only the windows option works, the android option is dark and i dont know what to do, i installed it good, please help me?
I installed wqwga version because non exist the version HVGA 320x480, it,s possible make it?
thanks
5th January 2012, 10:15 AM |#1121  
Junior Member
Thanks Meter: 0
 
More
Do the Android files need to be in the root of the SD card, or can they be put in a folder? Is there a registry change I can make to point to a folder instead of the root? Thanks.
Post Reply Subscribe to Thread

Tags
android dualboot, android fastboot

Guest Quick Reply (no urls or BBcode)
Message:
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes