FORUMS
Remove All Ads from XDA

Android rooting - Linux port of DooMLoRD script - ICS as well as Gingerbread

469 posts
Thanks Meter: 267
 
By amishxda, Senior Member on 31st December 2011, 08:12 AM
Post Reply Email Thread
Update: I have now also made a Linux port for DooMLoRD's rooting of ICS phones.(Sony Xperia only)

Please see attached file: Xperia-2011-ICS-ROOT-emu-Linux.zip

Note: You need flashtool for linux. Procedure remains the same as for windows.

Original script thread: http://forum.xda-developers.com/show....php?t=1601038
Rooting procedure: http://talk.sonymobile.com/thread/41...art=0&tstart=0

Please update Superuser app as well as SU binary to the latest version after rooting is done successfully.

Update: Updated as per DooMLoRD's v4.0 script with zergRush binary of 21 Nov 2011 and with makespace which deletes Google Maps if there is not enough space.(< 6MB).

Hello

I am completely new to Android but not at all new to Linux.

I used paxchristos script (ran commands manually though) to root my Sony Ericsson Live with Walkman. (WT19i / Android 2.3.4 / Build 4.0.2.A.0.58)

Source threads used:
http://forum.xda-developers.com/show....php?t=1319653
http://forum.xda-developers.com/show...php?p=18615502

In an attached file, I fixed/modified/added few things in paxchristos script. Here is the detail:

1) Fixed error in symlinking su. (source/destination were same)
2) Don't delete (and recreate) /data/local/tmp/ directory unnecessarily, just delete its contents.
3) Create /data/local/tmp if it does not exist.
4) Uses dd instead of cp (because DooMLoRD's script does, dont know why!). Update: as per anantshri, dd is used because cp has been known to give errors.
5) If your system already has 'adb' then it uses system 'adb' instead of one in zip-archive.
6) Updated zip archive to contain the latest files from DooMLoRD's archive (paxchristos archive seemed old)

Please try/verify and let me know if I missed something.

Thanks.
The Following 24 Users Say Thank You to amishxda For This Useful Post: [ View ] Gift amishxda Ad-Free
 
 
2nd January 2012, 02:08 AM |#2  
Senior Member
Thanks Meter: 132
 
More
Very nice to know that fellow *nixers are on xda.
2nd January 2012, 02:26 AM |#3  
OP Senior Member
Thanks Meter: 267
 
More
Thanks, I am still getting used to this forum.

Have already found answers to many of my questions regarding Android.

One thing that shocked me is Android uses Java and not C. I would have preferred C anyday.
2nd January 2012, 04:21 AM |#4  
Senior Member
Flag Bangalore
Thanks Meter: 320
 
Donate to Me
More
ohk so few things
1) yes java is used mainly in Android, However look at NDK if you are a C fan.
2) dd command is used in scripts to avoid cp related issues. coz last i remember we encountered multiple errors based on scenarios where cp used to fail but dd used to work. so dd is defacto there.
@doomLord, Correct me if i am wrong.
The Following 2 Users Say Thank You to anantshri For This Useful Post: [ View ] Gift anantshri Ad-Free
2nd January 2012, 04:31 AM |#5  
OP Senior Member
Thanks Meter: 267
 
More
Ah that clears dd confusion. Till now I was wondering why he chose dd? I thought may be because dd was faster for internal memory to internal memory transfer.

Since DooMLoRD is good programmer I knew there has to be a reason. And that is why I changed paxchristos script to use dd.
4th January 2012, 12:51 PM |#6  
OP Senior Member
Thanks Meter: 267
 
More
Updated to match with DooMLoRD's v4 script. See update on first post for details.
The Following User Says Thank You to amishxda For This Useful Post: [ View ] Gift amishxda Ad-Free
20th January 2012, 04:58 AM |#7  
Member
Flag St. Louis
Thanks Meter: 1
 
More
Just used this script on my Galaxy S 2 Skyrocket. Worked great!
21st January 2012, 02:04 PM |#8  
Junior Member
Flag Sao Paulo
Thanks Meter: 0
 
More
Have used the script with Sony Ericsson Xperia Mini E10a Latin America.
Script runned, ADB found the device, device has rebooted correctly but... no root after reboot. Checked with Root Checker from Market.

Anyway, great script! Should work for some models.
23rd January 2012, 12:18 PM |#9  
Junior Member
Flag Curitiba
Thanks Meter: 2
 
More
On my phone (Milestone 2 with Gingerbread 2.3.6) the root process worked, but part of the space check it returns 90% of free space, the software does not correctly identify and delete my google maps. The following screen to evaluate and correct the bug. And congratulations for the initiative, I'd have to do it by hand when I found your script ready.

---------------------------------------------------------------
Easy rooting toolkit (v4.0)
created by DooMLoRD
using exploit zergRush (Revolutionary Team)
This script has been ported by paxchristos and modified by amish
Credits go to all those involved in making this possible!
---------------------------------------------------------------[*] This script will:
(1) root ur device using latest zergRush exploit (16 Nov)
(2) install Busybox (1.18.4)
(3) install SU files (binary: 3.0.3 and apk: 3.0.6)
(4) some checks for free space, tmp directory
(will remove Google Maps if required)[*] Before u begin:
(1) make sure u have installed adb drivers for ur device
(2) enable 'USB DEBUGGING'
from (Menu\Settings\Applications\Development)
(3) enable 'UNKNOWN SOURCES'
from (Menu\Settings\Applications)
(4) [OPTIONAL] increase screen timeout to 10 minutes
(5) connect USB cable to PHONE and then connect to PC
(6) skip 'PC Companion Software' prompt on device
---------------------------------------------------------------
CONFIRM ALL THE ABOVE THEN
PRESS ENTER WITHIN 120 seconds TO CONTINUE OR ctrl-c to cancel

--Starting---
---Killing the adb server to make sure that there are no problems---
---Waiting for Device---
* daemon not running. starting it now on port 5037 *
* daemon started successfully *
---Cleaning out any previous zergRush attempts---
mkdir failed for /data/local/tmp, File exists
rm failed for /data/local/tmp/*, No such file or directory
---Pushing zergRush---
531 KB/s (23060 bytes in 0.042s)
---Fixing permissions for zergRush---
---Running zergRush---
If it gets stuck here for a long time then try:
1)disconnect usb cable and reconnect it
2)toggle 'Usb Debugging' (first disable it then reenable it)

[**] Zerg rush - Android 2.2/2.3 local root
[**] (C) 2011 Revolutionary. All rights reserved.

[**] Parts of code from Gingerbreak, (C) 2010-2011 The Android Exploid Crew.

[+] Found a GingerBread ! 0x00000118[*] Scooting ...[*] Sending 149 zerglings ...[*] Sending 189 zerglings ...
[+] Zerglings found a way to enter ! 0x18
[+] Overseer found a path ! 0x000151e0[*] Sending 189 zerglings ...
[+] Zerglings caused crash (good news): 0x4011ccd4 0x0074[*] Researching Metabolic Boost ...
[+] Speedlings on the go ! 0xafd19413 0xafd3925f[*] Sending 181 zerglings ...

[+] Rush did it ! It's a GG, man !
[+] Killing ADB and restarting as root... enjoy!
---Waiting for Device---
---Pushing busybox---
2011 KB/s (1075144 bytes in 0.522s)
---Fixing busybox permissions---
---remounting system---
---checking free space on /system---
10 KB/s (439 bytes in 0.040s)
--- Free space on /system : 90% bytes
test: 90%: bad number
--- NOT enough free space on /system!!!
--- making free space by removing Google Maps

---copying busybox to /system/xbin---
2099+1 records in
2099+1 records out
1075144 bytes transferred in 0.084 secs (12799333 bytes/sec)
---fixing ownership and permissions---
---installing busybox---
---cleaning up---
---pushing SU binary---
546 KB/s (22228 bytes in 0.039s)
---correcting ownership and permissions for SU---
---correcting symlinks---
---Pushing Superuser app---
2160 KB/s (785801 bytes in 0.355s)
--cleaning---
---rebooting---
---All done, your Xperia has been rooted by DooMLoRD---
---This script has been ported by paxchristos and modified by amish!!---
---If have any questions, feel free to email me @ nielson.peter@gmail.com---
The Following User Says Thank You to Leduck For This Useful Post: [ View ] Gift Leduck Ad-Free
23rd January 2012, 02:41 PM |#10  
OP Senior Member
Thanks Meter: 267
 
More
Umm.... Freespace checking script was not developed by me. I have copied it directly from DooMLoRD script AS IS (had not tested it either). I think we dont need it anyway. It will be very rare that person rooting wud have run out of space. Person can re-install Google Maps (so no big harm done by bug)

But when I get the time I will check the DooMLoRD's script if there exist a bug.


Please click on THANKS if u liked my script
23rd January 2012, 03:37 PM |#11  
Junior Member
Flag Curitiba
Thanks Meter: 2
 
More
Your script has saved me a lot of work, because I'm tired of borrowing the notebook of my wife for flashing my phone and was looking for solutions for linux, missing root can do, I do not want to use SuperOneclick (did not want to install it just for Mono ) and go on to adapt the script DoomLord for Linux, which you did very well done. Now I can do everything on my computer with linux, what about the bug, I realized that the program was part of the original script, but I made a warning to those who wish, like me, deactivate the check room not to lose Google Maps (or have to reinstall the Market).
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Message:
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes