Remove All Ads from XDA
Honor View 10

Get Android Market Working on A7+

25 posts
Thanks Meter: 6
By Destron5683, Junior Member on 7th January 2012, 12:51 AM
Thread Deleted Email Thread
As you have already found out, an Android device is useless without the Android Market. Here is how you can get it working on your A7+.

First do a factory reset on your tablet.

Go to Settings>Privacy>Factory Data Reset

Once your tablet restart you will be ready to go.

Download this package here:


and extract the contents to your micro sd card or USB stick. (I used a USB stick and it worked great). There is a folder and two files:

gapps folder
Amazon Marketplace.apk (optional - see below)

You will also need to acquire a copy of root explorer. It's a paid app and well worth the $4. How YOU acquire it is entirely up to you, I will count on you to do the right thing. The Amazon marketplace DOES work on the Elocity A7 and you can buy Root Explorer from there. I personally installed Amazon MP and bought a copy, even though I already bought one from Android Marketplace. (You can use the Amazon MP on all devices and log in with the same credentials to install on multiple devices with one purchase.)

Insert your SD card or USB stick in to your tablet and wait for them to mount.

Open your app drawer and find OI File Manager that came pre-installed on your tabled and open it, and hit the HOME button icon in the upper left corner.

Now hit storage and scroll down and look for:

SDCARD - look for sdcard-disk
USB - look for usb0-disk

Find the appropriate folder and click it, then find the z4root.1.3.0.apk and click it and you will go to the installation screen. Click Install at the bottom. Once its done, open it.

You will be presented with two options, temporary root and permanent root. Click permanent root and let it do its thing. It will restart your tablet and it will be done. (if it fails - especially if it hangs on reboot, turn the tablet off and do it again).

Repeat the steps above to install the Amazon Market if you need to. Either way you do it at this point you need to install Root Explorer.

Once you have Root Explorer installed open it, you should get a prompt for Super User access. Make sure you choose to ALLOW.

With Root Explorer open you should see / in the upper left corner, if not hit the back button until you do.

scroll down and click find the system folder, open it, then find the bin folder and open it. Scroll all the way down and find the file


long press on this file and choose COPY, and hit the back button twice so you are back at /.

At the top of the screen is a button that says Mount R/W - click it so that is says Mount R/O, then click the PASTE button at the bottom of the screen.

Long press on wpa_supplicant and choose rename - rename the file to wpa_supplicant_bk.

Now in this same folder find the Storage Folder and open it, and find the correct folder for your external storage method (same as above) and click it. Open the gapps folder, then system folder, then the app folder.

Hit the menu button, choose Multi Select, then click select all, then copy.

Now hit back again untill you are at the / directory, then go to the System folder, and open the app folder.

Click PASTE. (if you get an error hit the Mount R/W button again) when it asks if you want to over wright some apps, choose YES to all.

Your device will flash, and jump to the Elocity Boot screen, then it will make you go through the Android setup wizard.

At this point ensure WiFi is turned OFF.

Now open root explorer, browse back to your storage method, open gapps>System>bin and find the wpa_supplicant file. Long press it, and copy it.

Now browse back to the system folder, and open the bin folder, and click paste. It will ask to confirm over wright - choose YES. (Same as above if you get protected directory error).

Finally reboot one last time and you should now have a working market!
The Following 3 Users Say Thank You to Destron5683 For This Useful Post: [ View ] Gift Destron5683 Ad-Free
7th January 2012, 09:58 PM |#2  
Junior Member
Thanks Meter: 1
stuck at trying to paste into /system/app folder and can't seem to toggle Mount R/W there.

update: if this happens, apparently a reinstall from the amazon appstore fixes root explorer
8th January 2012, 06:40 PM |#3  
Junior Member
Thanks Meter: 0
Even with reinstalling the app I am unable to toggle the Mount R/W button at that same point.

Update: Installing BusyBox seemed to fix whatever was keeping the toggle from working. But once I go to paste the files, it tells me there isn't enough space.

Also, somewhere along the way I lost the keyboard software, and its not detected under settings either -.-
4th February 2012, 05:04 AM |#4  
Junior Member
Thanks Meter: 0
Hey, this worked! I didn't actually do a factory reset because I had a bunch of stuff I wanted to keep, so i thought I'd take a gamble.... My Elocity A4+ didn't restart automatically after copying the files, so I restarted it manually. I thought I might be in trouble when it brought up the "sign in to google" page over phone data. Of course that couldn't be done since I have no phone and the wireless authentication wouldn't work.

I restarted again and noticed that the google authentication had a "later" option, which I selected. That took me into my tablet like it had been before. I disabled the wireless, copied the wpa_supplicant file provided, restarted again and ... viola! It worked. Reenabled wifi, went into the market and updated a bunch of apps through appbrain. I thought this tablet was good before (able to sideload most apps I needed) ... I love this tablet a lot more now. Thanks again for the info.
18th February 2012, 07:00 PM |#5  
Junior Member
Thanks Meter: 0
Smile Got Android Market working on Elocity A7+
I also was getting the message that there was not enough space to copy the files, so I deleted some the apps that were on the Elocity A7+, like Fring. It gave me an error when deleting Fring but I did a reboot and it was gone. Android Market is now on my tablet. So far so good.
24th February 2012, 01:33 PM |#6  
Junior Member
Thanks Meter: 0
Thank you! This worked for me.
(I'd click the Thanks button but I don't have one, maybe I'm too new?)

I didn't do the factory reset either.
Had to manually reboot.
Didn't have any space problems but I uninstalled some stuff anyway.
5th March 2012, 04:17 PM |#7  
Junior Member
Thanks Meter: 0
Thumbs up Very Grateful
Hey Destron5683,

As someone who is not particularly well versed with Android I am super grateful for this step by step fix you've provided.

I got the A7+ yesterday and found it to be quite a deal. I was unpleasantly surprised however to discover this whole no android market none-sense. Your fix worked flawlessly, I now have the market app an have downloaded a bunch of apps that have worked great.

Skype is the 1 app I have had no luck with. I've installed it but when I try to sign in it reads an error message like:
"Skype has stopped working. Would you like to sign in again or exit Skype?"

I can't get passed that error loop. Reading around, I get the sense that Skype detects whether or not the device is compatible and blocks you from successful log in.

If by chance you now of a way to get around this, please do tell!

Again, thanks so much for posting this useful step by step guide and for going through the trouble of creating this well needed fix.
14th March 2012, 03:10 AM |#8  
Junior Member
Thanks Meter: 0
I followed these instructions to a T but after copying the app files the tab did not switch to the splash screen, so I rebooted and the "Click the android" came up but I could not click the android to continue the setup, it just got stuck there.
21st March 2012, 06:14 AM |#9  
Junior Member
Thanks Meter: 0
Android market working
Followed the instructions and it worked like a charm if you get the not enough space error delete the video trailers and try again!!
3rd June 2012, 02:39 PM |#10  
Junior Member
Thanks Meter: 0
android market
Great post. I have been looking for this since getting my A7+ passed over to me. One problem, I cannot get the file from the Filesonic site. They have changed policy and only the user can download his files. Is it possible to send another link to access this file?
3rd June 2012, 11:04 PM |#11  
Junior Member
Thanks Meter: 2
The instructions are very helpfull and greatly appreciated
I got everything working fairly easily with the exception
of having to reboot it myself, as others have noted it didn't
auto reboot.

Still in process of trying to find a google play apk as the
old market app from this thread while functional, it really
sucks compared to play on my infuse.

via rooted/hacked A7+ with xda app
Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes