Random Reboot Investigation [FIX AVAILABLE FOR ROOTED TFs]

273 posts
Thanks Meter: 95
By msaraiva, Senior Member on 26th February 2012, 06:42 PM
Post Reply Email Thread

I bought my TF about 15 days ago, rooted it and installed CWM recovery, and it was running just great. Then, the ICS update came along and i just waited for the CWM package to update mine. No problems in the update process, but the random reboots started happening, so i thought the problem was that i updated without wiping, so i did this. No dice, still getting (not so) random reboots. So, i thought maybe it was the CWM package. I downgraded to HC via NVFlash, then let it update via FOTA. Even then, the random reboots persisted. Then, i noticed the tablet never rebooted while in use, but only while in deep sleep state. The "No Sleep" widget is the current workaround, but then, you risk getting a SOD.

So, from what i could gather until now, the following things are NOT the cause for the RRs:

1. Updating without wiping.
2. Updating via CWM.
3. Rooting.

Well, i got really sick of this problem, so it's time to do something about it. I am trying to gather as much info as possible to try and narrow down the possible cause for the random reboots, so i need everyone that is facing the same issue to give me the following info:

1. Serial number of your Transformer
2. Firmware region (TW, US or WW)
3. Logcat before the reboot

For number 3, you need to open Terminal Emulator, and do this:

# su -
# logcat > /sdcard/logcat.txt

Then you just turn off the screen and let your tablet go to deep sleep. After it reboots, post here the info above and attach logcat.txt.

Please, only use this thread to post the info i asked. Thanks!

Update: Some users contacted ASUS and it seems they are aware of the problem. A fix is supposed to released soon, in the form of another OTA update.

Update2: Very good knews for rooted users. The test13 version of guevor's kernel is able to let the TF deep sleep and not reboot. Link to his thread:

The Following User Says Thank You to msaraiva For This Useful Post: [ View ] Gift msaraiva Ad-Free
26th February 2012, 06:50 PM |#2  
Thanks Meter: 7
Good idea. Mine just randomly shuts down during sleep, as opposed to rebooting. Shall I contribute too?
26th February 2012, 06:52 PM |#3  
baseballfanz's Avatar
Senior Member
Flag Sugar Land TX
Thanks Meter: 1,725
Have you tried a factory reset?
26th February 2012, 07:15 PM |#4  
OP Senior Member
Thanks Meter: 95
Originally Posted by Balor

Good idea. Mine just randomly shuts down during sleep, as opposed to rebooting. Shall I contribute too?

Yes, please.

Sent from my Transformer TF101 using XDA Premium HD app
26th February 2012, 07:32 PM |#5  
Exnor's Avatar
Senior Member
Flag LX
Thanks Meter: 126
Can´t give you a logcat yet but here's my TF101 info:

FOTA to ICS 2 days ago and started random reboot's... Not Rooted (never has), no service/app/etc.. killer, but i did disable all of ASUS crapware on the Apps manager.

I was able to caught one of the reboots (it's freeze on the ASUS logo) and when i hard reboot it, during boot sequence appear some message saying that was finalizing update (this was after the FOTA and after other 2 random reboots. I did reboot the device after the update at least twice before experiencing the 1st Random Reboot).

S/N: B90KAS146231
WW (Build Number IML74K.WW_epad-
Kernel: » [email protected]#1

as soon i have the Log i will post.

Hope this help somehow
26th February 2012, 08:05 PM |#6  
OP Senior Member
Thanks Meter: 95
Originally Posted by baseballfanz

Have you tried a factory reset?

Every kind of update method that you can think of was tried. In that case, yes, it was wiped. Several times, in fact.

Please, post just what i asked. I want this info to investigate the issue. Post on another thread if you want to share theories or something else.

Sent from my Transformer TF101 using XDA Premium HD app
26th February 2012, 08:32 PM |#7  
Senior Member
Thanks Meter: 6
Mine was never rooted, 100% stock, took the ICS OTA on Friday moring, ran great all day, I woke up Saturday morning (I had docked it and put the doc on the charger friday night when I went to bed) and it was stuck in a boot loop. Now I'm looking at how to NVFLASH it back to honey comb to recover it, might as well root it now.

26th February 2012, 09:27 PM |#8  
eyesoftsys's Avatar
Thanks Meter: 10
still waiting to freeze or reboot ... for now 493K of logcat

Sent from my Transformer TF101 using Tapatalk
26th February 2012, 09:54 PM |#9  
thebadfrog's Avatar
Senior Member
Thanks Meter: 473
This is going to be a problem in the kernel like it has been on previous releases. When kernel source is released then the kernel devs will fix it and then asus will fix it. My SODs are caused by a kernel panic so until we get an updated kernel we need to get asus to release source.
26th February 2012, 11:23 PM |#10  
Junior Member
Thanks Meter: 0
I am mostly a longtime lurker/user of XDA but I thought I should contribute to this thread.

Bone Stock 16g TF101-A1, Refurb purchased last week from online vendor. Still getting used to the tablet format but I also purchased a TF101 Dock.

I noticed yesterday that I had a couple of random re-boots. Didn't know if it was related to an update or why this particular tablet was "refurbished." About 7 hours ago, this morning, I got multiple re-boots. Splash screen then power off and on again. I saw at least 15 re-boots before I started looking around for solutions. I tried the stock rom (downloaded from Asus) and re-boot to recovery w/o any success. Re-booted and wiped (hard reset) multiple times as well.

Still no complete boot but I had two separate and distinct paths that displayed:
1. it would boot with an android bot asking for a password and the keyboard displayed
2. It would cold boot into the "Start" screen like a normal set up.

I did manage to get the recovery started only to reach the bot with the exclamation point and no further progress at recovery.

In either case, typing a password of any kind did nothing, and hitting start and beginning the set up process did nothing but continue the re-boots/splash screen/power up/power down.

Finally connected to my laptop and it succeed in a complete boot and I was able to set up and connect to my wireless. It did not re-boot for several moments and I was able to observe the "About" page from the settings. I was still running

I also noticed that it was actively downloading a "firmware update" I went through several more re-boots until it finished the download and then I installed the firmware w/o any further trouble. In watching the download, I noticed re-boots at 31%, 32%, 41% "download completion", and one or two more before it fully downloaded. Of course, it did re-boot upon completion of the upgrade.

I am now running Android version: 4.0.3 Build number: IML74K.US_epad-

Everything has been stable for an hour or so of moderate use including installation of multiple apps.

FWIW, I think that the reason my problem started is that I had my WiFi set to turn off when screen is off. I believe my incomplete download started the re-boots and my settings "may" have contributed to the incomplete downloads that started the rest of my issues.

Thanks to all of the "regulars" around here that are busy helping us customize our devices. This may not be my first post, but I think I have less than 5 posts right now. Hope this helps in discovering the causes of the re-boots.
26th February 2012, 11:33 PM |#11  
Dany XP's Avatar
Senior Member
Flag Milano
Thanks Meter: 310
ICS OTA on Saturday, 2 reboots already, stock rom, 100% original, Italy. Should i contact Asus?
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes