Remove All Ads from XDA
Honor View 10

fix "can't mount /dev/block/mmcblk0p2 (File exists) error mounting /sd-ext/!.

208 posts
Thanks Meter: 4
By lawrrtan, Senior Member on 18th April 2011, 09:03 PM
Post Reply Email Thread
24th April 2011, 09:28 PM |#11  
CtapukaH's Avatar
Flag Milano
Thanks Meter: 5
Originally Posted by streetdaddy

Thankfully was able to rescue all files from my SD card, format and partition again, then flashed LeeDroid 3.0.2 and restored a Titanium backup... everything running smoothly again! Phew...

May I ask how did you manage to do that?

Ok. Apart from the backup/restore issues that depend on having a healthy ext partition as I figure, the "can't mount [..] error mounting /sd-ext/!" problem is responsible for the "green HTC logo on the white screen freeze" also. So I've been trying to make it work all evening and this is what I found:

The Error (at least in my case) and the freaking "green HTC logo" freezez were generated because the Ext partition got corrupted in some bizarre and mysterious way. I have no idea how that could have happened, but I guess a small role in this ballet got played by the ROM itself and maybe even the nandroid backup built into the CWM (ClockWorkMod). It started right after I finished installing a fresh copy of the LeeDroid 2.4.1 and all my favourite apps (which worked flawlessly), rebooted into bootloader > CWM > nandroid and made the full backup of the system. Rebooting the device afterwards got me into the above mentioned freeze.

I tried many things, among which were flashing different ROMs and Radio images (without wiping though), but none worked. I just wanted to roll back to the previous state (because i've spent quite some time configuring and installing the 2.4.1) and it seemed impossible at that point. Browsing the recovery options got me into the Mount and storage section where I noticed the listed error with the ext partition. I thought maybe formatting will help - well, it didn't. After a couple of weird things I had tried, I've decided I should delete the ext partition (leaving just the fat32 intact). Creating a new ext partition from scratch seemed to solve the error. However this didn't solve the freezing. And the reason had to be the fact that when it created the nandroid backup images, the ext was already corrupt (or however unreadable), so the relative image was not written because it didn't see the source.

I doubt there is any way to fully restore my previously installed ROM with all of it's apps in place and in a functioning order, because the ext partition had data on it and now it's missing (hence the freeze).

Therefore the question: what could have gone so badly wrong to compromise the ext partition?
And another one: is the LeeDroid 2.4.1 ROM or the ClockworkMod Recovery the culprit?

Sorry for the looong post. I look further to hearing from Lee, if his busy schedule allows it and thank him in advance.

21st May 2011, 01:06 AM |#12  
Junior Member
Thanks Meter: 0
Originally Posted by streetdaddy

Hmmm I had this exact same problem with LeeDroid 3.0.2... Trying to flash without wiping, had about 80 apps on my EXT3 partition... Got stuck on the white HTC screen for about 2 hours, gave up, pulled the battery, tried to flash the alignment zip, still stuck... tried to restore nandroid backup but then started getting this same error as you.

Thankfully was able to rescue all files from my SD card, format and partition again, then flashed LeeDroid 3.0.2 and restored a Titanium backup... everything running smoothly again! Phew...

hi! having the same exact problem right now... could you please help me how did you rescue all of your sd-card and sd-ext partitions? Thank you very much!
23rd October 2011, 07:46 PM |#13  
warpaper's Avatar
Senior Member
Thanks Meter: 3
same problem on my N1, reparition to resolved
2nd November 2011, 06:44 PM |#14  
Thanks Meter: 0

i got this problem too

i have clockworkmod recovery. pvt4.
cyanogenmod 7.1.
didn't make any partitions,
everything is by default as i got with cyanogenmod
sd - 8gb, class2

yesterday my desire i had to pull out the battery. but i couldn't turn it on till' i didn't wipe cache and dalvik cache.

When i selected wipe dalvik cache i got this

E: can't mount /dev/ block/mmcblk0p2
(file exists)

but it wiped it and my phone worked.

this appears even without sd card

it freezed after a week again but after a couple of reboots it works again but the error still exists.

i am newbie so i don't know what to do?
27th February 2012, 12:41 PM |#15  
Flag Sydney
Thanks Meter: 0
So I flashed a ROM which stuffed up my partitions somehow (also became S-ON, WTH?!).
I got 'can't open /dev/block/mmcblk0 (or /dev/block/mmcblk0p1) (invalid argument)' when trying to mount /sdcard.
I also got the aforementioned 'can't open /dev/block/mmcblk0p2 (file exists)' when trying to mount /sd-ext.

After literally 16 hours of head banging, I realised when I partitioned the SD card again that they were logical instead of primary. Partitioned using minitool partition wizard home edition.

I'm using LeeDroid v3.3.3 with clockworkmod recovery

Make sure you partition FAT32 first as primary, then ext3 as primary. LeeDroid says to partition ext3 1GB after FAT32, so e.g. my SD card is 16GB, I have ~13.8GB FAT32 | 1GB ext3
This fixed the 'can't mount /dev/block/mmcblk0' error, /sdcard is mountable.
You can now run .zip files from recovery (yay!). Throw on there and run it. You should now be able to mount /sd-ext.

Do a full wipe + Dalvik cache wipe (to test /sd-ext accessibility). For me it was back to normal and I'm currently doing a restore.

Always do a backup.
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes