Remove All Ads from XDA

[Q] No Sound when calling certain numbers

37 posts
Thanks Meter: 2
By mactherapy, Member on 5th December 2011, 05:00 AM
Post Reply Email Thread
24th December 2011, 09:43 PM |#11  
Junior Member
Thanks Meter: 0
Thanks. This works on Droid 3 as well.

Originally Posted by mactherapy

OK, I found the instructions on Droid Forums..

Pull up the dialer on your phone
Dial ##PROGRAM (##7764726)
Hit Send (the call button)
The password is 000000 (six zeros)
Select "Option 6 - Test Mode"
Hit "Next" until you come to the "Field test screen"
Under "Service Option" (top most), select EVRC-B
Hit "Back"
The phone should then reboot and you'll be all set.

29th December 2011, 01:00 AM |#12  
Senior Member
Flag Victoria
Thanks Meter: 72
Donate to Me
I have recently started having this exact same problem on telstra and it is driving me absolutely insane!

If anybody has ANY idea how to fix it on GSM/UTMS please let us all know.
31st December 2011, 07:32 AM |#13  
OP Member
Thanks Meter: 2
Ok, I am still working on this issue. I figure that if there is some way of changing the default UTMS codec to be the same as the GSM that might work. I am still trying to find the setting for this. However I was looking through the build.prop and I found some settings that seem to have an effect on other issues that I notice.

If you edit build.prop and change the line




then reboot the phone

The phone behaves slightly differently, the signal strength indicators are more accurate for a start.

Also from what I can see the following options are set to Verizon defaults and are only useful for people on the USA and so should be changed for overseas users..

ro.telephony.default_network= (set to 7 for global, change to 3 for Gsm/UMTS or 4 for CDMA only)
31st December 2011, 08:30 AM |#14  
Gasai Yuno's Avatar
Senior Member
Flag Rausu
Thanks Meter: 342
These have been discussed a few times (especially .vzwglobalphone).

.gsm-routes-us-smsc is only applicable for Vodafone NL users; for all other carriers, SMS routing is done via local carrier's SMSC.
.default_network doesn't matter at all; it determines the mode the phone starts after a factory reset.
31st January 2012, 02:42 PM |#15  
tjikko's Avatar
Junior Member
Thanks Meter: 3
Hey there,
Through the search forum feature I found this issue,
My phone started to do it too, i'm using GSM/UMTS, I've been using the phone since last august and untill 2 weeks ago I didn't have problems.
What I tried was>
Change simcard,
change carrier,
I was on 2.3 I SBF back to 2.2
all without succes.

I only can call one mobile number properly all others are silen,t mobile and landlines alike.

Has there been more succes to get closer to resolve this? I don't mind helping finding it.
I love my D2G and i would get separation problems if I need to change phone
22nd February 2012, 09:19 AM |#16  
Senior Member
Flag Victoria
Thanks Meter: 72
Donate to Me
In the end there was nothing anybody could do.

Fault finders at my network provider were just as stumped as me. No amount of reflashing would change anything, the handset was cursed.

I ended up having to give up on it.
27th February 2012, 01:23 PM |#17  
OP Member
Thanks Meter: 2
The problem continues to get worse. More and more numbers get no audio either when they call me or when I call them. It only happens on the WCDMA 850mhz Telstra network.
The phone behaves normally on any other network or on the GSM Telstra network.

Re-flashing the phone with Miui or CM7 or CM9 or any of the official Motorola firmware's makes no difference. It is a truly crazy problem.

I am going to buy another android phone from Telstra and see if that behaves normally with my sim card. A non android phone I have behaves normally.

The behaviour is still the same, if I am on 3G WCDMA 850mhz on the Telstra network, someone calls me or I call them, it shows the call is connected, neither of us gets any audio, no hash, just silence. Rebooting the phone, changing the rom, factory resets, changing the Telstra SIM, nothing makes any difference. Switch to GSM only and suddenly the issue goes away.

My GF also has a D2G and has exactly the same issue and it is getting worse for her too.

I am guessing that the network is storing something like the phones IMEI on the WCDMA network and then forcing an incompatible audio codec. I don't know enough about the operation of the network to be able to prove anything.

I would like to find some way to force or change the audio codec that gets used when I make calls, is there any way to see what the phone is using for each call?
27th February 2012, 02:08 PM |#18  
OP Member
Thanks Meter: 2
Ok, another update. I have been doing some more testing. I have discovered that DTMF tones go through to a non Android Telstra phone . Any key presses on the D2G can be heard as DTMF tones on the other phone. DTMF tones do not register on the D2G.

Between two D2G phones on the 850mhz wcdma network there is no audio in either direction and the DTMF tones do not come through either.

As usual switch either phone to GSM and everything works perfectly again.
28th February 2012, 12:51 AM |#19  
Senior Member
Flag Victoria
Thanks Meter: 72
Donate to Me
Right, here we go.

I got a call back a couple of days ago from a tel$tra tech.

This was a long time coming and I have since stopped using the phone altogether anyway.

Basically what you need to do is call telstra tech support and go through the Indian rigmarole with technical support.

These guys will eventually escalate your problem and an Australian tech will call you back.

This person too will be completely useless but do not give up hope.

What you need to do is this: gather data.

Sit down with an internet clock in front of you and log a series of phone calls to numbers that you know the fault exists with and record the details of each failed, no-volume call and weather it was incoming or outgoing, duration of call, type of handsets connected etc etc.

Even though I have given up on the D2G on telstra and moved on, the tech assured me that he would have been able to help with this issue as he had seen it before.
12th April 2012, 09:36 AM |#20  
tjikko's Avatar
Junior Member
Thanks Meter: 3
Long time no post, but I found something (I think atleast)

The no sound error occurred only when I make call over the 3G UMTS netwerk. When I forced my Droid on GSM only it worked again.

Has anyone tried this too?

My carrier (KPN Netherlands) has introduced "HD Voice" for it's voice calls over the UMTS netwerk.
Might this be something? Because my Droid started to get the problem around the time the pilot of "HD Voice" was rolled out.
28th April 2012, 09:59 AM |#21  
Junior Member
Thanks Meter: 0
Unhappy My D2G is also giving similar problem
I have an unlocked D2G. in Global mode. ( Android 2.3.4)
Mine started a similar issue.

No voice in either direction.
Happens intermittently.
No difference lo land lines or mobiles.

Yet Skype and data works fine.

I use on the Dialog network in Sri Lanka. ( GSM 3G network )
Post Reply Subscribe to Thread

d2g, no audio, no sound, telstra, utms

Guest Quick Reply (no urls or BBcode)
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes