Remove All Ads from XDA
Honor 9 Lite

How to get MMS working on sim unlocked phones

3 posts
Thanks Meter: 3
By Assault88, Junior Member on 8th May 2011, 05:33 AM
Post Reply Email Thread
OK I got my LG C900 AT&T working with MMS here in New Zealand after much painstaking investigation. Here's what I did:

1. Unlock the MFG app and log in to it. (probably best to dev unlock and prevent relock here while you are at it). Details here:

2. Make sure you are updated to Nodo update to have the latest carrier network provider files. T-mobile users must do this otherwise the files wont be there.

3. In MFG App, Enable ADC in the "engineer menu" under "other settings"

4. go to "set network profiles", if there are no network profiles in the box on the lower half of the page then observe the 2 boxes just above it, one is called MCC and one is called MNC.

5. You need to type in the correct numbers for your provider in these boxes. I de-compiled a flash rom and found out what these all are, you can also find out what they all are by browsing the windows directory of your phone and look for the provider XML files. In the file name of the XML file for your provider should be 2 numbers like this:


This is a T-Mobile US network provider file. The 2 numbers are MCC: 310 and MNC: 800

There may be mulitple config files for each carrier like the T-mobile guys have a lot of XML files and I dont know which is right for each of you so you will just have to try them one by one until you find what works. T-Mobile US is always MCC: 310 but MNC is different for different areas/states I guess. Here are the numbers for T-mobile:

MCC: 310 MNC: 160
MCC: 310 MNC: 200
MCC: 310 MNC: 210
MCC: 310 MNC: 220
MCC: 310 MNC: 230
MCC: 310 MNC: 240
MCC: 310 MNC: 250
MCC: 310 MNC: 260
MCC: 310 MNC: 270
MCC: 310 MNC: 300
MCC: 310 MNC: 310
MCC: 310 MNC: 490
MCC: 310 MNC: 530
MCC: 310 MNC: 580
MCC: 310 MNC: 590
MCC: 310 MNC: 640
MCC: 310 MNC: 660
MCC: 310 MNC: 800

So after you put in the two numbers, hit find and in the below box a provider config file will come up. Select it and your phone will now switch profiles and your MMS should now work, assuming you have the right provider config file. If you need help finding the right numbers for your provider, I may be able to find them for you.

I have no idea if this works on non-LG phones using the MFG app.

Hope this helps some people get MMS working
The Following 3 Users Say Thank You to Assault88 For This Useful Post: [ View ] Gift Assault88 Ad-Free
25th May 2011, 05:54 AM |#2  
Junior Member
Thanks Meter: 0
Hey Assault88, thanks for sharing this info. I need your help finding a profile for Simple Mobile (MVNO of T-Mobile). I've been working on this for weeks and can't get my MMS to work.
Customer Service can't help and have no knowledge of the OS and The LG app is only good for Europe. Please Help ASAP! Thanks!
4th June 2011, 10:44 AM |#3  
Junior Member
Thanks Meter: 0
Great hints, thank you !
7th June 2011, 09:36 AM |#4  
OP Junior Member
Thanks Meter: 3
Originally Posted by romaink

Hey Assault88, thanks for sharing this info. I need your help finding a profile for Simple Mobile (MVNO of T-Mobile). I've been working on this for weeks and can't get my MMS to work.
Customer Service can't help and have no knowledge of the OS and The LG app is only good for Europe. Please Help ASAP! Thanks!

Hi romaink, sorry for the late response. according to simple mobiles website it should be:

MCC: 310 MNC: 260

This is a T-mobile settings file and hopefully it works for you. If it does not work then let me know and I'll see if I can create a custom settings file with the correct simple mobile settings.
4th July 2011, 05:21 PM |#5  
Junior Member
Thanks Meter: 0
Thanks, but...
Still doesn't work. Text messages work fine, but still can't send/receive mms msgs. I was hoping LG would have released an updated app to fix this, but it looks like that won't happen. Thanks for the info
8th July 2011, 03:15 PM |#6  
Thanks Meter: 5
The easiest way is to call your provider and ask them if they have OTA push messaging available. Most do. If they do, they can push the provisioning doc to your phone to add the xml document to allow you to use mms. If you complain enough and they have OTA capabilities, they will do it. But if they dont... and you are not in the already on there XML files, MMS will not work. That simple.
The Following User Says Thank You to generationxile For This Useful Post: [ View ] Gift generationxile Ad-Free
6th August 2011, 01:56 PM |#7  
Senior Member
Thanks Meter: 3
I finally got my MMS working using the OP instructions and the MCC & MNC codes listed on this wikipedia page:

MMC (Mobile Country Code) & MNC (Mobile Network Code) List

I plugged my appropriate country and network code. And voila it was working.

Thank you OP.
6th January 2012, 07:28 AM |#8  
Junior Member
Thanks Meter: 0
I Have a LG c900 AT&T, I took the sim card from my nokia e71 (straight talk) and I cant find the correct MCC MNC code that works...
22nd February 2012, 05:40 AM |#9  
Junior Member
Flag Arlington
Thanks Meter: 0
Unable to get MMS to work on C900 quantum from AT&T, now with T-Mobile
Current Network settings: TMU_US_310_260_ENG.xml
Am I missing something?
Really need this to work otherwise I will have to get a new phone
28th February 2012, 07:33 PM |#10  
Junior Member
Thanks Meter: 0
Help with step 1
Hello Assault88, thank you for your post. I was wondering what you mean in step 1, is the MFG App, an app you get on the windows mobile market? or where can I get it? the link you point to is broken

Im trying to set this phone on Simple Mobile. and although Simple Mobile does provide OTA programming, it is not available for this phone. I cant even get the internet to work. any help will be appreciated, thanks.
3rd April 2012, 07:17 PM |#11  
Junior Member
Flag Rio Rancho
Thanks Meter: 0
Unhappy Lg c900 no cell data
I have a LG Quantum an I can't get the Cell data to work with Straight Talk (MVNO-ATT-US).
I already tried a few trick but just doesn't want to work.
I know I cant make the MMS to work because is no settings for it and honestly I don't care but I cant make it to work the data either.
Reading on forums the data should work with the following settings:
NAME straight talk
APN: att.mvno
PORT: 80

... but doesn't. has anybody the same problem? how you fix it?
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes