[TOOL] PERMANENT-ROOT (Fixed Links!) & Temp-Root (v2) for any MT4GS (Windows)

116 posts
Thanks Meter: 68
By jdmarko, Senior Member on 30th July 2011, 01:00 AM
Post Reply Email Thread
24th February 2012, 06:09 PM |#221  
jdmarko's Avatar
OP Senior Member
Thanks Meter: 68
Donate to Me
Originally Posted by theansible

I'm soooo frustrated. When I run Revolutionary, I receive this error message:

Your device: doubleshot, with HBOOT 1.45.0013 is not supported at this time.

I read this note on the "Read this before posting. MT4G Slide Compendium" thread:
Note as of 12/22/2011 the ota update is not rootable (H boot 1.45.0013) and s-off cannot be obtained.

So this means (currently) my device is completely un-rootable, correct?

According to this thread, we're still waiting for a tool to get around this?

Is this true? We're still waiting for someone to figure this out? Oh nooo.. I just got this device cuz I saw so many people already rooted theirs. I didn't see this coming!

Oh well, Tmobile gives a 20 day "buyer's remorse period". I guess I'll wait a couple weeks for the tool to emerge. If not, I'll send it back.

I believe there's an HTC-provided way to unlock the bootloader. It won't give you S-OFF, but you can root and install custom ROMs.

Also, my wife returned her MT4G, saying it wasn't working and received a new replacement in the mail the following day... with the 1.44 HBoot. I rooted her replacement with Revolutionary.

Sent from my HTC Sensation 4G using xda premium
27th February 2012, 10:34 PM |#222  
jdmarko's Avatar
OP Senior Member
Thanks Meter: 68
Donate to Me
Yes, you can unlock the bootloader of the newest HBOOT with the HTC -provided tool http://htcdev.com/bootloader/

I recommend you read up on the advantages and disadvantages of this method... But you should be able to root and install ROMs.
1st March 2012, 04:03 AM |#223  
gtmaster303's Avatar
Senior Member
Thanks Meter: 427
Donate to Me
I can't run the temp root file in the OP.
The zip opens in winrar just fine, but then it says unknown method and that there are no files to extract....
What's going on?

Edit: Never mind...
The fixed link is posted in the thread, read through a few posts back to find it
Worked like a charm S-OFF and ROOT!

NOTE: you may have to flash su a few times for it to work. Mine said error twice over and worked on the third try.
Post Reply Subscribe to Thread


Guest Quick Reply (no urls or BBcode)
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes