Remove All Ads from XDA

Need som help to end Froyo on Kaiser install

25 posts
Thanks Meter: 6
By bernie.discale, Junior Member on 20th February 2012, 11:06 AM
Post Reply Email Thread
Hello xda-kaiser-android community

My configuration is :
SDCARD with 4 partitions :
  1. FAT16 with Haret, zimage, inird, default.txt
  2. SYSTEM (ext2)
  3. DATA (ext2)
  4. swap

I've managed to launch Android, and the phones does work.
Unfortunately, at the moment, some other things does not work :
  • WIFI : fails when getting the IP (so I scan WIFI networks well, but there is a problemn when creating the network interface...)
  • Modem : does not work..
  • Camera : not very important for the moment, but can become more...
So, I wanted to dump log files and try, with the terminal, to guess what is happening, but I COULD NOT MANAGED to SU ROOT (as a Linux user, I don't feel comfortable when I cannont be root on my personnal machine)...

When launching the "SuperUser" program the Applist is empty ?
When I set suid and root:root ownership of /bin/su on the SYSTEM partition, when SD mounted on my computer, It is not preserved when used inside Android...
After some inspection of the init scripts (see here under), my question is :
WHY is it chowned to the user 1000:1000 ?

            # mount and set perms
            $BB mount -o noatime,nodiratime -t auto $PARTITION $SD_EXT_DIRECTORY;
            if [ "$?" = 0 ];
                $BB chown 1000:1000 $SD_EXT_DIRECTORY;
                $BB chmod 771 $SD_EXT_DIRECTORY;
                log -p i -t mountsd "$SD_EXT_DIRECTORY successfully mounted";
Thank you for your comments, any help will be appreciated
20th February 2012, 01:21 PM |#2  
OP Junior Member
Thanks Meter: 6
I overpost myself : My problem probably comes from the way I extracted the Froyo tarball to the SYSTEM partition...

I'll try again and inform you of my mistake.

20th February 2012, 01:48 PM |#3  
Ttblondey's Avatar
Senior Member
Thanks Meter: 105
why don't you try FAT32 instead of FAT16
The Following User Says Thank You to Ttblondey For This Useful Post: [ View ] Gift Ttblondey Ad-Free
23rd February 2012, 05:43 AM |#4  
n2rjt's Avatar
Senior Member
Flag San Diego, California
Thanks Meter: 103
Originally Posted by bernie.discale

I overpost myself : My problem probably comes from the way I extracted the Froyo tarball to the SYSTEM partition...

I'll try again and inform you of my mistake.


Don't extract the froyo tarball. Just place androidinstall.tgz and androidupdate.tgz into the SDCARD andboot folder. Then, after you boot linux, touch and hold the center of the screen, and an install menu will appear. Then select your partitions, install system (and format data partition), install updates, and fix permissions, then exit. Android should start. Be sure your kernel (zImage) and drivers (androidupdate.tgz) match, and it also helps for the initrd.lzma to match. When wifi doesn't work, that usually means the driver is mismatched.
The Following User Says Thank You to n2rjt For This Useful Post: [ View ] Gift n2rjt Ad-Free
26th February 2012, 11:24 AM |#5  
OP Junior Member
Thanks Meter: 6
Hi Guys

Thnk you for your answers.
I got a more urgent issue than porting my kaiser to android : I've been forced to move my laptop back to windows again ...
So I must know workaround to dual boot linux (and, believe me, this install of windows is not the standard one)..

But A soon as I can, I will try the install stuff.

thank you again
29th February 2012, 09:32 PM |#6  
OP Junior Member
Thanks Meter: 6
Heydiho !

Things get better...
I caught eu-froyo-odex and installed it as is after entering the installation menu (launched by init ?)... The su command is now working. I have to tackle a few things now :
  1. Wifi works even worse (now I clealry see an error, where, with the other distro, it was probably a permission issue)
  2. Screen has still odd behaviors
  3. Keymap issue with Keyboard arrows does not work in terminal
  4. And camera to be confirmed

I'll dig the forum for topics on these subjects and get back if I'm really stuck

Best regards
3rd March 2012, 02:09 PM |#7  
OP Junior Member
Thanks Meter: 6

Things goes in the good direction :
  1. Wifi is now ok (was not working with panel 1.. can this be correlated ?)
  2. Screen works better with panel 2, but I'am still not sure if mine is 2 or 3)
  3. Keymap Fixed : was only a matter of using bash insted of default busybox's shell
  4. camera is not working
  5. GPRS modem not working
  6. Battery consumption is high with system on sdcard

Stay tuned !
11th March 2012, 01:46 PM |#8  
PoXFreak's Avatar
Senior Member
Flag Apex NC
Thanks Meter: 852
Donate to Me
I am working on a couple of things, specifically a "build.prop" mod and adding a "gps.conf" file to /system/etc, which is just a list of AGPS servers and to fix some GPS issues.
The modded build.prop that I have reworked adds some dalvik cache lines and "sleep mode" lines, as our Kaisers don't have a sleep mode implemented.

Camera and GPRS can be associated with the radio rom installed. I found that on my specific device, radio allowed GPS and data to work smoothly, but I would lose the phone after the first call and camera had just a dark green screen. dropped GPRS but improved data speeds and allowed the phone to work as well as the camera.

YMMV but I would say wipe any trace of WM from that phone (support is ending this May) and go directly with Android via NAND install.
23rd March 2012, 02:35 PM |#9  
OP Junior Member
Thanks Meter: 6
Hello guys

I still have some habbits on my WM (freeOTFE encryption, contacts and some other stuffs) that are still working well on WM, and I don't feel very comfortable in switching on full Android (I mean on NAND) while I'am not very used to use Android... I would have definitely preferred to have a working platform booting from sdcard before flashing the NAND, but you confirmed that some issues may be linked to the SDCARD install...

I'm stuck since the beginning of march with the GPRS modem, and I don't clearly understand what are you talking about (have to check what you mean by radio).

My problem is, at the moment, that I don't have any mean to debug : is there a way to activate logs for users spaces programs ? Where to find em ?
If there is a better way to debug, what is it ?

As always, thank you, in advance, for any answer.
I'll try by myself a soon as I can (and, during the last weeks, it was not the case).
Best regards
23rd March 2012, 02:37 PM |#10  
OP Junior Member
Thanks Meter: 6
I will add, moreover, that I'am still not sure of my panel (2 or 3 !!!)

Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes