Remove All Ads from XDA

Volume Control headset

66 posts
Thanks Meter: 12
By jhonyrod, Member on 25th March 2012, 12:45 AM
Post Reply Email Thread
My stock headphones broke and I wanted a replacement, but a nice sounding ones.

Went to a local store, asked for a headset with remote and they showed me an Aiaiai Tracks (these have mic+volume control), but, as many of you may know, the "iPhone" headsets aren't compatible with the XPlay, and so I was getting an "Accessory not supported" error.

I researched a bit, and finally got a CTIA<->OMTP adapter, returned to the store and surprisingly the headset still not worked, I was no longer getting the error but no sound came from the headset, in fact, seemed like my phone didn't detect them since the music played trough the loudspeakers. Then asked an employee if they had a similar ones and gave me a Marshall Major (just mic and the central button), plugged with the adapter and worked just fine, the mic, the button...

Nevertheless I prefer the sound of the Tracks over the Major and I think that the only difference on their connections is the volume control since they are both "iPhone compatible".

Can anyone explain me how can I get them to work?, I don't mind if the volume buttons don't work, just as far as I can use the mic and the central button.
25th May 2012, 06:20 AM |#2  
OP Member
Flag Tlalnepantla, Edo. Mex.
Thanks Meter: 12
I think I got the answer
Well, I stumbled upon a fix from a Xperia Ray owner at the forums:
Originally Posted by Herbert

I also bought a Fiio LU2 Smart Adapter Cable, and I had it all packed up to return it, when I read a review on from a guy who said he taped down the button on his mic line and that made it work. So I tried holding down the in-line button on my headset, and voila, it a sense. Here is what I have and did:
Xperia Ray and Bose MIE2i headset. The headset alone gives the "Accessory not Supported" message. Headset with Fiio LU2 just plays through phone speakers.

  1. Plug headset into Fiio LU2 Smart Adapter Cable.
  2. Get a piece of audio (mp3 or whatever) ready on Ray.
  3. Hold Down the main button on the in-line headset controller and keep holding it down.
  4. Plug Fiio LU2 Smart Adapter Cable into Ray.
  5. Start audio on Ray for at least 5 seconds -it plays through headset-
  6. Release headset button.
  7. You can stop the audio if you wish. Headset will continue to function.
The audio and mic will function for me on my headset until I unplug it. I haven't tried powering the Ray all the way down, but the headset stays working even after waking from standby. None of the in-line headset controls will work for me.

The downside is that it appears that the central button won't work this way .
Also, I recently flashed an ICS rom, so I'm not sure if I still have this issue.
Once I get my adapter (lost the one I got earlier) I'll update this post, just in case anybody cared
Post Reply Subscribe to Thread

headphones, headset, in-line mic, remote, volume control

Guest Quick Reply (no urls or BBcode)
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes