Remove All Ads from XDA

[Q] RIP to my Sidekick

228 posts
Thanks Meter: 38
By eurohomie, Senior Member on 6th April 2012, 06:52 AM
Post Reply Email Thread
So today, as i was on my way to work I accidentally held down the lockscreen button and the power menu popped up (I was on Glorious Overdoes V2) in the middle of a text and i pressed reboot accidentally... My phone never rebooted... It was stuck on the black Sidekick 4G/T-Mobile screen and then it would go black, then once again that screen would pop up... I removed the battery and put it back in, and without me pressing any buttons the same screen came back up... I let it sit for a while and after 20minutes nothing changed except the phone got really hot. Luckily I had my OLD Nokia in my car and popped my SIM card in it so that i could continue having a phone. I let The Sidekick sit for 4hours and it was extremely hot and then eventually it just turned off completely (Im assuming the battery drained, it was at 90% 4 hours before.) I got home, plugged it in and it wouldn't even turn on the charging screen. Somebody told me that my Motherboard is fried but I don't know. I called T-mobile and they're going to send me a new phone since it's still in the 1-year warranty period.

Anyone know if they're going to be able to inspect my old device and find out if i rooted/flashed it? because i can't get into it or anything to ODIN
6th April 2012, 07:16 AM |#2  
d3xtro.'s Avatar
Thanks Meter: 23
I feel like they will try putting a new battery in it, and if it still wont turn on you should be fine.
6th April 2012, 09:31 AM |#3  
Jax184's Avatar
Senior Member
Flag Vancouver
Thanks Meter: 166
It got hot because the CPU was churning over something and couldn't enter a low power state. I bet you could coax the phone into download mode and reflash it.
7th April 2012, 07:59 AM |#4  
eurohomie's Avatar
OP Senior Member
Flag Houston
Thanks Meter: 38
what do you mean coax the phone into download mode? by using the button combo to get it into download mode when turning on? I've tried that and it doesn't work. I tried rebooting into recovery and that wont work either. Also, it wont charge the battery anymore...
7th April 2012, 12:14 PM |#5  
Jax184's Avatar
Senior Member
Flag Vancouver
Thanks Meter: 166
I've always had a hard time getting into download mode, and my phone works fine. I just spent 5 minutes trying different combinations until I got it.

I've heard people say trackpad-power button, volume down-home-power button, volume up/down-put battery in-plug in USB, etc etc etc. But the only method that works for me is to put in the battery, plug in the USB, wait for the charging screen, then hold volume down-trackpad-power, releasing power as soon as the screen goes black

You say your phone is turning on as soon as the battery is inserted? What if you have it plugged into USB first?
7th April 2012, 09:11 PM |#6  
Junior Member
Flag Round Rock
Thanks Meter: 2
I had the exact same problem, I sent it into samsung and they just replaced a part(never told me which one) and it was fixed. I did noticed that when the sccreen was poped open to show the keyboard, it would stop. But it's probably a loose cable like I've read before.

Sent from my SGH-T839 using Tapatalk
10th April 2012, 01:20 PM |#7  
Account currently disabled
Flag Springfield, Massachusetts
Thanks Meter: 75
Worst case scenario if you can't figure it out here on XDA, you could always sell it on eBay for parts as defective.
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes