Remove All Ads from XDA

[SOLVED]Flashing kernel for Miui 2.2.1, always getting "turn on Unknown Sources..."

62 posts
Thanks Meter: 3
By pef6000, Member on 17th April 2012, 06:38 PM
Post Reply Email Thread
Hey guys.

I'd like to flash my X10 Kernel with the ftf given with the Miui 2.2.1 rom. But the thing is, when I open flashtool, after doing all the steps and when I connect my phone to the computer, here is what I get :

17/007/2012 18:07:46 - INFO - Start Flashing
17/007/2012 18:07:46 - INFO - VER="R8A013";DATE="20100119";TIME="17:24:00";
17/007/2012 18:07:46 - INFO - Flashing loader
17/007/2012 18:07:46 - ERROR - Error flashing. Aborted
17/007/2012 18:07:46 - INFO - Now unplug the device and power it on
17/007/2012 18:07:46 - INFO - Then go to application settings
17/007/2012 18:07:46 - INFO - turn on Unknown Sources and Debugging

It is always turned on, both of them, so I went in, I turned them both off, then again one of them on, then the other one on, then again both on, nothing happens, it's always the same error message.

Somebody can help me please ?

Thanks !

Btw, I am on Miui 2.3.2 Cobrato
With baseband 2.1.71 & Kernel 2.6.29-zdzihu-mod4.05
And I have both CWM and xRecovery.
17th April 2012, 06:48 PM |#2  
Senior Member
Flag Honolulu
Thanks Meter: 108
Try doing the downgrade/upgrade method, flashing from stock, using a different USB cable, or a different computer. Those are the USUAL methods of solving this. After that, it gets tricky. GL!
The Following User Says Thank You to R1K05@N For This Useful Post: [ View ] Gift R1K05@N Ad-Free
17th April 2012, 06:57 PM |#3  
OP Member
Thanks Meter: 3
Thanks, I'll try it now !

EDIT : PC Companion tells me that there is an update (3.0.1.G..., the official 2.3.3 from Sony). If I do this update, will I have to install again xRecovery, CWM, root it, unlock bootloader, etc etc ?
17th April 2012, 07:10 PM |#4  
Senior Member
Flag Honolulu
Thanks Meter: 108
As far as I know, you don't have to update... as long as you have the phone drivers installed on the PC, you should be fine. Updating thru PC Companion or SEUS seems to be pretty much the same as loading a ROM (but official).

On the other hand, I actually updated my phones (two x10s) before unlocking the bootloaders and loading the custom roms on them but I also did full wipes (SD, system, everything through recovery) of them before loading up my current roms and had no issues whatsoever... but I did run into what you ran into when loading up my second phone (wife's) with Oodie Prime X MIUI... so I changed out he USB cord then everything went fine.
The Following User Says Thank You to R1K05@N For This Useful Post: [ View ] Gift R1K05@N Ad-Free
17th April 2012, 07:31 PM |#5  
OP Member
Thanks Meter: 3
So I tried with the charger's USB cable, it doesn't seem to change anything ...

Well, I'll downgrade it and try to start from the beginning.

Thank you

EDIT : Yeah it's done !

I made the update that SEMC wanted me to do, because I didn't know on which generic I should downgrade ^^'. So I did it, then I rooted it, unlocked bootloader, installed CWM, and installed the app from CWM

Thank you for your help !
Post Reply Subscribe to Thread

error turn on unknown debugging

Guest Quick Reply (no urls or BBcode)
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes