Remove All Ads from XDA
Honor View 10

[Q] wifi module problem with faux123 kernel-MB860

41 posts
Thanks Meter: 3
By kwick60073, Member on 21st April 2012, 09:49 PM
Post Reply Email Thread
I am trying an experiment with my Atrix in which I need to be able to build the kernel and have a working wifi module. I have successfully built the faux123's kernel-MB860 (thanks very much!).

I then downloaded faux123's atrix-wifi-module in order to get wifi working. I have built the module, and pushed it to /system/lib/modules. However, wifi doesn't work. Under settings, it just displays "error". dmesg doesn't show nearly as much as a kernel packaged by faux123. Here is my output:
<4>[   24.504982] sdhci_tegra_wlan_detect Detecting WLAN
<4>[   24.504998] mot_wifi_set_carddetect: Nobody to notify
<4>[   24.507937]
<4>[   24.507940] Dongle Host Driver, version
<4>[   24.507944] Compiled in /home/kenny/android/atrix-wifi-module/open-src/src/dhd/linux/../.. on Apr 17 2012 at 06:54:15
<6>[   24.724025] request_suspend_state: wakeup (3->0) at 13492036210 (2012-04-21 19:25:46.351491984 UTC)
<6>[   24.725196] lm3532_brightness_set: lcd-backlight, 0x4c(76), webtop=0
<7>[   25.088713] mmc1: queuing CIS tuple 0x91 length 3
<6>[   25.088824] mmc1: new SDIO card at address 0001
<6>[   25.534772] usb_ether_get_stats
Whereas, dmesg from a kernel/module packaged by faux123 displays:
[   49.811365] sdhci_tegra_wlan_detect Detecting WLAN
[   49.811403] mot_wifi_set_carddetect: Nobody to notify
[   49.812815]
[   49.812818] Dongle Host Driver, version
[   49.812822] Compiled in /home/paul/Froyo/system/vendor/bcm/wlan/osrc/open-src/src/dhd/linux/../.. on Dec 17 2011 at 19:58:57
[   50.108317] mmc1: queuing CIS tuple 0x91 length 3
[   50.108350] mmc1: new SDIO card at address 0001
[   50.136595] alloc static buf at e9980000!
[   50.136975] F1 signature read @0x18000000=0x9934329
[   50.139716] DHD: dongle ram size is set to 294912(orig 294912)
[   50.143537] wl_iw_attach thr:6d0 started
[   50.143598] wl_iw_bt_init thr:6d1 started
[   50.143655] dhd_attach thr:6d2 started
[   50.143706] dhd_attach thr:6d3 started
[   50.143749] dhd_attach thr:6d4 started
[   50.191722] dhdsdio_write_vars: Download, Upload and compare of NVRAM succeeded.
[   50.273753] wifi_get_mac_addr
[   50.274700] Firmware version = wl0: May  6 2011 13:09:01 version
[   50.442416] eth0: Broadcom Dongle Host Driver mac=40:fc:89:13:a8:83
If I try to do a insmod, I get an invalid argument message.
# insmod /system/lib/modules/dhd.ko
insmod: init_module '/system/lib/modules/dhd.ko' failed (Invalid argument)
Can someone suggest what I might be missing or doing wrong?
21st April 2012, 09:58 PM |#2  
dLo GSR's Avatar
Senior Member
Flag Los Angeles
Thanks Meter: 225
as far as i've researched this problem, it's hardware related. i get the same error (and an accompanying reboot) every time i try to toggle wifi.

if you have any more success please let me know.
21st April 2012, 11:16 PM |#3  
OP Member
Flag Gurnee, IL
Thanks Meter: 3
Donate to Me
Originally Posted by dLo GSR

as far as i've researched this problem, it's hardware related.

I'm not convinced it is hardware related (other than maybe having the wrong driver), since wifi works great using a true faux123 kernel/module.

I suspect my problem has something to do with how I compiled module or other files that I need to put on the phone.
22nd April 2012, 03:31 AM |#4  
Senior Member
Thanks Meter: 1,004
Donate to Me
How did you build it? A little more background might help
22nd April 2012, 05:40 AM |#5  
OP Member
Flag Gurnee, IL
Thanks Meter: 3
Donate to Me
Talking Build process ... it works!?!?
First, the good news...the module now works. But I don't understand what I may have done differently this time other than do the builds consecutively.

I retrieved the source:
$ cd ~/android/faux123-olympus-cm7-kernel
$ git clone
$ cd ~/android
$ git clone
Then I built:
$ cd ~/android/faux123-olympus-cm7-kernel/kernel-MB860
$ make ARCH=arm tegra_olympus_cm7_defconfig
$ make ARCH=arm CROSS_COMPILE=/home/kenny/tools/arm-2011.09/bin/arm-none-eabi- -j1

$ cd ../../atrix-wifi-module/open-src/src/dhd/linux/
$ export LINUXSRCDIR=/home/kenny/android/faux123-olympus-cm7-kernel/kernel-MB860
$ make ARCH=arm CROSS_COMPILE=~/tools/arm-2011.09/bin/arm-none-eabi- -j1
$  adb push /home/kenny/android/faux123-olympus-cm7-kernel/kernel-MB860/vendor/bcm/wlan/osrc/open-src/src/dhd/linux/dhd.ko /system/lib/modules/dhd.ko
I had kernel built a few days before I had found the wifi module source. I then tried building the wifi module and pushing the module as shown above.

Since then (over last week or so), I have tried a number of things, including copying files (/etc/firmware/wifi/*) from another phone which has a faux123 kernel. Are these files required? Are there steps in here that I missed?
Post Reply Subscribe to Thread

faux123, kernel, modules, wifi

Guest Quick Reply (no urls or BBcode)
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes