Remove All Ads from XDA

Problem with edited APK's - xpost from General

29 posts
Thanks Meter: 18
By Mark98, Junior Member on 23rd April 2012, 10:57 AM
Post Reply Email Thread
Hi all,

First of all, apologies for the xpost...

Question re: weird behaviour on APK files I've edited according to

I use a couple of apps regularly and have tried modifying them to make the UI suit me a bit better. For what it's worth, one's a Twitter app and one's a keyboard.

I've used apktool to decompile them, edited certain res .xml files to change the interface and then compiled them again with apktool. I've then signed them using Sigare (obviously it's not signed using the original developers key, but a key that I've made)

I've then replaced the apk in data\app with my modified one.

The problem is that, while the new app works for a little white, after a while it just disappears from my app list. When I go to run it directly, I get a message that the app won't load.

TL;DR: apps I've modified work to start with and then don't. Anyone think of a reason?
23rd April 2012, 08:27 PM |#2  
spirosbond's Avatar
Senior Member
Flag Thessaloniki
Thanks Meter: 665
Donate to Me
have you read this answer of mine?
23rd April 2012, 09:52 PM |#3  
OP Junior Member
Thanks Meter: 18
Originally Posted by spirosbond

have you read this answer of mine?

I did thanks. Giving it a go now
26th April 2012, 11:37 PM |#4  
OP Junior Member
Thanks Meter: 18
Arrow Problem with edited APK's (updated
I've tried a couple of things and got these edited APK's to install and work


Fire it up the next morning and find that the app crashes

Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes