Remove All Ads from XDA

host mode and power Supply - help!

164 posts
Thanks Meter: 9
By atlantisu21, Senior Member on 24th April 2012, 10:53 PM
Post Reply Email Thread
I Have:
Cyanogenmod 7.1 rom
Kernel: 2.6.37 cyanogen 7.x Kernel Patched with USB Host (from here)
Desire GSM phone
OTG cable
USB Y cable (to male and one female) - picture in attachment

And two problems!
The FIRST problem
This kernel enable host mode, when load command in terminal.
I typed command but, I have error:

I searching dev/bock but there is no sda1 or sdxx..

The SECOND problem
Maybe I have problem with power supply?
I tried to attach in computer port, usb flash drive lighting and copmuter recognize and open..
And I tried to attach to usb charger and nothing happen. Flash doesn't light...

Any help please!
Attached Thumbnails
Click image for larger version

Name:	IMG_20120424_234745.jpg
Views:	34
Size:	250.0 KB
ID:	1023061  
25th April 2012, 10:02 AM |#2  
Thanks Meter: 5
This looks to me as if you connected the cable wrong... usually the male connector with the two cables coming out is the one for data and the other one is the one for the power.
Try connecting your USB to Micro USB cable to the other male connector...
To be sure the cable is working correctly, try connecting the drive via your y-cable to a computer. That way it's easier to find out wether you are using the correct plugs. Also in this case, don't plug in the second male cable, b/c the computer USB port should already give you enough power.
25th April 2012, 11:24 PM |#3  
OP Senior Member
Flag Belgrade
Thanks Meter: 9
Finaly works!
Yes, you were right. I reverse usb male connection devices.

I loaded kernels again, but there is no sda in block folder.
So I used USB host controller app, and mount usb from here and works.
Picture in attachment.

But I don't know where is the path to my sda?
On this picture says sda4?

I tried this
HTML Code:
mount -t vfat /dev/block/sda4 /mnt/sdcard/mnt/
but have same error - no such file or directory
Attached Thumbnails
Click image for larger version

Name:	screenshot-1335390694607.jpg
Views:	24
Size:	34.4 KB
ID:	1024874  
26th April 2012, 10:40 PM |#4  
OP Senior Member
Flag Belgrade
Thanks Meter: 9
Ok, the first question sloved (almost)
Another question:

Where I can get power supply, maybe usb battery to give a power to flash drive?
I don't want a adapter or charger, I need portable usb power battery for traveling.
Anybody have idea where I get this?
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes